libraries/rxtx: Updated for version 2.2pre2.

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
David Spencer 2011-07-19 21:05:22 -03:00 committed by Robby Workman
parent 7bd2bdca98
commit 7e73a9b6ba
8 changed files with 308 additions and 135 deletions

View file

@ -1,9 +1,8 @@
RXTX is a Java library providing serial and parallel port communication.
Note: this is an obsolete version of RXTX intended for use with JMRI
(available at SlackBuilds.org). It is not necessarily suitable for use
with other applications.
To build RXTX requires the jdk package (available in Slackware's extra/
directory) and javacomm (available at SlackBuilds.org). To run RXTX
requires javacomm but not jdk.
directory).
If you are upgrading from rxtx-2.0_7pre2, please note that the javacomm
package is no longer required and should be uninstalled before building
rxtx-2.2pre2.

View file

@ -0,0 +1,20 @@
--- rxtx-2.2pre2_original/Makefile.in 2008-12-31 02:29:12.000000000 +0000
+++ rxtx-2.2pre2_patched/Makefile.in 2009-12-21 12:34:37.099017471 +0000
@@ -619,13 +619,15 @@
# install librxtxSerial.so into the proper directory and copy $(JARTARGET) to its
# proper location
install: all
+ $(INSTALL_PROGRAM) -d $(DESTDIR)$(RXTX_PATH)
@$(LIBTOOL_INST) \
`for i in $(TARGETLIB);do \
if [ -f $$i ];then \
echo $$i; \
fi; \
- done` $(RXTX_PATH)
- $(INSTALL_PROGRAM) $(JARTARGET) $(JHOME)/
+ done` $(DESTDIR)$(RXTX_PATH)
+ $(INSTALL_PROGRAM) -d $(DESTDIR)$(JHOME)
+ $(INSTALL_DATA) $(JARTARGET) $(DESTDIR)$(JHOME)/
clean-generic:
rm -rf $(DEST) $(TOP)/$(CLASSTOP)

View file

@ -0,0 +1,205 @@
? im-20090910.patch
Index: I2CImp.c
===================================================================
RCS file: /var/cvs/cvsroot/rxtx-devel/src/Attic/I2CImp.c,v
retrieving revision 1.1.2.12
diff -u -p -r1.1.2.12 I2CImp.c
--- I2CImp.c 26 Apr 2007 05:26:05 -0000 1.1.2.12
+++ I2CImp.c 10 Sep 2009 05:24:55 -0000
@@ -1,7 +1,7 @@
/*-------------------------------------------------------------------------
| RXTX License v 2.1 - LGPL v 2.1 + Linking Over Controlled Interface.
| RXTX is a native interface to serial ports in java.
-| Copyright 1997-2007 by Trent Jarvi tjarvi@qbang.org and others who
+| Copyright 1997-2009 by Trent Jarvi tjarvi@qbang.org and others who
| actually wrote it. See individual source files for more information.
|
| A copy of the LGPL v 2.1 may be found at
@@ -113,7 +113,9 @@ JNIEXPORT void JNICALL Java_gnu_io_I2CPo
)
{
#ifndef WIN32
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
struct utsname name;
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
/* This bit of code checks to see if there is a signal handler installed
for SIGIO, and installs SIG_IGN if there is not. This is necessary
for the native threads jdk, but we don't want to do it with green
@@ -125,7 +127,7 @@ JNIEXPORT void JNICALL Java_gnu_io_I2CPo
sigaction( SIGIO, NULL, &handler );
if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
#endif /* !__FreeBSD__ */
-#if defined(__linux__)
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{
@@ -137,7 +139,7 @@ JNIEXPORT void JNICALL Java_gnu_io_I2CPo
fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
getchar();
}
-#endif /* __linux__ */
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
#endif /* WIN32 */
}
Index: RS485Imp.c
===================================================================
RCS file: /var/cvs/cvsroot/rxtx-devel/src/Attic/RS485Imp.c,v
retrieving revision 1.1.2.12
diff -u -p -r1.1.2.12 RS485Imp.c
--- RS485Imp.c 26 Apr 2007 05:26:05 -0000 1.1.2.12
+++ RS485Imp.c 10 Sep 2009 05:24:55 -0000
@@ -1,7 +1,7 @@
/*-------------------------------------------------------------------------
| RXTX License v 2.1 - LGPL v 2.1 + Linking Over Controlled Interface.
| RXTX is a native interface to serial ports in java.
-| Copyright 1997-2007 by Trent Jarvi tjarvi@qbang.org and others who
+| Copyright 1997-2009 by Trent Jarvi tjarvi@qbang.org and others who
| actually wrote it. See individual source files for more information.
|
| A copy of the LGPL v 2.1 may be found at
@@ -113,7 +113,9 @@ JNIEXPORT void JNICALL Java_gnu_io_RS485
)
{
#ifndef WIN32
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
struct utsname name;
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
/* This bit of code checks to see if there is a signal handler installed
for SIGIO, and installs SIG_IGN if there is not. This is necessary
for the native threads jdk, but we don't want to do it with green
@@ -125,7 +127,7 @@ JNIEXPORT void JNICALL Java_gnu_io_RS485
sigaction( SIGIO, NULL, &handler );
if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
#endif /* !__FreeBSD__ */
-#if defined(__linux__)
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{
@@ -137,7 +139,7 @@ JNIEXPORT void JNICALL Java_gnu_io_RS485
fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
getchar();
}
-#endif /* __linux__ */
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
#endif /* WIN32 */
}
Index: RawImp.c
===================================================================
RCS file: /var/cvs/cvsroot/rxtx-devel/src/Attic/RawImp.c,v
retrieving revision 1.1.2.12
diff -u -p -r1.1.2.12 RawImp.c
--- RawImp.c 18 Nov 2007 22:32:42 -0000 1.1.2.12
+++ RawImp.c 10 Sep 2009 05:24:55 -0000
@@ -6,7 +6,7 @@
/*-------------------------------------------------------------------------
| RXTX License v 2.1 - LGPL v 2.1 + Linking Over Controlled Interface.
| RXTX is a native interface to serial ports in java.
-| Copyright 1997-2007 by Trent Jarvi tjarvi@qbang.org and others who
+| Copyright 1997-2009 by Trent Jarvi tjarvi@qbang.org and others who
| actually wrote it. See individual source files for more information.
|
| A copy of the LGPL v 2.1 may be found at
@@ -258,7 +258,9 @@ JNIEXPORT void JNICALL Java_gnu_io_RawPo
)
{
#ifndef WIN32
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
struct utsname name;
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
/* This bit of code checks to see if there is a signal handler installed
for SIGIO, and installs SIG_IGN if there is not. This is necessary
for the native threads jdk, but we don't want to do it with green
@@ -270,7 +272,7 @@ JNIEXPORT void JNICALL Java_gnu_io_RawPo
sigaction( SIGIO, NULL, &handler );
if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
#endif /* !__FreeBSD__ */
-#if defined(__linux__)
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{
@@ -282,7 +284,7 @@ JNIEXPORT void JNICALL Java_gnu_io_RawPo
fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
getchar();
}
-#endif /* __linux__ */
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
#endif /* WIN32 */
}
Index: SerialImp.c
===================================================================
RCS file: /var/cvs/cvsroot/rxtx-devel/src/SerialImp.c,v
retrieving revision 1.46.2.204
diff -u -p -r1.46.2.204 SerialImp.c
--- SerialImp.c 10 Sep 2009 05:04:21 -0000 1.46.2.204
+++ SerialImp.c 10 Sep 2009 05:24:56 -0000
@@ -279,10 +279,10 @@ JNIEXPORT void JNICALL RXTXPort(Initiali
jclass jclazz
)
{
-#if defined DEBUG && defined(__linux__)
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
struct utsname name;
char message[80];
-#endif /* DEBUG && __linux__ */
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
/* This bit of code checks to see if there is a signal handler installed
for SIGIO, and installs SIG_IGN if there is not. This is necessary
for the native threads jdk, but we don't want to do it with green
@@ -318,7 +318,7 @@ JNIEXPORT void JNICALL RXTXPort(Initiali
#if DEBUG_TIMING
gettimeofday(&seloop, NULL);
#endif /* DEBUG_TIMING */
-#if defined(DEBUG) && defined(__linux__)
+#if defined(DEBUG) && defined(__linux__) && defined(UTS_RELEASE)
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{
@@ -334,7 +334,7 @@ JNIEXPORT void JNICALL RXTXPort(Initiali
getchar();
}
LEAVE( "RXTXPort:Initialize" );
-#endif /* DEBUG && __linux__ */
+#endif /* DEBUG && __linux__ && UTS_RELEASE */
}
/*----------------------------------------------------------
Index: SerialImp.cpp
===================================================================
RCS file: /var/cvs/cvsroot/rxtx-devel/src/SerialImp.cpp,v
retrieving revision 1.1.2.10
diff -u -p -r1.1.2.10 SerialImp.cpp
--- SerialImp.cpp 26 Apr 2007 05:26:06 -0000 1.1.2.10
+++ SerialImp.cpp 10 Sep 2009 05:24:57 -0000
@@ -1,7 +1,7 @@
/*-------------------------------------------------------------------------
| RXTX License v 2.1 - LGPL v 2.1 + Linking Over Controlled Interface.
| RXTX is a native interface to serial ports in java.
-| Copyright 1997-2007 by Trent Jarvi tjarvi@qbang.org and others who
+| Copyright 1997-2009 by Trent Jarvi tjarvi@qbang.org and others who
| actually wrote it. See individual source files for more information.
|
| A copy of the LGPL v 2.1 may be found at
@@ -126,7 +126,7 @@ JNIEXPORT void JNICALL RXTXPort(Initiali
#ifndef WIN32
#ifndef __BEOS__
-#ifdef DEBUG
+#if defined(DEBUG) && defined (UTS_RELEASE)
struct utsname name;
#endif
/* This bit of code checks to see if there is a signal handler installed
@@ -140,7 +140,7 @@ JNIEXPORT void JNICALL RXTXPort(Initiali
sigaction( SIGIO, NULL, &handler );
if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
#endif /* !__FreeBSD__ */
-#ifdef DEBUG
+#if defined(DEBUG) && defined (UTS_RELEASE)
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{

View file

@ -1,22 +1,35 @@
#!/bin/sh
# Slackware build script for rxtx
# Written by David Spencer <nobbutl@yahoo.co.uk>
# This script is dedicated to the public domain
# Copyright 2011 David Spencer, Baildon, West Yorkshire, U.K.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=rxtx
VERSION=2.0_7pre2
BUILD=${BUILD:-2}
VERSION=${VERSION:-2.2pre2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCVER=$(echo $VERSION | sed 's/_/-/')
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@ -54,9 +67,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$SRCVER
tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
cd $PRGNAM-$SRCVER
rm -rf $PRGNAM-$VERSION
unzip $CWD/$PRGNAM-$VERSION.zip
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -64,13 +77,20 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Patch JDK and kernel version tests, and add DESTDIR support
cat $CWD/rxtx.patch | patch -p1
# Disable obsolete UTS_RELEASE check
# http://mailman.qbang.org/pipermail/rxtx/2009-September/5399616.html
patch -d src <$CWD/im-20090910.patch
# Enumerate all serial ports (notably ttyACM*)
# http://git.debian.org/?p=pkg-java/rxtx.git;a=commit;h=3302001ca24b671e75d43c9febd771e709a759e7
patch -p1 <$CWD/ttyACM_port.patch
# Add DESTDIR support to 'make install'
patch -p1 <$CWD/destdir.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--libdir=/usr/lib${LIBDIRSUFFIX}
--libdir=/usr/lib${LIBDIRSUFFIX} \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
@ -78,14 +98,9 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/$JAVA_HOME/lib/
cat << EOF > $PKG/$JAVA_HOME/lib/javax.comm.properties
Driver=gnu.io.RXTXCommDriver
EOF
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING ChangeLog INSTALL PORTING README README.JRE \
AUTHORS COPYING ChangeLog INSTALL PORTING README \
SerialPortInstructions.txt TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View file

@ -1,10 +1,10 @@
PRGNAM="rxtx"
VERSION="2.0_7pre2"
HOMEPAGE="http://users.frii.com/jarvi/rxtx/"
DOWNLOAD="ftp://jarvi.dsl.frii.com/pub/rxtx/rxtx-2.0-7pre2.tar.gz"
MD5SUM="43127b18cb2e06684100b400d4b8263e"
VERSION="2.2pre2"
HOMEPAGE="http://rxtx.qbang.org/wiki"
DOWNLOAD="http://rxtx.qbang.org/pub/rxtx/rxtx-2.2pre2.zip"
MD5SUM="7eedb18e3f33a427e2b0e9be8ce3f94c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="David Spencer"
EMAIL="nobbutl@yahoo.co.uk"
APPROVED="dsomero"
EMAIL="baildon.research@googlemail.com"
APPROVED="Niels Horn"

View file

@ -1,94 +0,0 @@
diff -u -r rxtx-2.0-7pre2_original/Makefile.in rxtx-2.0-7pre2_patched/Makefile.in
--- rxtx-2.0-7pre2_original/Makefile.in 2004-04-15 08:07:57.000000000 +0100
+++ rxtx-2.0-7pre2_patched/Makefile.in 2009-02-21 16:46:13.000000000 +0000
@@ -442,13 +442,15 @@
# install librxtxSerial.so into the proper directory and copy $(JARTARGET) to its
# proper location
install: all
+ $(INSTALL_PROGRAM) -d $(DESTDIR)$(RXTX_PATH)
@$(LIBTOOL_INST) \
`for i in $(TARGETLIB);do \
if [ -f $$i ];then \
echo $$i; \
fi; \
- done` $(RXTX_PATH)
- $(INSTALL_PROGRAM) $(JARTARGET) $(JHOME)/
+ done` $(DESTDIR)$(RXTX_PATH)
+ $(INSTALL_PROGRAM) -d $(DESTDIR)$(JHOME)
+ $(INSTALL_DATA) $(JARTARGET) $(DESTDIR)$(JHOME)/
clean-generic:
rm -rf $(DEST) $(TOP)/$(CLASSTOP)
diff -u -r rxtx-2.0-7pre2_original/configure rxtx-2.0-7pre2_patched/configure
--- rxtx-2.0-7pre2_original/configure 2005-01-17 18:52:47.000000000 +0000
+++ rxtx-2.0-7pre2_patched/configure 2009-02-21 16:46:53.000000000 +0000
@@ -10066,10 +10066,10 @@
fi
if test -d $JPATH/share/kaffe/
then fix_comm_jar $JPATH/share/kaffe/comm.jar
-elif test -d $JPATH/jre/lib/ext
- then fix_comm_jar $JPATH/jre/lib/ext/comm.jar
elif test -d $JPATH/lib/ext
then fix_comm_jar $JPATH/lib/ext/comm.jar
+elif test -d $JPATH/jre/lib/ext
+ then fix_comm_jar $JPATH/jre/lib/ext/comm.jar
elif test -d $JPATH/lib
then fix_comm_jar $JPATH/lib/comm.jar
fi
@@ -10079,13 +10079,16 @@
case $OS_NAME in
Linux)
LDFLAGS=-lpthread
- check_kernel_headers
check_java_headers
CFLAGS=$CFLAGS" -D__need_timespec"
case $JAVA_VERSION in
+ 1.6*)
+ CLASSPATH=".:\$(TOP):\$(TOP)/src:"`find $JPATH/ -name comm.jar |head -n1`
+ JHOME=$JPATH"/lib/ext"
+ RXTX_PATH="\$(JPATH)/lib/\$(OS_ARCH)"
+ ;;
1.2*|1.3*|1.4*|1.5*)
- fix_parameters $JPATH/jre/lib/javax.comm.properties
CLASSPATH=".:\$(TOP):\$(TOP)/src:"`find $JPATH/ -name comm.jar |head -n1`
JHOME=$JPATH"/jre/lib/ext"
RXTX_PATH="\$(JPATH)/jre/lib/\$(OS_ARCH)"
diff -u -r rxtx-2.0-7pre2_original/src/SerialImp.c rxtx-2.0-7pre2_patched/src/SerialImp.c
--- rxtx-2.0-7pre2_original/src/SerialImp.c 2005-01-17 17:48:41.000000000 +0000
+++ rxtx-2.0-7pre2_patched/src/SerialImp.c 2009-02-21 16:46:13.000000000 +0000
@@ -295,6 +295,7 @@
gettimeofday (&seloop, NULL);
#endif /* DEBUG_TIMING */
#if defined(DEBUG) && defined(__linux__)
+#if 0
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{
@@ -310,6 +311,7 @@
getchar ();
}
LEAVE ("RXTXPort:Initialize");
+#endif
#endif /* DEBUG && __linux__ */
}
diff -u -r rxtx-2.0-7pre2_original/src/SerialImp.cpp rxtx-2.0-7pre2_patched/src/SerialImp.cpp
--- rxtx-2.0-7pre2_original/src/SerialImp.cpp 2003-10-17 11:11:08.000000000 +0100
+++ rxtx-2.0-7pre2_patched/src/SerialImp.cpp 2009-02-21 16:46:13.000000000 +0000
@@ -130,6 +130,7 @@
if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
#endif /* !__FreeBSD__ */
#ifdef DEBUG
+#if 0
/* Lets let people who upgraded kernels know they may have problems */
if (uname (&name) == -1)
{
@@ -142,6 +143,7 @@
name.release);
getchar();
}
+#endif
#endif /* DEBUG */
#endif /* __BEOS__ */
#endif /* WIN32 */

View file

@ -1,12 +1,12 @@
|-----handy-ruler------------------------------------------------------|
rxtx: rxtx (Java library for serial and parallel communication)
rxtx:
rxtx: RXTX is a Java library providing serial and parallel communication
rxtx:
rxtx: RXTX is a Java library providing serial and parallel communication
rxtx: for the Java Development Toolkit (JDK).
rxtx:
rxtx: Homepage: http://users.frii.com/jarvi/rxtx/
rxtx:
rxtx:
rxtx:
rxtx:
rxtx:
rxtx:
rxtx: Homepage: http://rxtx.qbang.org/wiki
rxtx:
rxtx:
rxtx:
rxtx:
rxtx:

View file

@ -0,0 +1,28 @@
Description: Allows for the enumeration of many additional ports, including ttyACM for Arduino Unos
Author: Scott Howard <showard314@gmail.com>
Index: rxtx/src/gnu/io/RXTXCommDriver.java
===================================================================
--- rxtx.orig/src/gnu/io/RXTXCommDriver.java 2010-10-04 23:14:47.236148507 -0400
+++ rxtx/src/gnu/io/RXTXCommDriver.java 2010-10-04 23:18:56.976108303 -0400
@@ -574,20 +574,7 @@
if(osName.equals("Linux"))
{
String[] Temp = {
- "ttyS", // linux Serial Ports
"ttySA", // for the IPAQs
- "ttyUSB", // for USB frobs
- "rfcomm", // bluetooth serial device
- "ttyircomm", // linux IrCommdevices (IrDA serial emu)
- };
- CandidatePortPrefixes=Temp;
- }
- else if(osName.equals("Linux-all-ports"))
- {
- /* if you want to enumerate all ports ~5000
- possible, then replace the above with this
- */
- String[] Temp = {
"comx", // linux COMMX synchronous serial card
"holter", // custom card for heart monitoring
"modem", // linux symbolic link to modem.