games/meandmyshadow: Patched for gcc-4.7.

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
Larry Hajali 2012-08-01 08:34:54 -03:00 committed by Robby Workman
parent c8bf3c668c
commit 7db66fdb9b
3 changed files with 19 additions and 2 deletions

View file

@ -0,0 +1,14 @@
diff -Naur meandmyshadow-0.3.orig/src/TreeStorageNode.cpp meandmyshadow-0.3/src/TreeStorageNode.cpp
--- meandmyshadow-0.3.orig/src/TreeStorageNode.cpp 2012-02-07 18:19:03.000000000 +0000
+++ meandmyshadow-0.3/src/TreeStorageNode.cpp 2012-07-11 02:17:49.188110565 +0000
@@ -17,6 +17,10 @@
**
****************************************************************************/
+#ifndef WIN32
+#include <stdint.h>
+#include <unistd.h>
+#endif
#include "TreeStorageNode.h"
#include "MD5.h"
#include <string.h>

View file

@ -6,7 +6,7 @@
PRGNAM=meandmyshadow
VERSION=${VERSION:-0.3}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -57,6 +57,9 @@ sed -i -e '/^Version/d' -e 's|;Game;|;|' meandmyshadow.desktop
# SLKCFLAGS are respected.
sed -i "s|-Wall -g|& $SLKCFLAGS|" CMakeLists.txt
# From upstream. Fix for building with gcc 4.7.x.
patch -p1 < $CWD/gcc-4.7.patch
mkdir -p build
cd build
cmake -G "Unix Makefiles" \

View file

@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
APPROVED="dsomero"
APPROVED="dsomero,Niels Horn"