mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
graphics/aeskulap: Removed (no longer built and abandoned).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
d8a4520dfe
commit
7b5a4afdae
7 changed files with 0 additions and 462 deletions
|
@ -1,6 +0,0 @@
|
|||
Aeskulap is a medical image viewer.
|
||||
It is able to load a series of special images stored in the DICOM
|
||||
format for review. Additionally Aeskulap is able to query and fetch
|
||||
DICOM images from archive nodes (also called PACS) over the network.
|
||||
The goal of this project is to create a full open source replacement
|
||||
for commercially available DICOM viewers.
|
|
@ -1,22 +0,0 @@
|
|||
diff -urp aeskulap-0.2.2-beta1//configuration/aconfiguration-gconf.cpp aeskulap-0.2.2-beta1.new//configuration/aconfiguration-gconf.cpp
|
||||
--- aeskulap-0.2.2-beta1//configuration/aconfiguration-gconf.cpp 2007-05-10 18:44:00.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1.new//configuration/aconfiguration-gconf.cpp 2011-08-08 19:58:17.986000024 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
|
||||
#include <gconfmm.h>
|
||||
#include <iostream>
|
||||
+#include <cstdio>
|
||||
|
||||
namespace Aeskulap {
|
||||
|
||||
diff -urp aeskulap-0.2.2-beta1//configure.in aeskulap-0.2.2-beta1.new//configure.in
|
||||
--- aeskulap-0.2.2-beta1//configure.in 2007-05-24 20:59:09.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1.new//configure.in 2011-08-09 15:36:37.598000023 +0200
|
||||
@@ -166,6 +166,6 @@ if test x"$MINGW32" = xno ; then
|
||||
cd $srcdir/dcmtk
|
||||
export CFLAGS="$CFLAGS"
|
||||
export CXXFLAGS="$CXXFLAGS"
|
||||
-sh ./configure --without-openssl --without-zlib --without-libwrap --prefix=${prefix} --libdir=${prefix}/lib/aeskulap
|
||||
+sh ./configure --without-openssl --without-zlib --without-libwrap --prefix=${prefix} --libdir=${libdir}/aeskulap --sysconfdir=${sysconfdir} --localstatedir=${localstatedir} --mandir=${mandir}
|
||||
|
||||
fi
|
|
@ -1,114 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for aeskulap
|
||||
|
||||
# Copyright 2011 Federico Lupi, flupi@mclink.it, http://www.mclink.it/personal/MG2508
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=aeskulap
|
||||
VERSION=0.2.2_beta1
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
SRCVER=$(printf $VERSION | tr _ -)
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$SRCVER
|
||||
tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
|
||||
cd $PRGNAM-$SRCVER
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix missing #include and libdir for 64 bit
|
||||
patch -p1 < $CWD/$PRGNAM-$SRCVER.patch || exit 1
|
||||
|
||||
# Fix for gcc-4.7.x
|
||||
patch -p1 < $CWD/gcc47.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
ABOUT-NLS COPYING COPYING.DCMTK COPYING.LIB ChangeLog INSTALL README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
cat $CWD/$PRGNAM-$SRCVER.patch > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-$SRCVER.patch
|
||||
mv $PKG/usr/share/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rmdir $PKG/usr/share/doc
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="aeskulap"
|
||||
VERSION="0.2.2_beta1"
|
||||
HOMEPAGE="http://aeskulap.nongnu.org/"
|
||||
DOWNLOAD="http://ponce.cc/slackware/sources/repo/aeskulap-0.2.2-beta1.tar.gz"
|
||||
MD5SUM="33a0f8659909426c67bebc10bd61b1d0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="gconfmm libglademm"
|
||||
MAINTAINER="Federico Lupi"
|
||||
EMAIL="flupi@mclink.it"
|
|
@ -1,19 +0,0 @@
|
|||
schema_install() {
|
||||
SCHEMA="$1"
|
||||
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
|
||||
chroot . gconftool-2 --makefile-install-rule \
|
||||
/etc/gconf/schemas/$SCHEMA \
|
||||
1>/dev/null
|
||||
}
|
||||
|
||||
schema_install aeskulap.schemas
|
||||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
|
@ -1,272 +0,0 @@
|
|||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diargpxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diargpxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diargpxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diargpxt.h 2012-09-25 20:11:29.881757648 +0200
|
||||
@@ -95,7 +95,7 @@
|
||||
const unsigned long planeSize,
|
||||
const int bits)
|
||||
{ // not very much optimized, but no one really uses ARGB !!
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
register T2 value;
|
||||
const T1 offset = OFstatic_cast(T1, DicomImageClass::maxval(bits - 1));
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicmypxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicmypxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicmypxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicmypxt.h 2012-09-25 20:14:32.593745320 +0200
|
||||
@@ -91,7 +91,7 @@
|
||||
const unsigned long planeSize,
|
||||
const int bits)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
// use the number of input pixels derived from the length of the 'PixelData'
|
||||
// attribute), but not more than the size of the intermediate buffer
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicocpt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicocpt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicocpt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicocpt.h 2012-09-25 20:07:57.968771948 +0200
|
||||
@@ -90,7 +90,7 @@
|
||||
inline void copy(const T *pixel[3],
|
||||
const unsigned long offset)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
for (int j = 0; j < 3; j++)
|
||||
OFBitmanipTemplate<T>::copyMem(pixel[j] + offset, this->Data[j], this->getCount());
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicoflt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicoflt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicoflt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicoflt.h 2012-09-25 20:06:58.548775958 +0200
|
||||
@@ -107,14 +107,14 @@
|
||||
const int horz,
|
||||
const int vert)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
if (horz && vert)
|
||||
- flipHorzVert(pixel, this->Data);
|
||||
+ this->flipHorzVert(pixel, this->Data);
|
||||
else if (horz)
|
||||
- flipHorz(pixel, this->Data);
|
||||
+ this->flipHorz(pixel, this->Data);
|
||||
else if (vert)
|
||||
- flipVert(pixel, this->Data);
|
||||
+ this->flipVert(pixel, this->Data);
|
||||
}
|
||||
}
|
||||
};
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicorot.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicorot.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicorot.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicorot.h 2012-09-25 20:05:34.961781601 +0200
|
||||
@@ -107,14 +107,14 @@
|
||||
inline void rotate(const T *pixel[3],
|
||||
const int degree)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
if (degree == 90)
|
||||
- rotateRight(pixel, this->Data);
|
||||
+ this->rotateRight(pixel, this->Data);
|
||||
else if (degree == 180)
|
||||
- rotateTopDown(pixel, this->Data);
|
||||
+ this->rotateTopDown(pixel, this->Data);
|
||||
else if (degree == 270)
|
||||
- rotateLeft(pixel, this->Data);
|
||||
+ this->rotateLeft(pixel, this->Data);
|
||||
}
|
||||
}
|
||||
};
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicosct.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicosct.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dicosct.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dicosct.h 2012-09-25 20:07:14.648774873 +0200
|
||||
@@ -116,8 +116,8 @@
|
||||
inline void scale(const T *pixel[3],
|
||||
const int interpolate)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
- scaleData(pixel, this->Data, interpolate);
|
||||
+ if (this->Init(pixel))
|
||||
+ this->scaleData(pixel, this->Data, interpolate);
|
||||
}
|
||||
};
|
||||
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dihsvpxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dihsvpxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dihsvpxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dihsvpxt.h 2012-09-25 20:18:17.936730111 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
const unsigned long planeSize,
|
||||
const int bits)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
register T2 *r = this->Data[0];
|
||||
register T2 *g = this->Data[1];
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dipalpxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dipalpxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dipalpxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dipalpxt.h 2012-09-25 20:22:18.771713860 +0200
|
||||
@@ -103,7 +103,7 @@
|
||||
void convert(const T1 *pixel,
|
||||
DiLookupTable *palette[3])
|
||||
{ // can be optimized if necessary !
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
register const T1 *p = pixel;
|
||||
register T2 value = 0;
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dirgbpxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dirgbpxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/dirgbpxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/dirgbpxt.h 2012-09-25 21:11:27.952514832 +0200
|
||||
@@ -91,7 +91,7 @@
|
||||
const unsigned long planeSize,
|
||||
const int bits)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
// use the number of input pixels derived from the length of the 'PixelData'
|
||||
// attribute), but not more than the size of the intermediate buffer
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diybrpxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diybrpxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diybrpxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diybrpxt.h 2012-09-25 21:18:03.026488172 +0200
|
||||
@@ -96,7 +96,7 @@
|
||||
const int bits,
|
||||
const OFBool rgb)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
const T1 offset = OFstatic_cast(T1, DicomImageClass::maxval(bits - 1));
|
||||
// use the number of input pixels derived from the length of the 'PixelData'
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diyf2pxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diyf2pxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diyf2pxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diyf2pxt.h 2012-09-25 21:27:04.284451644 +0200
|
||||
@@ -105,7 +105,7 @@
|
||||
const int bits,
|
||||
const OFBool rgb)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
const T1 offset = OFstatic_cast(T1, DicomImageClass::maxval(bits - 1));
|
||||
register unsigned long i;
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diyp2pxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diyp2pxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimage/include/dcmtk/dcmimage/diyp2pxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimage/include/dcmtk/dcmimage/diyp2pxt.h 2012-09-25 21:30:20.158438426 +0200
|
||||
@@ -101,7 +101,7 @@
|
||||
void convert(const T1 *pixel,
|
||||
const int bits)
|
||||
{
|
||||
- if (Init(pixel))
|
||||
+ if (this->Init(pixel))
|
||||
{
|
||||
register T2 *r = this->Data[0];
|
||||
register T2 *g = this->Data[1];
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/diflipt.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/diflipt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/diflipt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/diflipt.h 2012-09-25 19:59:57.991804341 +0200
|
||||
@@ -139,7 +139,7 @@
|
||||
else if (vert)
|
||||
flipVert(src, dest);
|
||||
else
|
||||
- copyPixel(src, dest);
|
||||
+ this->copyPixel(src, dest);
|
||||
}
|
||||
}
|
||||
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoflt.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoflt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoflt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoflt.h 2012-09-25 19:54:07.636827983 +0200
|
||||
@@ -114,11 +114,11 @@
|
||||
if (this->Data != NULL)
|
||||
{
|
||||
if (horz && vert)
|
||||
- flipHorzVert(&pixel, &this->Data);
|
||||
+ this->flipHorzVert(&pixel, &this->Data);
|
||||
else if (horz)
|
||||
- flipHorz(&pixel, &this->Data);
|
||||
+ this->flipHorz(&pixel, &this->Data);
|
||||
else if (vert)
|
||||
- flipVert(&pixel, &this->Data);
|
||||
+ this->flipVert(&pixel, &this->Data);
|
||||
}
|
||||
}
|
||||
}
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h 2012-09-25 19:52:42.383833738 +0200
|
||||
@@ -79,10 +79,10 @@
|
||||
else if ((this->Modality != NULL) && this->Modality->hasRescaling())
|
||||
{
|
||||
rescale(pixel, this->Modality->getRescaleSlope(), this->Modality->getRescaleIntercept());
|
||||
- determineMinMax(OFstatic_cast(T3, this->Modality->getMinValue()), OFstatic_cast(T3, this->Modality->getMaxValue()));
|
||||
+ this->determineMinMax(OFstatic_cast(T3, this->Modality->getMinValue()), OFstatic_cast(T3, this->Modality->getMaxValue()));
|
||||
} else {
|
||||
rescale(pixel); // "copy" or reference pixel data
|
||||
- determineMinMax(OFstatic_cast(T3, this->Modality->getMinValue()), OFstatic_cast(T3, this->Modality->getMaxValue()));
|
||||
+ this->determineMinMax(OFstatic_cast(T3, this->Modality->getMinValue()), OFstatic_cast(T3, this->Modality->getMaxValue()));
|
||||
}
|
||||
}
|
||||
}
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimorot.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimorot.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimorot.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimorot.h 2012-09-25 19:54:35.497826106 +0200
|
||||
@@ -114,11 +114,11 @@
|
||||
if (this->Data != NULL)
|
||||
{
|
||||
if (degree == 90)
|
||||
- rotateRight(&pixel, &(this->Data));
|
||||
+ this->rotateRight(&pixel, &(this->Data));
|
||||
else if (degree == 180)
|
||||
- rotateTopDown(&pixel, &(this->Data));
|
||||
+ this->rotateTopDown(&pixel, &(this->Data));
|
||||
else if (degree == 270)
|
||||
- rotateLeft(&pixel, &(this->Data));
|
||||
+ this->rotateLeft(&pixel, &(this->Data));
|
||||
}
|
||||
}
|
||||
}
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimosct.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimosct.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimosct.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dimosct.h 2012-09-25 19:52:51.411833127 +0200
|
||||
@@ -130,7 +130,7 @@
|
||||
{
|
||||
const T value = OFstatic_cast(T, OFstatic_cast(double, DicomImageClass::maxval(bits)) *
|
||||
OFstatic_cast(double, pvalue) / OFstatic_cast(double, DicomImageClass::maxval(WIDTH_OF_PVALUES)));
|
||||
- scaleData(&pixel, &this->Data, interpolate, value);
|
||||
+ this->scaleData(&pixel, &this->Data, interpolate, value);
|
||||
}
|
||||
}
|
||||
}
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dirotat.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dirotat.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dirotat.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/dirotat.h 2012-09-25 20:00:16.761803074 +0200
|
||||
@@ -141,7 +141,7 @@
|
||||
else if (degree == 270)
|
||||
rotateLeft(src, dest);
|
||||
else
|
||||
- copyPixel(src, dest);
|
||||
+ this->copyPixel(src, dest);
|
||||
}
|
||||
|
||||
|
||||
diff -Naur aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/discalet.h aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/discalet.h
|
||||
--- aeskulap-0.2.2-beta1.orig/dcmtk/dcmimgle/include/dcmtk/dcmimgle/discalet.h 2007-05-24 21:20:41.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1/dcmtk/dcmimgle/include/dcmtk/dcmimgle/discalet.h 2012-09-25 19:55:53.419820846 +0200
|
||||
@@ -201,12 +201,12 @@
|
||||
ofConsole.unlockCerr();
|
||||
}
|
||||
#endif
|
||||
- fillPixel(dest, value); // ... fill bitmap
|
||||
+ this->fillPixel(dest, value); // ... fill bitmap
|
||||
}
|
||||
else if ((this->Src_X == this->Dest_X) && (this->Src_Y == this->Dest_Y)) // no scaling
|
||||
{
|
||||
if ((Left == 0) && (Top == 0) && (Columns == this->Src_X) && (Rows == this->Src_Y))
|
||||
- copyPixel(src, dest); // copying
|
||||
+ this->copyPixel(src, dest); // copying
|
||||
else if ((Left >= 0) && (OFstatic_cast(Uint16, Left + this->Src_X) <= Columns) &&
|
||||
(Top >= 0) && (OFstatic_cast(Uint16, Top + this->Src_Y) <= Rows))
|
||||
clipPixel(src, dest); // clipping
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
aeskulap: aeskulap (medical image viewer)
|
||||
aeskulap:
|
||||
aeskulap: It is able to load a series of special images stored in the DICOM
|
||||
aeskulap: format for review. Additionally Aeskulap is able to query and fetch
|
||||
aeskulap: DICOM images from archive nodes (also called PACS) over the network.
|
||||
aeskulap: The goal of this project is to create a full open source replacement
|
||||
aeskulap: for commercially available DICOM viewers.
|
||||
aeskulap:
|
||||
aeskulap: http://aeskulap.nongnu.org/
|
||||
aeskulap:
|
||||
aeskulap:
|
Loading…
Reference in a new issue