mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
graphics/aeskulap: Added (medical image viewer)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
1e194d77d4
commit
7ab8ff8f34
6 changed files with 187 additions and 0 deletions
8
graphics/aeskulap/README
Normal file
8
graphics/aeskulap/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
Aeskulap is a medical image viewer.
|
||||
It is able to load a series of special images stored in the DICOM
|
||||
format for review. Additionally Aeskulap is able to query and fetch
|
||||
DICOM images from archive nodes (also called PACS) over the network.
|
||||
The goal of this project is to create a full open source replacement
|
||||
for commercially available DICOM viewers.
|
||||
|
||||
This requires libglademm and gconfmm.
|
22
graphics/aeskulap/aeskulap-0.2.2-beta1.patch
Normal file
22
graphics/aeskulap/aeskulap-0.2.2-beta1.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff -urp aeskulap-0.2.2-beta1//configuration/aconfiguration-gconf.cpp aeskulap-0.2.2-beta1.new//configuration/aconfiguration-gconf.cpp
|
||||
--- aeskulap-0.2.2-beta1//configuration/aconfiguration-gconf.cpp 2007-05-10 18:44:00.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1.new//configuration/aconfiguration-gconf.cpp 2011-08-08 19:58:17.986000024 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
|
||||
#include <gconfmm.h>
|
||||
#include <iostream>
|
||||
+#include <cstdio>
|
||||
|
||||
namespace Aeskulap {
|
||||
|
||||
diff -urp aeskulap-0.2.2-beta1//configure.in aeskulap-0.2.2-beta1.new//configure.in
|
||||
--- aeskulap-0.2.2-beta1//configure.in 2007-05-24 20:59:09.000000000 +0200
|
||||
+++ aeskulap-0.2.2-beta1.new//configure.in 2011-08-09 15:36:37.598000023 +0200
|
||||
@@ -166,6 +166,6 @@ if test x"$MINGW32" = xno ; then
|
||||
cd $srcdir/dcmtk
|
||||
export CFLAGS="$CFLAGS"
|
||||
export CXXFLAGS="$CXXFLAGS"
|
||||
-sh ./configure --without-openssl --without-zlib --without-libwrap --prefix=${prefix} --libdir=${prefix}/lib/aeskulap
|
||||
+sh ./configure --without-openssl --without-zlib --without-libwrap --prefix=${prefix} --libdir=${libdir}/aeskulap --sysconfdir=${sysconfdir} --localstatedir=${localstatedir} --mandir=${mandir}
|
||||
|
||||
fi
|
109
graphics/aeskulap/aeskulap.SlackBuild
Normal file
109
graphics/aeskulap/aeskulap.SlackBuild
Normal file
|
@ -0,0 +1,109 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for aeskulap
|
||||
|
||||
# Copyright 2011 Federico Lupi, flupi@mclink.it, http://www.mclink.it/personal/MG2508
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=aeskulap
|
||||
VERSION=0.2.2-beta1
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix missing #include and libdir for 64 bit
|
||||
patch -p1 < $CWD/${PRGNAM}-${VERSION}.patch || exit 1
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
ABOUT-NLS COPYING COPYING.DCMTK COPYING.LIB ChangeLog INSTALL README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
cat $CWD/${PRGNAM}-${VERSION}.patch > $PKG/usr/doc/$PRGNAM-$VERSION/${PRGNAM}-${VERSION}.patch
|
||||
mv $PKG/usr/share/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rmdir $PKG/usr/share/doc
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
graphics/aeskulap/aeskulap.info
Normal file
10
graphics/aeskulap/aeskulap.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="aeskulap"
|
||||
VERSION="0.2.2-beta1"
|
||||
HOMEPAGE="http://aeskulap.nongnu.org/"
|
||||
DOWNLOAD="http://www.bms-austria.com/%7Epipelka/aeskulap/aeskulap-0.2.2-beta1.tar.gz"
|
||||
MD5SUM="33a0f8659909426c67bebc10bd61b1d0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Federico Lupi"
|
||||
EMAIL="flupi@mclink.it"
|
||||
APPROVED="Niels Horn"
|
19
graphics/aeskulap/doinst.sh
Normal file
19
graphics/aeskulap/doinst.sh
Normal file
|
@ -0,0 +1,19 @@
|
|||
schema_install() {
|
||||
SCHEMA="$1"
|
||||
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
|
||||
chroot . gconftool-2 --makefile-install-rule \
|
||||
/etc/gconf/schemas/$SCHEMA \
|
||||
1>/dev/null
|
||||
}
|
||||
|
||||
schema_install aeskulap.schemas
|
||||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
19
graphics/aeskulap/slack-desc
Normal file
19
graphics/aeskulap/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
aeskulap: aeskulap (medical image viewer)
|
||||
aeskulap:
|
||||
aeskulap: It is able to load a series of special images stored in the DICOM
|
||||
aeskulap: format for review. Additionally Aeskulap is able to query and fetch
|
||||
aeskulap: DICOM images from archive nodes (also called PACS) over the network.
|
||||
aeskulap: The goal of this project is to create a full open source replacement
|
||||
aeskulap: for commercially available DICOM viewers.
|
||||
aeskulap:
|
||||
aeskulap: http://aeskulap.nongnu.org/
|
||||
aeskulap:
|
||||
aeskulap:
|
Loading…
Reference in a new issue