office/grisbi: Updated for version 0.6.0.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Larry Hajali 2010-06-15 01:44:44 -05:00 committed by Robby Workman
parent e811bf0adf
commit 774b75d2f6
6 changed files with 34 additions and 116 deletions

View file

@ -1,7 +1,6 @@
Grisbi is a personnal accounting application running under
GNU/Linux and Windows, released under the GPL licence. It's
aim is to provide you with the most simple and intuitive
software for basic use, and still very powerful if you spend
a little time on the setup.
Grisbi is a personnal accounting application running under GNU/Linux and
Windows, released under the GPL licence. Its aim is to provide you with
the most simple and intuitive software for basic use, and still very
powerful if you spend a little time on the setup.
Grisbi has an optional dependency for libofx.

View file

@ -2,6 +2,9 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

View file

@ -2,28 +2,26 @@
# Slackware build script for grisbi
# Written by Larry Hajali
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=grisbi
VERSION=${VERSION:-0.6.0b2}
VERSION=0.6.0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@ -44,7 +42,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-1.tar.bz2
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@ -53,8 +51,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix the HELP_PATH so that the help menu looks in /usr/doc/$PRGNAM-$VERSION.
patch -p1 < $CWD/help-menu.patch
# Fix the HELP_PATH so that the help menu looks in /usr/doc/grisbi-$VERSION.
sed -i \
-e "/^grisbi_helpdir/s|/doc||g" \
-e "/^AM_CPPFLAGS/s|/doc||g" \
src/Makefile.* help/*/Makefile.*
# Fix .desktop menu item.
sed -i \
-e "s|$PRGNAM.png|$PRGNAM|" \
share/grisbi.desktop
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@ -76,14 +81,7 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
# Grisbi comes with a desktop menu item but we're going to overwrite it.
mkdir -p $PKG/usr/share/applications
install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \

View file

@ -1,10 +0,0 @@
[Desktop Entry]
Name=Grisbi
Comment=A personnal account manager
Exec=grisbi
Icon=grisbi/grisbi.png
Terminal=false
StartupNotify=false
Type=Application
MimeType=application/x-grisbi;
Categories=Office;

View file

@ -1,10 +1,10 @@
PRGNAM="grisbi"
VERSION="0.6.0b2"
VERSION="0.6.0"
HOMEPAGE="http://www.grisbi.org/"
DOWNLOAD="http://downloads.sourceforge.net/grisbi/grisbi-0.6.0b2-1.tar.bz2"
MD5SUM="f0c05d42c90a33b1b43840dbe32a507b"
DOWNLOAD="http://downloads.sourceforge.net/grisbi/grisbi-0.6.0.tar.bz2"
MD5SUM="19062be7f4f6ec29adda4ec09f0d626f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
APPROVED="Erik Hanson"
APPROVED="rworkman"

View file

@ -1,72 +0,0 @@
diff -Naur grisbi-0.6.0b1.orig/help/C/Makefile.in grisbi-0.6.0b1/help/C/Makefile.in
--- grisbi-0.6.0b1.orig/help/C/Makefile.in 2009-09-19 09:41:04.000000000 +0000
+++ grisbi-0.6.0b1/help/C/Makefile.in 2009-09-20 16:20:32.000000000 +0000
@@ -230,7 +230,7 @@
quickstart.html \
translation.html
-grisbi_helpdir = $(datadir)/doc/grisbi/C
+grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/C
grisbi_help_DATA = \
topic.dat \
contents_motif.gif \
diff -Naur grisbi-0.6.0b1.orig/help/de/Makefile.in grisbi-0.6.0b1/help/de/Makefile.in
--- grisbi-0.6.0b1.orig/help/de/Makefile.in 2009-09-19 09:41:04.000000000 +0000
+++ grisbi-0.6.0b1/help/de/Makefile.in 2009-09-20 16:21:10.000000000 +0000
@@ -230,7 +230,7 @@
quickstart.html \
translation.html
-grisbi_helpdir = $(datadir)/doc/grisbi/de
+grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/de
grisbi_help_DATA = \
topic.dat \
contents_motif.gif \
diff -Naur grisbi-0.6.0b1.orig/help/en/Makefile.in grisbi-0.6.0b1/help/en/Makefile.in
--- grisbi-0.6.0b1.orig/help/en/Makefile.in 2009-09-19 09:41:04.000000000 +0000
+++ grisbi-0.6.0b1/help/en/Makefile.in 2009-09-20 16:21:47.000000000 +0000
@@ -230,7 +230,7 @@
quickstart.html \
translation.html
-grisbi_helpdir = $(datadir)/doc/grisbi/en
+grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/en
grisbi_help_DATA = \
topic.dat \
contents_motif.gif \
diff -Naur grisbi-0.6.0b1.orig/help/fr/Makefile.in grisbi-0.6.0b1/help/fr/Makefile.in
--- grisbi-0.6.0b1.orig/help/fr/Makefile.in 2009-09-19 09:41:04.000000000 +0000
+++ grisbi-0.6.0b1/help/fr/Makefile.in 2009-09-20 16:22:19.000000000 +0000
@@ -230,7 +230,7 @@
quickstart.html \
translation.html
-grisbi_helpdir = $(datadir)/doc/grisbi/fr
+grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/fr
grisbi_help_DATA = \
topic.dat \
contents_motif.gif \
diff -Naur grisbi-0.6.0b1.orig/src/Makefile.am grisbi-0.6.0b1/src/Makefile.am
--- grisbi-0.6.0b1.orig/src/Makefile.am 2009-07-14 19:33:32.000000000 +0000
+++ grisbi-0.6.0b1/src/Makefile.am 2009-09-20 16:07:36.000000000 +0000
@@ -1,7 +1,7 @@
# Process this file with automake to produce Makefile.in
localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(datadir)/doc/@PACKAGE@\"" -Wall
+INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(prefix)/doc/@PACKAGE@-@VERSION@\"" -Wall
bin_PROGRAMS = grisbi
# TODO: This manual setting of -Wl is a hack, I cannot get it from
diff -Naur grisbi-0.6.0b1.orig/src/Makefile.in grisbi-0.6.0b1/src/Makefile.in
--- grisbi-0.6.0b1.orig/src/Makefile.in 2009-09-19 09:41:05.000000000 +0000
+++ grisbi-0.6.0b1/src/Makefile.in 2009-09-20 16:06:26.000000000 +0000
@@ -379,7 +379,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(datadir)/doc/@PACKAGE@\"" -Wall
+INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(prefix)/doc/@PACKAGE@-@VERSION@\"" -Wall
# TODO: This manual setting of -Wl is a hack, I cannot get it from
# configure right now because of no doc.