mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
multimedia/HandBrake: Updated for version 0.10.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
961d46cead
commit
77459e8b75
6 changed files with 40 additions and 118 deletions
|
@ -1,28 +0,0 @@
|
|||
diff -Naur lame.orig/configure lame/configure
|
||||
--- lame.orig/configure 2015-02-08 17:37:18.000000000 -0500
|
||||
+++ lame/configure 2015-02-08 17:38:32.000000000 -0500
|
||||
@@ -21031,7 +21031,14 @@
|
||||
|
||||
|
||||
|
||||
-
|
||||
+case $host_cpu in
|
||||
+powerpc*|i686*)
|
||||
+ check_xmmintrin=
|
||||
+ ;;
|
||||
+*)
|
||||
+ check_xmmintrin="xmmintrin.h"
|
||||
+ ;;
|
||||
+esac
|
||||
|
||||
for ac_header in \
|
||||
errno.h \
|
||||
@@ -21042,7 +21049,7 @@
|
||||
sys/soundcard.h \
|
||||
sys/time.h \
|
||||
unistd.h \
|
||||
- xmmintrin.h \
|
||||
+ $check_xmmintrin \
|
||||
linux/soundcard.h
|
||||
do
|
||||
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
|
@ -1,19 +0,0 @@
|
|||
diff -Naur mpeg2dec.orig/configure mpeg2dec/configure
|
||||
--- mpeg2dec.orig/configure 2015-02-08 17:37:18.000000000 -0500
|
||||
+++ mpeg2dec/configure 2015-02-08 17:38:32.000000000 -0500
|
||||
@@ -21031,7 +21031,14 @@
|
||||
|
||||
|
||||
|
||||
-
|
||||
+case $host_cpu in
|
||||
+powerpc*|i686*)
|
||||
+ check_xmmintrin=
|
||||
+ ;;
|
||||
+*)
|
||||
+ check_xmmintrin="xmmintrin.h"
|
||||
+ ;;
|
||||
+esac
|
||||
|
||||
for ac_header in \
|
||||
errno.h \
|
|
@ -8,9 +8,10 @@
|
|||
# Patched to fix x264 segfault by John Vogel
|
||||
|
||||
PRGNAM=HandBrake
|
||||
VERSION=${VERSION:-0.9.9}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-0.10.5}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
DOCDIR=${DOCDIR:-/usr/doc}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
|
@ -62,22 +63,19 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# fix i686 build: "inlining failed in call to always_inline '_mm_loadu_ps': target specific option mismatch"
|
||||
# https://github.com/HandBrake/HandBrake/blob/master/contrib/lame/A00-xmmintrin.patch
|
||||
cp $CWD/A00-lame-xmmintrin.patch contrib/lame/
|
||||
cp $CWD/A00-mpeg2dec-xmmintrin.patch contrib/mpeg2dec/
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--disable-gtk-update-checks \
|
||||
--enable-fdk-aac \
|
||||
--disable-libav-aac \
|
||||
--enable-x265 \
|
||||
--arch=$ARCH
|
||||
|
||||
cd build
|
||||
# Fix underlinking by configuring the gtk module first, then sed:
|
||||
make gtk.configure
|
||||
sed -i '/^LDFLAGS/s/$/ -ltheoraenc -ltheoradec/' gtk/src/Makefile
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd $TMP/$PRGNAM-$VERSION
|
||||
|
@ -85,10 +83,10 @@ cd $TMP/$PRGNAM-$VERSION
|
|||
export CFLAGS="$saved_CFLAGS"
|
||||
export CXXFLAGS="$saved_CXXFLAGS"
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mkdir -p $PKG/$DOCDIR/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING CREDITS NEWS THANKS TRANSLATIONS \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
$PKG/$DOCDIR/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/$DOCDIR/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
|
|
@ -1,60 +1,24 @@
|
|||
PRGNAM="HandBrake"
|
||||
VERSION="0.9.9"
|
||||
VERSION="0.10.5"
|
||||
HOMEPAGE="http://handbrake.fr/"
|
||||
DOWNLOAD="http://download.handbrake.fr/releases/0.9.9/HandBrake-0.9.9.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/a52dec-0.7.4.tar.gz \
|
||||
http://download.handbrake.fr/handbrake/contrib/bzip2-1.0.6.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/faac-1.28.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/faad2-2.7.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libav-v9.6.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/fontconfig-2.8.0.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/freetype-2.4.7.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/lame-3.98.tar.gz \
|
||||
http://download.handbrake.fr/handbrake/contrib/libass-0.10.0-1.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libbluray-0.2.3.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/libdca-r81-strapped.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libdvdnav-svn1168.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libdvdread-svn1168.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libiconv-1.13.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/libmkv-0.6.5-0-g82075ae.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libogg-1.3.0.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libsamplerate-0.1.4.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/libtheora-1.1.0.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/libvorbis-aotuv_b6.03.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/libxml2-2.7.7.tar.gz \
|
||||
http://mp4v2.googlecode.com/files/mp4v2-trunk-r355.tar.bz2 \
|
||||
http://download.m0k.org/handbrake/contrib/mpeg2dec-0.5.1.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/pthreads-w32-cvs20100909.tar.bz2 \
|
||||
http://download.handbrake.fr/handbrake/contrib/x264-r2273-b3065e6.tar.gz \
|
||||
http://download.m0k.org/handbrake/contrib/zlib-1.2.3.tar.gz"
|
||||
MD5SUM="ee81337a46f8af76599d6038f193a2c1 \
|
||||
ce5a978bb359f642dcbd24c6e14a45a7 \
|
||||
6ec09fe81e3380184ed11e21ea06c215 \
|
||||
80763728d392c7d789cde25614c878f6 \
|
||||
ee1b4d67ea2d76ee52c5621bc6dbf61e \
|
||||
a03c00a20a7a5b92e285ee47511a28c1 \
|
||||
77e15a92006ddc2adbb06f840d591c0e \
|
||||
dbadce8f0c5e70a0b7c51eadf2dd9394 \
|
||||
7036b52e792538fd665595d56b9e49a0 \
|
||||
ec2b87024fc93792e5d11fb0ecaa1bd8 \
|
||||
684e420d2ebafa13786ae84364543cf9 \
|
||||
448bab6df6e4f738e4afaa6ebc085d65 \
|
||||
327c0a3a4304d7c06d75199a75ad4f02 \
|
||||
39cb0b27cc6b05e4f5c849dececf1f7a \
|
||||
9c8b41b77f508edf72e26b406e873a2f \
|
||||
08ba2ae015de9b80ee6150d4a9b82e4c \
|
||||
0a7eb40b86ac050db3a789ab65fe21c2 \
|
||||
69ec6c05f487458f688dda8f3e722e5d \
|
||||
d0f83cf7f13e2b3bd068a858ca1398ad \
|
||||
586d2ac0fa13f32cba78be5db4a16330 \
|
||||
9abc9959823ca9ff904f1fbcf21df066 \
|
||||
38a753e936df5ef4c2f7de3d16f440f6 \
|
||||
a6173dc90cfe7f0414624c3c8bbad727 \
|
||||
d1dea735b53176567e9841ca77388633 \
|
||||
10a0f3307027f2d8321f4d834e319208 \
|
||||
af3358a811ad3469a2e54db49f77d52a"
|
||||
DOWNLOAD="http://download.handbrake.fr/handbrake/releases/0.10.5/HandBrake-0.10.5.tar.bz2 \
|
||||
http://download.handbrake.fr/contrib/libvpx-v1.3.0.tar.bz2 \
|
||||
http://download.handbrake.fr/handbrake/contrib/libav-v10.1.tar.bz2 \
|
||||
http://download.handbrake.fr/handbrake/contrib/fdk-aac-v0.1.1-6-gbae4553.tar.bz2
|
||||
http://download.handbrake.fr/handbrake/contrib/libdvdread-5.0.0-6-gcb1ae87.tar.gz \
|
||||
http://download.handbrake.fr/handbrake/contrib/libdvdnav-5.0.1-0-gaa3659d.tar.gz \
|
||||
http://download.handbrake.fr/contrib/x265_1.9.tar.gz \
|
||||
http://download.handbrake.fr/handbrake/contrib/libbluray-0.5.0.tar.bz2"
|
||||
MD5SUM="ef889f9cb1c7a8230c19cf9d403d7981 \
|
||||
14783a148872f2d08629ff7c694eb31f \
|
||||
435967fb41cac169fc66207209dacd9c \
|
||||
b1ac9b8bcc37b26cfb2c5e1761f50ff9 \
|
||||
607a5dd41b0dd2f35433d6deac79b99e \
|
||||
1fb10188c7a33f480011d3ddf32553c7 \
|
||||
f34a1c4c660ff07511365cb0983cf164 \
|
||||
c367f8b881135524f23bb7bd3867c770"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="libass"
|
||||
REQUIRES="libass x264 lame"
|
||||
MAINTAINER="klaatu"
|
||||
EMAIL="klaatu@hackerpublicradio.org"
|
||||
EMAIL="klaatu@member.fsf.org"
|
||||
|
|
|
@ -5,6 +5,13 @@ pixel aspect ratio, deinterlacing, and so on.
|
|||
|
||||
The legality of ripping content from commercial DVDs may vary.
|
||||
|
||||
Lacking a GUI, the binary is HandBrakeCLI -- not HandBrake as you might
|
||||
otherwise expect. To launch this application after installing, type in
|
||||
"HandBrakeCLI" For the manual, type in "HandBrakeCLI --help"
|
||||
On by default, to skip building the GTK GUI, pass GUI=no to the script:
|
||||
|
||||
# GUI=no sh ./HandBrake.SlackBuild
|
||||
|
||||
|
||||
Commands
|
||||
--------
|
||||
|
||||
* The command to launch the HandBrake GUI is `ghb`
|
||||
* Without the GUI, it's `HandBrakeCLI`
|
||||
|
|
|
@ -6,14 +6,14 @@
|
|||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
HandBrake: HandBrake (HandBrakeCLI - a DVD ripper)
|
||||
HandBrake: HandBrake (DVD ripper)
|
||||
HandBrake:
|
||||
HandBrake: HandBrake is a DVD ripper that reads DVD movies and outputs them
|
||||
HandBrake: to a variety of video and audio formats, with subtitle options,
|
||||
HandBrake: options for alternate audio streams, a number of presets, etc.
|
||||
HandBrake: This is command line only; a GTK GUI can be found on the project
|
||||
HandBrake:
|
||||
HandBrake: Homepage: http://www.handbrake.fr
|
||||
HandBrake:
|
||||
HandBrake:
|
||||
HandBrake:
|
||||
HandBrake:
|
||||
|
|
Loading…
Reference in a new issue