mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
development/ragel: Updated for version 7.0.4.
Create shared libraries Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ab1664ac43
commit
77042863c7
4 changed files with 59 additions and 18 deletions
15
development/ragel/lib64.patch
Normal file
15
development/ragel/lib64.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- a/configure.ac 2021-02-15 20:45:20.000000000 +0100
|
||||
+++ b/configure.ac 2021-02-21 17:59:13.593674832 +0100
|
||||
@@ -46,9 +46,9 @@
|
||||
COLM_WRAP="$withval/bin/colm-wrap"
|
||||
CPPFLAGS="-I$withval/include ${CPPFLAGS}"
|
||||
CPPFLAGS="-I$withval/include/aapl ${CPPFLAGS}"
|
||||
- LDFLAGS="-L$withval/lib ${LDFLAGS}"
|
||||
- LIBCOLM_LA="$withval/lib/libcolm.la"
|
||||
- LIBFSM_LA="$withval/lib/libfsm.la"
|
||||
+ LDFLAGS="-L$withval/lib64 ${LDFLAGS}"
|
||||
+ LIBCOLM_LA="$withval/lib64/libcolm.la"
|
||||
+ LIBFSM_LA="$withval/lib64/libfsm.la"
|
||||
COLM_SHARE="$withval/share"
|
||||
],
|
||||
[]
|
|
@ -30,8 +30,8 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=ragel
|
||||
VERSION=${VERSION:-7.0.0.12}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-7.0.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -66,22 +66,10 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
DOCS="AUTHORS COPYING README TODO"
|
||||
DOCS="COPYING README"
|
||||
|
||||
set -e
|
||||
|
||||
if [ -x /usr/bin/ragel ]; then
|
||||
cat <<EOF
|
||||
****************************************************************
|
||||
This build would fail, because you already have ragel installed.
|
||||
Do this first:
|
||||
removepkg ragel
|
||||
...then run this script again. Sorry.
|
||||
****************************************************************
|
||||
EOF
|
||||
exit 1
|
||||
fi
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
|
@ -96,6 +84,11 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
|
||||
|
||||
if [ "$LIBDIRSUFFIX" = "64" ]; then
|
||||
patch --verbose -p1 -i $CWD/lib64.patch
|
||||
fi
|
||||
patch --verbose -p1 -i $CWD/shared-colm.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -106,6 +99,8 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--disable-static \
|
||||
--with-colm=/usr \
|
||||
--disable-manual \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="ragel"
|
||||
VERSION="7.0.0.12"
|
||||
VERSION="7.0.4"
|
||||
HOMEPAGE="https://www.colm.net/open-source/ragel/"
|
||||
DOWNLOAD="https://www.colm.net/files/ragel/ragel-7.0.0.12.tar.gz"
|
||||
MD5SUM="f95b1830fa6d9acea34f753d91e038e8"
|
||||
DOWNLOAD="https://www.colm.net/files/ragel/ragel-7.0.4.tar.gz"
|
||||
MD5SUM="2ca4f5507c1923bcf9a7909baa8254d3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="colm kelbt"
|
||||
|
|
31
development/ragel/shared-colm.patch
Normal file
31
development/ragel/shared-colm.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index e1a0fc67..07a2b075 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -59,6 +59,26 @@ AC_CHECK_FILES(
|
||||
[],
|
||||
[AC_ERROR([colm is required to build ragel])]
|
||||
)
|
||||
+
|
||||
+dnl If the .la files are present use those, otherwise locate the libs with AC_CHECK_LIB.
|
||||
+AC_CHECK_FILES(
|
||||
+ [$LIBCOLM_LA $LIBFSM_LA],
|
||||
+ [],
|
||||
+ [
|
||||
+ AC_CHECK_LIB(
|
||||
+ [colm],
|
||||
+ [colm_run_program],
|
||||
+ [LIBCOLM_LA=-lcolm],
|
||||
+ [AC_ERROR([libcolm is required to build ragel])]
|
||||
+ )
|
||||
+ AC_CHECK_LIB(
|
||||
+ [fsm],
|
||||
+ [libfsm_present],
|
||||
+ [LIBFSM_LA=-lfsm],
|
||||
+ [AC_ERROR([libfsm is required to build ragel])]
|
||||
+ )
|
||||
+ ]
|
||||
+)
|
||||
AC_SUBST(COLM)
|
||||
AC_SUBST(COLM_WRAP)
|
||||
AC_SUBST(COLM_SHARE)
|
Loading…
Reference in a new issue