mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
network/aircrack-ptw: Removed from 12.2 repository
This commit is contained in:
parent
037b555ed8
commit
76a35bf423
5 changed files with 0 additions and 99 deletions
|
@ -1,9 +0,0 @@
|
|||
--- Makefile.orig 2008-03-14 17:14:23.000000000 -0400
|
||||
+++ Makefile 2008-03-14 17:14:37.000000000 -0400
|
||||
@@ -1,5 +1,5 @@
|
||||
aircrack-ptw: aircrack-ptw.c aircrack-ptw-lib.c aircrack-ptw-lib.h
|
||||
- gcc -o aircrack-ptw -Wall -fomit-frame-pointer -O3 -lpcap aircrack-ptw.c aircrack-ptw-lib.c
|
||||
+ gcc -o aircrack-ptw -Wall -fomit-frame-pointer -O3 aircrack-ptw.c aircrack-ptw-lib.c -lpcap
|
||||
|
||||
attacksim: attacksim.c aircrack-ptw-lib.c aircrack-ptw-lib.h
|
||||
gcc -o attacksim -Wall -fomit-frame-pointer -O3 -lpcap attacksim.c aircrack-ptw-lib.c
|
|
@ -1,6 +0,0 @@
|
|||
aircrack-ptw is an advanced wep cracking tool.
|
||||
|
||||
This software is provided for education only and intended for use
|
||||
only in networks that you own and/or control.
|
||||
|
||||
aircrack-ptw requires the aircrack-ng suite (available on SlackBuilds.org).
|
|
@ -1,57 +0,0 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for aircrack-ptw
|
||||
|
||||
PRGNAM=aircrack-ptw
|
||||
VERSION=${VERSION:-1.0.0}
|
||||
ARCH=$(uname -m) # No way around it without patching Makefile lots
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="README"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP || exit 1
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix for linker error in Makefile
|
||||
patch -p0 < $CWD/Makefile.patch
|
||||
|
||||
make aircrack-ptw
|
||||
make attacksim
|
||||
|
||||
mkdir -p $PKG/usr/bin
|
||||
cp -a aircrack-ptw attacksim $PKG/usr/bin
|
||||
strip --strip-unneeded $PKG/usr/bin/* 2>/dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp README $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
|
@ -1,8 +0,0 @@
|
|||
PRGNAM="aircrack-ptw"
|
||||
VERSION="1.0.0"
|
||||
HOMEPAGE="http://www.cdc.informatik.tu-darmstadt.de/aircrack-ptw/"
|
||||
DOWNLOAD="http://www.cdc.informatik.tu-darmstadt.de/aircrack-ptw/download/aircrack-ptw-1.0.0.tar.gz"
|
||||
MD5SUM="1d7d84d1e69189bc1397db3f565c183a"
|
||||
MAINTAINER="adev"
|
||||
EMAIL="adev@linuxmail.org"
|
||||
APPROVED="rworkman"
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler-------------------------------------------------|
|
||||
aircrack-ptw: aircrack-ptw (WLAN auditing tool)
|
||||
aircrack-ptw:
|
||||
aircrack-ptw: This is aircrack-ptw, an advanced wep cracking tool.
|
||||
aircrack-ptw: This software is provided for education only. Only use it
|
||||
aircrack-ptw: against your own networks.
|
||||
aircrack-ptw:
|
||||
aircrack-ptw: aircrack-ptw has been written by Erik Tews, Andrei Pychkine and
|
||||
aircrack-ptw: Ralf-Philipp Weinmann.
|
||||
aircrack-ptw:
|
||||
aircrack-ptw: Homepage: http://www.cdc.informatik.tu-darmstadt.de/aircrack-ptw
|
||||
aircrack-ptw:
|
Loading…
Reference in a new issue