games/mupen64plus-video-parallel: Added (Video Plugin mupen64plus).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Steven Voges 2023-09-02 17:56:09 +07:00 committed by Willy Sudiarto Raharjo
parent 53011247fb
commit 75c19e9787
5 changed files with 155 additions and 0 deletions

View file

@ -0,0 +1,4 @@
Parallel RDP is a fast RDP LLE plugin for mupen64plus
Note that this plugin will only work with RSP plugins that can
interpret LLE, such as mupen64plus-rsp-parallel.

View file

@ -0,0 +1,10 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
@@ -4,7 +4,7 @@
project(parallel-rdp LANGUAGES CXX C)
set(NAME_PLUGIN_M64P "mupen64plus-video-parallel")
-include_directories(../mupen64plus-core/src/api)
+include_directories(/usr/include/mupen64plus)
add_definitions(-DM64P_PLUGIN_API -DGRANITE_VULKAN_MT)
# check for INTERPROCEDURAL_OPTIMIZATION support

View file

@ -0,0 +1,112 @@
#!/bin/bash
# Slackware build script for mupen64plus-video-parallel
# Copyright 2023 Steven Voges <Oregon, USA>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mupen64plus-video-parallel
SRCNAM=parallel-rdp-standalone
VERSION=${VERSION:-20221122_5628fa9}
SRCVER=${SRCVER:-5628fa906e8d9058878c7208819bba909a43fd69}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "aarch64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$SRCVER
tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
cd $SRCNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/fix-build.patch
#sed -i "4i #include <stdint.h>" rsp_disasm.hpp
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make
install -Dm 755 $PRGNAM.so $PKG/usr/lib$LIBDIRSUFFIX/mupen64plus/$PRGNAM.so
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -0,0 +1,10 @@
PRGNAM="mupen64plus-video-parallel"
VERSION="20221122_5628fa9"
HOMEPAGE="https://github.com/Mastergatto/parallel-rdp-standalone"
DOWNLOAD="https://github.com/Mastergatto/parallel-rdp-standalone/archive/5628fa906e8d9058878c7208819bba909a43fd69/parallel-rdp-standalone-5628fa906e8d9058878c7208819bba909a43fd69.tar.gz"
MD5SUM="5b77c3b85410930c993167e94fd42cc0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="mupen64plus-nightly"
MAINTAINER="Steven Voges"
EMAIL="svoges.sbo@gmail.com"

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
mupen64plus-video-parallel: mupen64plus-video-parallel (Video plugin for mupen64plus)
mupen64plus-video-parallel:
mupen64plus-video-parallel: A low-level Vulkan compute emulation of the N64 RDP
mupen64plus-video-parallel:
mupen64plus-video-parallel: Homepage: https://github.com/Themaister/parallel-rdp
mupen64plus-video-parallel:
mupen64plus-video-parallel:
mupen64plus-video-parallel:
mupen64plus-video-parallel:
mupen64plus-video-parallel:
mupen64plus-video-parallel: