mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
audio/alsaequal: Updated for new caps Eq name.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
051836e514
commit
74a301c2b2
5 changed files with 73 additions and 56 deletions
|
@ -3,11 +3,11 @@ adjusted using an ALSA compatible mixer like alsamixergui or alsamixer.
|
||||||
|
|
||||||
Alsaequal uses the Eq CAPS LADSPA Plugin as it's default equalizer
|
Alsaequal uses the Eq CAPS LADSPA Plugin as it's default equalizer
|
||||||
but you can change it to use almost any LADSPA plugin like mbeq from
|
but you can change it to use almost any LADSPA plugin like mbeq from
|
||||||
the swh-plugin package. Though alsaequal is primarily intended to be
|
the swh-plugin package. Though alsaequal is primarily intended to be
|
||||||
used as an equalizer you should be able to use it to control any
|
used as an equalizer you should be able to use it to control any
|
||||||
LADSPA plugin. It's similar in functionality to the LADSPA plugin
|
LADSPA plugin. It's similar in functionality to the LADSPA plugin
|
||||||
provided with ALSA but allows for real-time controls as opposed to
|
provided with ALSA but allows for real-time controls as opposed to
|
||||||
static controls defined in the asoundrc file.
|
static controls defined in the asoundrc file.
|
||||||
|
|
||||||
See the included asoundrc.example in the docs directory for ways of
|
See the included asoundrc.example in the docs directory for ways of
|
||||||
setting up alsa. The mixer is started with: 'alsamixer -D equal'
|
setting up alsa. The mixer is started with: 'alsamixer -D equal'
|
||||||
|
|
|
@ -24,7 +24,7 @@
|
||||||
|
|
||||||
PRGNAM=alsaequal
|
PRGNAM=alsaequal
|
||||||
VERSION=${VERSION:-0.6}
|
VERSION=${VERSION:-0.6}
|
||||||
BUILD=${BUILD:-2}
|
BUILD=${BUILD:-3}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
if [ -z "$ARCH" ]; then
|
if [ -z "$ARCH" ]; then
|
||||||
|
@ -64,13 +64,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||||
cd $PRGNAM
|
cd $PRGNAM
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
find -L . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
-exec chmod 755 {} \; -o \
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
# Fixes for x86_64
|
# Fixes for x86_64 and Eq renaming in caps 0.9.20
|
||||||
sed "s/@LIBDIRSUFFIX@/$LIBDIRSUFFIX/g" $CWD/lib64fix.diff | patch -p1
|
sed "s/@LIBDIRSUFFIX@/$LIBDIRSUFFIX/g" $CWD/lib64fix+EqRename.diff | patch -p1
|
||||||
|
|
||||||
make Q=
|
make Q=
|
||||||
make install DESTDIR=$PKG
|
make install DESTDIR=$PKG
|
||||||
|
|
61
audio/alsaequal/lib64fix+EqRename.diff
Normal file
61
audio/alsaequal/lib64fix+EqRename.diff
Normal file
|
@ -0,0 +1,61 @@
|
||||||
|
diff -Naur a/Makefile b/Makefile
|
||||||
|
--- a/Makefile 2010-03-05 17:30:39.000000000 +0000
|
||||||
|
+++ b/Makefile 2014-02-12 20:57:50.432081552 +0000
|
||||||
|
@@ -45,11 +45,11 @@
|
||||||
|
|
||||||
|
install: all
|
||||||
|
@echo Installing...
|
||||||
|
- $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
|
||||||
|
- $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
|
||||||
|
+ $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/
|
||||||
|
+ $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
@echo Un-installing...
|
||||||
|
- $(Q)rm ${DESTDIR}/usr/lib/alsa-lib/$(SND_PCM_BIN)
|
||||||
|
- $(Q)rm ${DESTDIR}/usr/lib/alsa-lib/$(SND_CTL_BIN)
|
||||||
|
+ $(Q)rm ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/$(SND_PCM_BIN)
|
||||||
|
+ $(Q)rm ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/$(SND_CTL_BIN)
|
||||||
|
|
||||||
|
diff -Naur a/ctl_equal.c b/ctl_equal.c
|
||||||
|
--- a/ctl_equal.c 2009-01-31 22:06:47.000000000 +0000
|
||||||
|
+++ b/ctl_equal.c 2014-02-12 21:12:08.155101938 +0000
|
||||||
|
@@ -166,8 +166,8 @@
|
||||||
|
snd_config_iterator_t it, next;
|
||||||
|
snd_ctl_equal_t *equal;
|
||||||
|
const char *controls = ".alsaequal.bin";
|
||||||
|
- const char *library = "/usr/lib/ladspa/caps.so";
|
||||||
|
- const char *module = "Eq";
|
||||||
|
+ const char *library = "/usr/lib@LIBDIRSUFFIX@/ladspa/caps.so";
|
||||||
|
+ const char *module = "Eq10";
|
||||||
|
long channels = 2;
|
||||||
|
const char *sufix = " Playback Volume";
|
||||||
|
int err, i, index;
|
||||||
|
@@ -263,9 +263,10 @@
|
||||||
|
for(i = 0; i < equal->num_input_controls; i++) {
|
||||||
|
if(equal->control_data->control[i].type == LADSPA_CNTRL_INPUT) {
|
||||||
|
index = equal->control_data->control[i].index;
|
||||||
|
- if(equal->klass->PortDescriptors[index] !=
|
||||||
|
- (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL)) {
|
||||||
|
- SNDERR("Problem with control file %s, %d.", controls, index);
|
||||||
|
+ //if(equal->klass->PortDescriptors[index] !=
|
||||||
|
+ // (LADSPA_PORT_INPUT | LADSPA_PORT_CONTROL)) {
|
||||||
|
+ if((0xf & equal->control_data->control[i].type) != LADSPA_CNTRL_INPUT) {
|
||||||
|
+ SNDERR("Problem with control file %s, %d.", controls, index);
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
equal->control_info[i].min =
|
||||||
|
diff -Naur a/pcm_equal.c b/pcm_equal.c
|
||||||
|
--- a/pcm_equal.c 2010-02-01 22:55:00.000000000 +0000
|
||||||
|
+++ b/pcm_equal.c 2014-02-12 20:49:41.297069927 +0000
|
||||||
|
@@ -150,8 +150,8 @@
|
||||||
|
snd_pcm_equal_t *equal;
|
||||||
|
snd_config_t *sconf = NULL;
|
||||||
|
const char *controls = ".alsaequal.bin";
|
||||||
|
- const char *library = "/usr/lib/ladspa/caps.so";
|
||||||
|
- const char *module = "Eq";
|
||||||
|
+ const char *library = "/usr/lib@LIBDIRSUFFIX@/ladspa/caps.so";
|
||||||
|
+ const char *module = "Eq10";
|
||||||
|
long channels = 2;
|
||||||
|
int err;
|
||||||
|
|
|
@ -1,43 +0,0 @@
|
||||||
diff -Naur alsaequal-orig/Makefile alsaequal/Makefile
|
|
||||||
--- alsaequal-orig/Makefile 2010-03-05 17:30:39.000000000 +0000
|
|
||||||
+++ alsaequal/Makefile 2011-01-17 22:13:10.156344120 +0000
|
|
||||||
@@ -45,11 +45,11 @@
|
|
||||||
|
|
||||||
install: all
|
|
||||||
@echo Installing...
|
|
||||||
- $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib/alsa-lib/
|
|
||||||
- $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib/alsa-lib/
|
|
||||||
+ $(Q)install -m 644 $(SND_PCM_BIN) ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/
|
|
||||||
+ $(Q)install -m 644 $(SND_CTL_BIN) ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
@echo Un-installing...
|
|
||||||
- $(Q)rm ${DESTDIR}/usr/lib/alsa-lib/$(SND_PCM_BIN)
|
|
||||||
- $(Q)rm ${DESTDIR}/usr/lib/alsa-lib/$(SND_CTL_BIN)
|
|
||||||
+ $(Q)rm ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/$(SND_PCM_BIN)
|
|
||||||
+ $(Q)rm ${DESTDIR}/usr/lib@LIBDIRSUFFIX@/alsa-lib/$(SND_CTL_BIN)
|
|
||||||
|
|
||||||
diff -Naur alsaequal-orig/ctl_equal.c alsaequal/ctl_equal.c
|
|
||||||
--- alsaequal-orig/ctl_equal.c 2009-01-31 22:06:47.000000000 +0000
|
|
||||||
+++ alsaequal/ctl_equal.c 2011-01-17 23:08:54.273018904 +0000
|
|
||||||
@@ -166,7 +166,7 @@
|
|
||||||
snd_config_iterator_t it, next;
|
|
||||||
snd_ctl_equal_t *equal;
|
|
||||||
const char *controls = ".alsaequal.bin";
|
|
||||||
- const char *library = "/usr/lib/ladspa/caps.so";
|
|
||||||
+ const char *library = "/usr/lib@LIBDIRSUFFIX@/ladspa/caps.so";
|
|
||||||
const char *module = "Eq";
|
|
||||||
long channels = 2;
|
|
||||||
const char *sufix = " Playback Volume";
|
|
||||||
diff -Naur alsaequal-orig/pcm_equal.c alsaequal/pcm_equal.c
|
|
||||||
--- alsaequal-orig/pcm_equal.c 2010-02-01 22:55:00.000000000 +0000
|
|
||||||
+++ alsaequal/pcm_equal.c 2011-01-17 23:07:56.424897961 +0000
|
|
||||||
@@ -150,7 +150,7 @@
|
|
||||||
snd_pcm_equal_t *equal;
|
|
||||||
snd_config_t *sconf = NULL;
|
|
||||||
const char *controls = ".alsaequal.bin";
|
|
||||||
- const char *library = "/usr/lib/ladspa/caps.so";
|
|
||||||
+ const char *library = "/usr/lib@LIBDIRSUFFIX@/ladspa/caps.so";
|
|
||||||
const char *module = "Eq";
|
|
||||||
long channels = 2;
|
|
||||||
int err;
|
|
|
@ -4,11 +4,10 @@
|
||||||
# the '|' on the right side marks the last column you can put a character in.
|
# the '|' on the right side marks the last column you can put a character in.
|
||||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|-----handy-ruler------------------------------------------------------|
|
|-----handy-ruler------------------------------------------------------|
|
||||||
alsaequal: alsaequal (10 Band Graphical Equalizer)
|
alsaequal: Alsaequal (10 Band Graphical Equalizer)
|
||||||
alsaequal:
|
alsaequal:
|
||||||
alsaequal: equal is a real-time adjustable equalizer plugin for ALSA.
|
alsaequal: Alsaequal is a real-time adjustable equalizer plugin for ALSA.
|
||||||
alsaequal: It can be adjusted using an ALSA compatible mixer like
|
alsaequal: It can be adjusted using an ALSA compatible mixer like
|
||||||
alsaequal: alsamixergui or alsamixer.
|
alsaequal: alsamixergui or alsamixer.
|
||||||
alsaequal:
|
alsaequal:
|
||||||
|
|
Loading…
Reference in a new issue