mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-25 10:03:03 +01:00
multimedia/Miro: Removed from 13.0 repository
This commit is contained in:
parent
a0b7ba9a67
commit
7487ea288f
8 changed files with 0 additions and 190 deletions
|
@ -1,93 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for Miro
|
||||
|
||||
# Copyright 2009 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=Miro
|
||||
VERSION=${VERSION:-2.0.4}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Add option to setup.py to search for seamonkey packages.
|
||||
# Hopefully, this patch won't be needed for version 2.1.
|
||||
patch -p1 < $CWD/seamonkey_xpcom.patch
|
||||
# Fix gstreamerrenderer.py hard coded path.
|
||||
patch -p1 < $CWD/gstreamerrenderer.diff
|
||||
|
||||
cd platform/gtk-x11
|
||||
# Fix the location of man pages.
|
||||
sed -i 's|/usr/share/man|/usr/man|g' setup.py
|
||||
python setup.py install --root=$PKG
|
||||
cd -
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
# Miro makes an executable that is hard link to to the seamonkey version.
|
||||
# Lets use the symlink version instead.
|
||||
SEAMONKEYVERSION=$(echo $(seamonkey -v) | awk -F"," '{print $1}' | awk '{print $2}')
|
||||
sed -i "s|seamonkey-${SEAMONKEYVERSION}|seamonkey|g" $PKG/usr/bin/miro
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a CREDITS LAYOUT license.txt README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/README.runtime > $PKG/usr/doc/$PRGNAM-$VERSION/README.runtime
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
|
@ -1,8 +0,0 @@
|
|||
PRGNAM="Miro"
|
||||
VERSION="2.0.4"
|
||||
HOMEPAGE="http://www.getmiro.com/"
|
||||
DOWNLOAD="http://ftp.osuosl.org/pub/pculture.org/miro/src/Miro-2.0.4.tar.gz"
|
||||
MD5SUM="e6cf48252496b2bddd290f375fc0ca33"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
APPROVED="dsomero"
|
|
@ -1,18 +0,0 @@
|
|||
Miro is a free Internet television application for the online
|
||||
Democracy Network.
|
||||
|
||||
Requires Boost, gst-python, and gnome-python-extras.
|
||||
|
||||
Optional dependencies are libtorrent-rasterbar and notify-python.
|
||||
Miro comes with libtorrent-rasterbar 0.14.2 and will not interfere
|
||||
with libtorrent-rasterbar if installed later.
|
||||
|
||||
See README.runtime for addtional runtime requirements.
|
||||
|
||||
Note:
|
||||
The Miro slackbuild aborts when trying to look at the pm-utils.pc file.
|
||||
This sed statement corrects the syntax error if it sees it in the
|
||||
pm-utils.pc file. If you haven't fixed it yet, then your welcome!!! :-)
|
||||
|
||||
sed -i 's|)|}|' /usr/lib/pkgconfig/pm-utils.pc 2>/dev/null
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
Gstreamer is the default video renderer for Miro. Gstreamer requires additional
|
||||
python plugins to extend video and audio capabilities.
|
||||
|
||||
For good codec support there is gst-plugins-good, gst-plugins-bad, gst-ffmpeg and
|
||||
gst-plugins-ugly.
|
||||
|
||||
Xine is the other video renderer. The option to change renderer can also be made
|
||||
after installation in the Video->Options->Playback menu.
|
||||
|
||||
Xine uses the "xv" driver by default. If you find instability issues with "xv"
|
||||
then you can try "xshm" or "opengl". You can test out the driver by running from
|
||||
the command line and passing:
|
||||
|
||||
miro --set=renderer=xine --set=xine-driver=xshm
|
||||
|
||||
or, alternatively
|
||||
|
||||
miro --set=renderer=xine --set=xine-driver=opengl
|
||||
|
||||
These settings will stay persistent on next program launch.
|
||||
|
||||
Note: The linux version of Miro doesn't support the flash-plugin, so video from sites
|
||||
like Hulu and Youtube won't display inside the Miro player.
|
|
@ -1,7 +0,0 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
|
@ -1,10 +0,0 @@
|
|||
diff -Naur Miro-2.0.4.orig/platform/gtk-x11/plat/renderers/gstreamerrenderer.py Miro-2.0.4/platform/gtk-x11/plat/renderers/gstreamerrenderer.py
|
||||
--- Miro-2.0.4.orig/platform/gtk-x11/plat/renderers/gstreamerrenderer.py 2009-03-30 20:04:53.000000000 +0000
|
||||
+++ Miro-2.0.4/platform/gtk-x11/plat/renderers/gstreamerrenderer.py 2009-04-13 08:12:45.000000000 +0000
|
||||
@@ -281,4 +281,5 @@
|
||||
position + (rate * gst.SECOND))
|
||||
|
||||
def movie_data_program_info(self, movie_path, thumbnail_path):
|
||||
- return ((sys.executable, 'plat/renderers/gst_extractor.py', movie_path, thumbnail_path), None)
|
||||
+ extractor_path = os.path.join(os.path.split(__file__)[0], "gst_extractor.py")
|
||||
+ return ((sys.executable, extractor_path, movie_path, thumbnail_path), None)
|
|
@ -1,17 +0,0 @@
|
|||
diff -Naur Miro-2.0.3.orig/platform/gtk-x11/setup.py Miro-2.0.3/platform/gtk-x11/setup.py
|
||||
--- Miro-2.0.3.orig/platform/gtk-x11/setup.py 2009-03-12 20:24:46.000000000 +0000
|
||||
+++ Miro-2.0.3/platform/gtk-x11/setup.py 2009-03-15 12:46:33.000000000 +0000
|
||||
@@ -466,8 +466,12 @@
|
||||
xpcom_lib = 'firefox-xpcom'
|
||||
gtkmozembed_lib = 'firefox-gtkmozembed'
|
||||
|
||||
+ elif re.search("^seamonkey-xpcom", packages, re.MULTILINE):
|
||||
+ xpcom_lib = 'seamonkey-xpcom'
|
||||
+ gtkmozembed_lib = 'seamonkey-gtkmozembed'
|
||||
+
|
||||
else:
|
||||
- sys.exit("Can't find libxul, xulrunner-xpcom, mozilla-xpcom or firefox-xpcom")
|
||||
+ sys.exit("Can't find libxul, xulrunner-xpcom, mozilla-xpcom, firefox-xpcom or seamonkey-xpcom")
|
||||
|
||||
print "using xpcom_lib: ", repr(xpcom_lib)
|
||||
print "using gtkmozembed_lib: ", repr(gtkmozembed_lib)
|
|
@ -1,14 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
Miro: Miro (Online media aggregator)
|
||||
Miro:
|
||||
Miro: Miro is a free Internet television application for the online
|
||||
Miro: Democracy Network.
|
||||
Miro:
|
||||
Miro: Homepage: http://www.getmiro.com/
|
Loading…
Reference in a new issue