libraries/gtkhtml: Removed (no longer needed)

This is an older version of gtkhtml that was only needed
by gnucash.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2013-11-23 23:19:44 -06:00
parent 2c2d8a1c58
commit 7363bdb9c8
6 changed files with 0 additions and 276 deletions

View file

@ -1,3 +0,0 @@
GtkHTML is a lightweight HTML rendering/printing/editing engine. It
was originally based on KHTMLW, part of the KDE project, but is now
being developed independently.

View file

@ -1,52 +0,0 @@
Index: gtkhtml-3.18.3/a11y/text.c
===================================================================
--- gtkhtml-3.18.3.orig/a11y/text.c
+++ gtkhtml-3.18.3/a11y/text.c
@@ -27,7 +27,7 @@
#include <atk/atkhypertext.h>
#include <atk/atkhyperlink.h>
#include <glib/gi18n-lib.h>
-#include <glib/gmacros.h>
+#include <glib.h>
#include <pango/pango.h>
#include "gtkhtml.h"
#include "htmlengine.h"
Index: gtkhtml-3.18.3/gtkhtml/htmlobject.c
===================================================================
--- gtkhtml-3.18.3.orig/gtkhtml/htmlobject.c
+++ gtkhtml-3.18.3/gtkhtml/htmlobject.c
@@ -23,8 +23,7 @@
#include <config.h>
#include <string.h>
-#include <glib/gdataset.h>
-#include <glib/gquark.h>
+#include <glib.h>
#include "htmlclue.h"
#include "htmlclueflow.h"
Index: gtkhtml-3.18.3/gtkhtml/test-stress.c
===================================================================
--- gtkhtml-3.18.3.orig/gtkhtml/test-stress.c
+++ gtkhtml-3.18.3/gtkhtml/test-stress.c
@@ -1,7 +1,7 @@
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
-#include <glib/gstring.h>
+#include <glib.h>
#include <gtk/gtkmain.h>
#include <gtk/gtkscrolledwindow.h>
#include <gtk/gtkwindow.h>
Index: gtkhtml-3.18.3/gtkhtml/test-suite.c
===================================================================
--- gtkhtml-3.18.3.orig/gtkhtml/test-suite.c
+++ gtkhtml-3.18.3/gtkhtml/test-suite.c
@@ -1,6 +1,6 @@
#include <string.h>
#include <stdio.h>
-#include <glib/gstring.h>
+#include <glib.h>
#include <gtk/gtkmain.h>
#include <gtk/gtkscrolledwindow.h>
#include <gtk/gtkwindow.h>

View file

@ -1,84 +0,0 @@
diff -Nur gtkhtml-3.18.3.orig/a11y/Makefile.am gtkhtml-3.18.3/a11y/Makefile.am
--- gtkhtml-3.18.3.orig/a11y/Makefile.am 2008-04-04 04:06:50.000000000 -0500
+++ gtkhtml-3.18.3/a11y/Makefile.am 2009-06-03 10:27:22.879317264 -0500
@@ -2,7 +2,7 @@
INCLUDES = -I$(top_srcdir)/gtkhtml $(GTKHTML_CFLAGS) $(I18N_LIB_CFLAGS)
-AM_CFLAGS = $(GAIL_CFLAGS) -DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1
+AM_CFLAGS = $(GAIL_CFLAGS) -DGDK_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1
noinst_LTLIBRARIES = libgtkhtml-a11y.la
diff -Nur gtkhtml-3.18.3.orig/a11y/Makefile.in gtkhtml-3.18.3/a11y/Makefile.in
--- gtkhtml-3.18.3.orig/a11y/Makefile.in 2008-06-29 00:41:02.000000000 -0500
+++ gtkhtml-3.18.3/a11y/Makefile.in 2009-06-03 10:28:28.053709547 -0500
@@ -244,7 +244,7 @@
top_srcdir = @top_srcdir@
END =
INCLUDES = -I$(top_srcdir)/gtkhtml $(GTKHTML_CFLAGS) $(I18N_LIB_CFLAGS)
-AM_CFLAGS = $(GAIL_CFLAGS) -DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1
+AM_CFLAGS = $(GAIL_CFLAGS) -DGDK_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1
noinst_LTLIBRARIES = libgtkhtml-a11y.la
libgtkhtml_a11y_la_SOURCES = \
cell.h \
diff -Nur gtkhtml-3.18.3.orig/components/html-editor/Makefile.am gtkhtml-3.18.3/components/html-editor/Makefile.am
--- gtkhtml-3.18.3.orig/components/html-editor/Makefile.am 2008-04-04 04:06:35.000000000 -0500
+++ gtkhtml-3.18.3/components/html-editor/Makefile.am 2009-06-03 10:29:16.240612316 -0500
@@ -28,7 +28,6 @@
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\"\
-DGLADE_DATADIR=\"$(gladedir)\" \
-DGDK_DISABLE_DEPRECATED=1 \
- -DG_DISABLE_DEPRECATED=1 \
-DPREFIX=\""$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DDATADIR=\""$(datadir)"\" \
diff -Nur gtkhtml-3.18.3.orig/components/html-editor/Makefile.in gtkhtml-3.18.3/components/html-editor/Makefile.in
--- gtkhtml-3.18.3.orig/components/html-editor/Makefile.in 2008-06-29 00:41:03.000000000 -0500
+++ gtkhtml-3.18.3/components/html-editor/Makefile.in 2009-06-03 10:29:41.423922363 -0500
@@ -328,7 +328,6 @@
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\"\
-DGLADE_DATADIR=\"$(gladedir)\" \
-DGDK_DISABLE_DEPRECATED=1 \
- -DG_DISABLE_DEPRECATED=1 \
-DPREFIX=\""$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DDATADIR=\""$(datadir)"\" \
diff -Nur gtkhtml-3.18.3.orig/gtkhtml/Makefile.am gtkhtml-3.18.3/gtkhtml/Makefile.am
--- gtkhtml-3.18.3.orig/gtkhtml/Makefile.am 2008-04-04 04:06:49.000000000 -0500
+++ gtkhtml-3.18.3/gtkhtml/Makefile.am 2009-06-03 10:30:32.202760845 -0500
@@ -20,7 +20,6 @@
AM_CFLAGS = \
-DGDK_DISABLE_DEPRECATED=1 \
- -DG_DISABLE_DEPRECATED=1 \
-DGNOME_DISABLE_DEPRECATED=1 \
-DPREFIX=\""$(prefix)"\" \
-DLIBDIR=\""$(datadir)"\" \
@@ -30,7 +29,6 @@
-DGTKHTML_DATADIR=\""$(gtkhtml_data)"\" \
-DGLADE_DATADIR=\"$(gladedir)\" \
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\"
-# -DGTK_DISABLE_DEPRECATED=1
lib_LTLIBRARIES = libgtkhtml-3.14.la
diff -Nur gtkhtml-3.18.3.orig/gtkhtml/Makefile.in gtkhtml-3.18.3/gtkhtml/Makefile.in
--- gtkhtml-3.18.3.orig/gtkhtml/Makefile.in 2008-06-29 00:41:03.000000000 -0500
+++ gtkhtml-3.18.3/gtkhtml/Makefile.in 2009-06-03 10:30:53.710234099 -0500
@@ -384,7 +384,6 @@
AM_CFLAGS = \
-DGDK_DISABLE_DEPRECATED=1 \
- -DG_DISABLE_DEPRECATED=1 \
-DGNOME_DISABLE_DEPRECATED=1 \
-DPREFIX=\""$(prefix)"\" \
-DLIBDIR=\""$(datadir)"\" \
@@ -395,7 +394,6 @@
-DGLADE_DATADIR=\"$(gladedir)\" \
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\"
-# -DGTK_DISABLE_DEPRECATED=1
lib_LTLIBRARIES = libgtkhtml-3.14.la
libgtkhtmldir = $(includedir)/libgtkhtml-@GTKHTML_API_VERSION@/gtkhtml

View file

@ -1,108 +0,0 @@
#!/bin/sh
# Slackware build script for gtkhtml
# Copyright 2009 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gtkhtml
VERSION=3.18.3
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Allow deprecated functions so the build can finish
patch -p1 < $CWD/gtkhtml-3.18.3-allow_deprecated_functions.diff || exit 1
# Starting with glib 2.32 it is now mandatory to
# include glib.h instead of individual headers.
patch -p1 -i $CWD/glib-single-include.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--disable-static \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS BUGS COPYING* ChangeLog INSTALL NEWS README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="gtkhtml"
VERSION="3.18.3"
HOMEPAGE="http://www.gnome.org/"
DOWNLOAD="http://ftp.acc.umu.se/pub/GNOME/sources/gtkhtml/3.18/gtkhtml-3.18.3.tar.bz2"
MD5SUM="4dae02a10f05fbca1cfd3bb5336f9273"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libgnomeprintui libgnomeui"
MAINTAINER="Vincent Batts"
EMAIL="vbatts@hashbangbash.com"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
gtkhtml: gtkhtml (html library for GTK framework)
gtkhtml:
gtkhtml: GtkHTML is a lightweight HTML rendering/printing/editing engine.
gtkhtml:
gtkhtml: It was originally based on KHTMLW, part of the KDE project, but
gtkhtml: is now being developed independently.
gtkhtml:
gtkhtml: http://www.gnome.org/
gtkhtml:
gtkhtml:
gtkhtml: