mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
misc/zyGrib: Added (Visualization of meteo data)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
38ed2ee04c
commit
733e5ec566
8 changed files with 177 additions and 0 deletions
23
misc/zyGrib/Makefile.patch
Normal file
23
misc/zyGrib/Makefile.patch
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
--- Makefile.orig 2011-09-10 06:59:30.000000000 +0000
|
||||||
|
+++ Makefile 2011-11-23 14:49:17.000000000 +0000
|
||||||
|
@@ -58,15 +58,15 @@
|
||||||
|
install: zyGrib
|
||||||
|
mkdir -p $(INSTALLDIR)
|
||||||
|
mkdir -p $(INSTALLDIR)/bin
|
||||||
|
+ mkdir -p $(INSTALLDIR)/../../usr/bin
|
||||||
|
cp -a data $(INSTALLDIR)
|
||||||
|
cp -a grib $(INSTALLDIR)
|
||||||
|
rm -f ./zyGrib
|
||||||
|
rm -f $(INSTALLDIR)/bin/zyGrib
|
||||||
|
cp -a src/zyGrib $(INSTALLDIR)/bin
|
||||||
|
- echo "#!/bin/bash" >> ./zyGrib
|
||||||
|
- echo "cd $(INSTALLDIR)" >> ./zyGrib
|
||||||
|
- echo 'bin/zyGrib $$*' >> ./zyGrib
|
||||||
|
- chmod 755 ./zyGrib
|
||||||
|
- cp -af zyGrib $(INSTALLDIR)
|
||||||
|
+ echo "#!/bin/bash" >> $(INSTALLDIR)/../../usr/bin/zyGrib
|
||||||
|
+ echo "cd /opt/zyGrib" >> $(INSTALLDIR)/../../usr/bin/zyGrib
|
||||||
|
+ echo 'bin/zyGrib $$*' >> $(INSTALLDIR)/../../usr/bin/zyGrib
|
||||||
|
+ chmod 755 $(INSTALLDIR)/../../usr/bin/zyGrib
|
||||||
|
|
||||||
|
|
22
misc/zyGrib/README
Normal file
22
misc/zyGrib/README
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
zyGrib is a Visualization of meteo data from files in GRIB Format 1
|
||||||
|
|
||||||
|
Available meteo infos (W and CH - *):
|
||||||
|
|
||||||
|
Surface Pressure (*)
|
||||||
|
Wind 10 m above mean sea level (*)
|
||||||
|
Wind gust (*)
|
||||||
|
Temperature 2 m above mean sea level (*)
|
||||||
|
Potential Temperature min - max 2 m above mean sea level
|
||||||
|
Relative Humidity 2 m above mean sea level (*)
|
||||||
|
Total Precipitation (mm/h) (*)
|
||||||
|
Total Cloud Cover (%) (*)
|
||||||
|
Dew Point 2 m above mean sea level (*)
|
||||||
|
0C Isotherm
|
||||||
|
Snow (Depth - Risk)
|
||||||
|
CAPE (convective available potential energy) at earth level (*)
|
||||||
|
Data in altitude (850 (*), 700 (*), 500 (*), 300, 200 hPa) : geopotential
|
||||||
|
altitude, wind (*), temperature (*), theta-e, relative humidity (*).
|
||||||
|
Waves : height, direction, period, whitecap probability, for wind waves,
|
||||||
|
swell, and for significant, maximum, primary, secondary waves.
|
||||||
|
|
||||||
|
This needs qwt.
|
3
misc/zyGrib/doinst.sh
Normal file
3
misc/zyGrib/doinst.sh
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
if [ -x /usr/bin/update-desktop-database ]; then
|
||||||
|
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||||
|
fi
|
19
misc/zyGrib/slack-desc
Normal file
19
misc/zyGrib/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
# HOW TO EDIT THIS FILE:
|
||||||
|
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||||
|
# up the first '|' above the ':' following the base package name, and the '|'
|
||||||
|
# on the right side marks the last column you can put a character in. You must
|
||||||
|
# make exactly 11 lines for the formatting to be correct. It's also
|
||||||
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|
|------handy-ruler-----------------------------------------------------|
|
||||||
|
zyGrib: zyGrib (Visualization of meteo data from files in GRIB Format 1)
|
||||||
|
zyGrib:
|
||||||
|
zyGrib: Homepage: http://www.zygrib.org/
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
||||||
|
zyGrib:
|
90
misc/zyGrib/zyGrib.SlackBuild
Normal file
90
misc/zyGrib/zyGrib.SlackBuild
Normal file
|
@ -0,0 +1,90 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Slackware build script for appname
|
||||||
|
|
||||||
|
# Copyright 2011 Chris Abela, Malta
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
# permitted provided that the following conditions are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of this script must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||||
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||||
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||||
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||||
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||||
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||||
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||||
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||||
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
PRGNAM=zyGrib
|
||||||
|
VERSION=${VERSION:-5.0.6}
|
||||||
|
BUILD=${BUILD:-1}
|
||||||
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
if [ -z "$ARCH" ]; then
|
||||||
|
case "$( uname -m )" in
|
||||||
|
i?86) ARCH=i486 ;;
|
||||||
|
arm*) ARCH=arm ;;
|
||||||
|
*) ARCH=$( uname -m ) ;;
|
||||||
|
esac
|
||||||
|
fi
|
||||||
|
|
||||||
|
CWD=$(pwd)
|
||||||
|
TMP=${TMP:-/tmp/SBo}
|
||||||
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
|
# zyGrib lacks configure scripts so the options are limited
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
# In case the source was fetched with wget or some other downloader:
|
||||||
|
SRCTAR=$PRGNAM-$VERSION.tgz
|
||||||
|
[ -e "getfile.php?file=$SRCTAR" ] && SRCTAR="getfile.php?file=$SRCTAR"
|
||||||
|
|
||||||
|
rm -rf $PKG
|
||||||
|
mkdir -p $TMP $PKG/opt/$PRGNAM $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
rm -rf $PRGNAM-$VERSION
|
||||||
|
tar xvf $CWD/$SRCTAR
|
||||||
|
cd $PRGNAM-$VERSION
|
||||||
|
chown -R root:root .
|
||||||
|
find . \
|
||||||
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||||
|
-exec chmod 755 {} \; -o \
|
||||||
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
|
# src/zyGrib.pro is looking for the wrong qwt library
|
||||||
|
sed -i 's/lqwt-qt4/lqwt/' src/zyGrib.pro
|
||||||
|
|
||||||
|
# Makefile installs a good local installation, but we need a system installation
|
||||||
|
patch -p0 < $CWD/Makefile.patch
|
||||||
|
|
||||||
|
# See http://www.zygrib.org/forum/viewtopic.php?f=3&t=221&view=print
|
||||||
|
[ "$ARCH" = x86_64 ] && make veryclean
|
||||||
|
make
|
||||||
|
make install INSTALLDIR=$PKG/opt/$PRGNAM
|
||||||
|
|
||||||
|
mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
|
||||||
|
cat $CWD/zyGrib.desktop > $PKG/usr/share/applications/zyGrib.desktop
|
||||||
|
cat $CWD/zyGrib.png > $PKG/usr/share/pixmaps/zyGrib.png
|
||||||
|
|
||||||
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
mkdir -p $PKG/install
|
||||||
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||||
|
|
||||||
|
cd $PKG
|
||||||
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
misc/zyGrib/zyGrib.desktop
Normal file
10
misc/zyGrib/zyGrib.desktop
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
[Desktop Entry]
|
||||||
|
Name=zyGrib
|
||||||
|
GenericName=GRIB file viewer
|
||||||
|
Comment=GRIB file viewer
|
||||||
|
Exec=zyGrib
|
||||||
|
Icon=zyGrib
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
StartupNotify=true
|
||||||
|
Categories=Network;
|
10
misc/zyGrib/zyGrib.info
Normal file
10
misc/zyGrib/zyGrib.info
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
PRGNAM="zyGrib"
|
||||||
|
VERSION="5.0.6"
|
||||||
|
HOMEPAGE="http://www.zygrib.org/"
|
||||||
|
DOWNLOAD="http://www.zygrib.org/getfile.php?file=zyGrib-5.0.6.tgz"
|
||||||
|
MD5SUM="ce2811a7abe9cc8f6703374130add902"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
|
MAINTAINER="Chris Abela"
|
||||||
|
EMAIL="kristofru@gmail.com"
|
||||||
|
APPROVED="Niels Horn"
|
BIN
misc/zyGrib/zyGrib.png
Normal file
BIN
misc/zyGrib/zyGrib.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 985 B |
Loading…
Reference in a new issue