libraries/libbonobo: Fix for the newer glib.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2013-05-29 19:27:37 +02:00 committed by Robby Workman
parent deb7c4bbec
commit 720f027099
2 changed files with 41 additions and 1 deletions

View file

@ -24,7 +24,7 @@
PRGNAM=libbonobo
VERSION=${VERSION:-2.32.1}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -69,6 +69,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Apply patch from upstream to build with the newer glib
patch -p1 < $CWD/remove_use_of_G_DISABLE_DEPRECATED.patch
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \

View file

@ -0,0 +1,35 @@
From fef13a371fc91f6d9b42518126c2a8b459fdf0e8 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Thu, 02 May 2013 18:17:38 +0000
Subject: Remove use of G_DISABLE_DEPRECATED
This now trips up on GStaticRecMutex; I'm not going to bother to port,
realistically no one is actively maintaining this code anymore.
---
diff --git a/activation-server/Makefile.am b/activation-server/Makefile.am
index efb18a8..ffa90f6 100644
--- a/activation-server/Makefile.am
+++ b/activation-server/Makefile.am
@@ -17,7 +17,6 @@ INCLUDES= \
$(SERVER_CFLAGS) \
$(WARN_CFLAGS) \
-DSERVER_CONFDIR=\"$(sysconfdir)\" \
- -DG_DISABLE_DEPRECATED \
-DG_LOG_DOMAIN=\"Bonobo-Activation-Server\" \
$(NULL)
diff --git a/configure.in b/configure.in
index 70a4e26..6be2bca 100644
--- a/configure.in
+++ b/configure.in
@@ -132,7 +132,7 @@ AC_SUBST(SERVER_LIBS)
AC_SUBST(SERVER_CFLAGS)
if test "$enable_maintainer_mode" = "yes"; then
- DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES"
+ DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_SINGLE_INCLUDES"
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
--
cgit v0.9.2