mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
multimedia/kaffeine: Updated for version 2.0.18.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
409c72e83f
commit
70f5b1f3ea
5 changed files with 23 additions and 40 deletions
|
@ -1,24 +0,0 @@
|
|||
From 4a1a90ee1b2b4d13302046f043adf1c2a1de758d Mon Sep 17 00:00:00 2001
|
||||
From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
|
||||
Date: Thu, 26 Nov 2015 15:36:26 +0100
|
||||
Subject: [PATCH] Explicitly include CheckIncludeFiles.
|
||||
|
||||
This fixes the build with CMake 3.4.0. We were calling check_include_files()
|
||||
and implicitly relying on CheckIncludeFiles being included.
|
||||
---
|
||||
CMakeLists.txt | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index d9be8db..b74b44d 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -21,6 +21,7 @@ if(STRICT_BUILD)
|
||||
-DQT_NO_URL_CAST_FROM_STRING -DQT_STRICT_ITERATORS)
|
||||
endif(STRICT_BUILD)
|
||||
|
||||
+include(CheckIncludeFiles)
|
||||
check_include_files(${CMAKE_CURRENT_SOURCE_DIR}/include/frontend.h HAVE_DVB)
|
||||
|
||||
if(NOT HAVE_DVB)
|
||||
|
|
@ -1,3 +1,11 @@
|
|||
Kaffeine is a full featured Multimedia-Player for KDE.
|
||||
Kaffeine is a media player. What makes it different from the others is
|
||||
its excellent support of digital TV (DVB). Kaffeine has user-friendly
|
||||
interface, so that even first time users can start immediately playing
|
||||
their movies: from DVD (including DVD menus, titles, chapters, etc.),
|
||||
VCD, or a file.
|
||||
|
||||
Kaffeine is a KDE Application
|
||||
Kaffeine requires KDE Frameworks packages provided by Slackware
|
||||
|
||||
Kaffeine is free software distributed under the terms of the
|
||||
GNU General Public Licence.
|
||||
|
|
|
@ -25,7 +25,7 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=kaffeine
|
||||
VERSION=${VERSION:-1.3.1}
|
||||
VERSION=${VERSION:-2.0.18}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -72,7 +72,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$SRC_VERSION
|
||||
tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
|
||||
tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.xz
|
||||
cd $PRGNAM-$SRC_VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
@ -81,7 +81,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/CMakeLists.patch
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
@ -100,7 +99,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
|
|||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING* Changelog NOTES README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING* Changelog NOTES README.md $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="kaffeine"
|
||||
VERSION="1.3.1"
|
||||
HOMEPAGE="http://kaffeine.sourceforge.net"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/kaffeine/kaffeine-1.3.1.tar.gz"
|
||||
MD5SUM="f2308cf7abf5ec7ad5c724593594c198"
|
||||
VERSION="2.0.18"
|
||||
HOMEPAGE="https://apps.kde.org/kaffeine/"
|
||||
DOWNLOAD="https://download.kde.org/stable/kaffeine/kaffeine-2.0.18.tar.xz"
|
||||
MD5SUM="185cd114e1ebcf15b98674e872a53556"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="vlc"
|
||||
|
|
|
@ -6,14 +6,14 @@
|
|||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
kaffeine: kaffeine (multimedia player for kde)
|
||||
kaffeine: Kaffeine (Multimedia player for KDE)
|
||||
kaffeine:
|
||||
kaffeine: Kaffeine is a full featured Multimedia-Player for KDE.
|
||||
kaffeine: Kaffeine is a media player. What makes it different from the others is
|
||||
kaffeine: its excellent support of digital TV (DVB). Kaffeine has user-friendly
|
||||
kaffeine: interface, so that even first time users can start immediately playing
|
||||
kaffeine: their movies: from DVD (including DVD menus, titles, chapters, etc.),
|
||||
kaffeine: VCD, or a file.
|
||||
kaffeine: Kaffeine is free software distributed under the terms of the
|
||||
kaffeine: GNU General Public Licence.
|
||||
kaffeine:
|
||||
kaffeine: Homepage: http://kaffeine.sourceforge.net
|
||||
kaffeine:
|
||||
kaffeine:
|
||||
kaffeine:
|
||||
kaffeine:
|
||||
kaffeine: homepage: https://apps.kde.org/kaffeine/
|
||||
|
|
Loading…
Reference in a new issue