libraries/SuiteSparse_config: Updated for version 4.2.1.

(renamed from UFconfig)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Kyle Guinn 2013-11-23 22:44:22 -06:00 committed by Robby Workman
parent d336b41477
commit 6dfc3f0199
5 changed files with 226 additions and 0 deletions

View file

@ -0,0 +1,5 @@
SuiteSparse_config is a common configuration library for the SuiteSparse
family of sparse matrix packages, including SuiteSparseQR, AMD, CAMD, COLAMD,
CCOLAMD, CHOLMOD, KLU, BTF, LDL, CXSparse, RBio, and UMFPACK.
This library was formerly named UFconfig.

View file

@ -0,0 +1,107 @@
#!/bin/sh
# Slackware build script for SuiteSparse_config
# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=SuiteSparse_config
VERSION=${VERSION:-4.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="README.txt"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
# Recommended by SuiteSparse
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/autotoolize.diff
autoreconf -vif
CFLAGS="$SLKCFLAGS" \
FFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-shared \
--disable-static \
--disable-dependency-tracking \
--build=$ARCH-slackware-linux
make
make check
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,10 @@
PRGNAM="SuiteSparse_config"
VERSION="4.2.1"
HOMEPAGE="https://www.cise.ufl.edu/research/sparse/SuiteSparse_config/"
DOWNLOAD="https://www.cise.ufl.edu/research/sparse/SuiteSparse_config/SuiteSparse_config-4.2.1.tar.gz"
MD5SUM="f9d709f442ab13e0cf0f53d6b516abd1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"

View file

@ -0,0 +1,85 @@
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = xerbla
+
+EXTRA_DIST = README.txt
+
+# Octave doesn't find SuiteSparse_config.h if it's placed in a non-default search path.
+# Don't put it in a subdirectory for now. Update suitesparseconfig.pc.in if this changes.
+#pkginclude_HEADERS = SuiteSparse_config.h
+include_HEADERS = SuiteSparse_config.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = suitesparseconfig.pc
+
+lib_LTLIBRARIES = libsuitesparseconfig.la
+libsuitesparseconfig_la_SOURCES = SuiteSparse_config.c
+libsuitesparseconfig_la_LDFLAGS = -no-undefined -version-number 4:2:1
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,32 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([SuiteSparse_config],[4.2.1],[DrTimothyAldenDavis@gmail.com],[suitesparseconfig],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([SuiteSparse_config.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
+# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_CC
+AC_PROG_F77
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([limits.h stdlib.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([clock_gettime])
+
+AC_CONFIG_FILES([
+ suitesparseconfig.pc
+ Makefile
+ xerbla/Makefile])
+AC_OUTPUT
diff --git a/suitesparseconfig.pc.in b/suitesparseconfig.pc.in
new file mode 100644
--- /dev/null
+++ b/suitesparseconfig.pc.in
@@ -0,0 +1,11 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: @PACKAGE_NAME@
+Description: SuiteSparse common library
+Version: @PACKAGE_VERSION@
+URL: @PACKAGE_URL@
+Libs: -L${libdir} -lsuitesparseconfig
+Cflags: -I${includedir}
diff --git a/xerbla/Makefile.am b/xerbla/Makefile.am
new file mode 100644
--- /dev/null
+++ b/xerbla/Makefile.am
@@ -0,0 +1,7 @@
+noinst_HEADERS = xerbla.h
+noinst_LTLIBRARIES = libxerbla.la libcerbla.la
+
+libxerbla_la_SOURCES = xerbla.f
+libxerbla_la_FFLAGS = $(AM_FFLAGS)
+libcerbla_la_SOURCES = xerbla.c
+libcerbla_la_CFLAGS = $(AM_CFLAGS)

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
SuiteSparse_config: SuiteSparse_config (SuiteSparse common library)
SuiteSparse_config:
SuiteSparse_config: SuiteSparse_config is a common configuration library for the
SuiteSparse_config: SuiteSparse family of sparse matrix packages, including SuiteSparseQR,
SuiteSparse_config: AMD, CAMD, COLAMD, CCOLAMD, CHOLMOD, KLU, BTF, LDL, CXSparse, RBio,
SuiteSparse_config: and UMFPACK.
SuiteSparse_config:
SuiteSparse_config:
SuiteSparse_config:
SuiteSparse_config:
SuiteSparse_config: