games/noteye: Added (roguelike frontend).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
B. Watson 2014-09-05 06:59:14 +07:00 committed by Willy Sudiarto Raharjo
parent 8557e772da
commit 699c963fde
14 changed files with 894 additions and 0 deletions

17
games/noteye/README Normal file
View file

@ -0,0 +1,17 @@
noteye (fontend for roguelike games; includes hydraslayer)
Necklace of the Eye (NotEye in short) is a roguelike frontend. It can
modify the output of console and libtcod roguelikes, and it also works
as a library which allows to easily port old ASCII roguelikes like ADOM
into 21st century.
Hydra Slayer is a Roguelike game focused on one thing: slaying Hydras. It
is inspired by Greek mythology, Dungeon Crawl, MathRL seven day roguelike,
and some mathematical puzzles about brave heroes slaying many headed
beasts. Hydra Slayer features an original combat system, based on
mathematical puzzles. Since Hydra Slayer is a flagship roguelike for
NotEye, the two are distributed together.
NotEye can be used as a frontend for most of the rogue-like games on
SlackBuilds.org, such as rogue, adom, nethack... try searching the site
for "rogue".

13
games/noteye/doinst.sh Normal file
View file

@ -0,0 +1,13 @@
# create empty high score file only if there isn't one
if [ ! -e var/games/hydrascores.sav ]; then
touch var/games/hydrascores.sav
fi
# always reset perms/ownership
chmod 660 var/games/hydrascores.sav
chown root:games var/games/hydrascores.sav
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

222
games/noteye/hydraslayer.6 Normal file
View file

@ -0,0 +1,222 @@
.\" Automatically generated by Pod::Man 2.27 (Pod::Simple 3.28)
.\"
.\" Standard preamble:
.\" ========================================================================
.de Sp \" Vertical space (when we can't use .PP)
.if t .sp .5v
.if n .sp
..
.de Vb \" Begin verbatim text
.ft CW
.nf
.ne \\$1
..
.de Ve \" End verbatim text
.ft R
.fi
..
.\" Set up some character translations and predefined strings. \*(-- will
.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
.\" double quote, and \*(R" will give a right double quote. \*(C+ will
.\" give a nicer C++. Capital omega is used to do unbreakable dashes and
.\" therefore won't be available. \*(C` and \*(C' expand to `' in nroff,
.\" nothing in troff, for use with C<>.
.tr \(*W-
.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
.ie n \{\
. ds -- \(*W-
. ds PI pi
. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
. ds L" ""
. ds R" ""
. ds C` ""
. ds C' ""
'br\}
.el\{\
. ds -- \|\(em\|
. ds PI \(*p
. ds L" ``
. ds R" ''
. ds C`
. ds C'
'br\}
.\"
.\" Escape single quotes in literal strings from groff's Unicode transform.
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.\"
.\" If the F register is turned on, we'll generate index entries on stderr for
.\" titles (.TH), headers (.SH), subsections (.SS), items (.Ip), and index
.\" entries marked with X<> in POD. Of course, you'll have to process the
.\" output yourself in some meaningful fashion.
.\"
.\" Avoid warning from groff about undefined register 'F'.
.de IX
..
.nr rF 0
.if \n(.g .if rF .nr rF 1
.if (\n(rF:(\n(.g==0)) \{
. if \nF \{
. de IX
. tm Index:\\$1\t\\n%\t"\\$2"
..
. if !\nF==2 \{
. nr % 0
. nr F 2
. \}
. \}
.\}
.rr rF
.\"
.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
.\" Fear. Run. Save yourself. No user-serviceable parts.
. \" fudge factors for nroff and troff
.if n \{\
. ds #H 0
. ds #V .8m
. ds #F .3m
. ds #[ \f1
. ds #] \fP
.\}
.if t \{\
. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
. ds #V .6m
. ds #F 0
. ds #[ \&
. ds #] \&
.\}
. \" simple accents for nroff and troff
.if n \{\
. ds ' \&
. ds ` \&
. ds ^ \&
. ds , \&
. ds ~ ~
. ds /
.\}
.if t \{\
. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
.\}
. \" troff and (daisy-wheel) nroff accents
.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
.ds ae a\h'-(\w'a'u*4/10)'e
.ds Ae A\h'-(\w'A'u*4/10)'E
. \" corrections for vroff
.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
. \" for low resolution devices (crt and lpr)
.if \n(.H>23 .if \n(.V>19 \
\{\
. ds : e
. ds 8 ss
. ds o a
. ds d- d\h'-1'\(ga
. ds D- D\h'-1'\(hy
. ds th \o'bp'
. ds Th \o'LP'
. ds ae ae
. ds Ae AE
.\}
.rm #[ #] #H #V #F C
.\" ========================================================================
.\"
.IX Title "HYDRASLAYER 6"
.TH HYDRASLAYER 6 "2014-09-03" "15.6" "SlackBuilds.org"
.\" For nroff, turn off justification. Always turn off hyphenation; it makes
.\" way too many mistakes in technical documents.
.if n .ad l
.nh
.SH "NAME"
hydraslayer \- roguelike game with combat system based on math puzzles
.SH "SYNOPSIS"
.IX Header "SYNOPSIS"
\&\fBhydraslayer\fR \fI[\-options]\fR \fI[\-N \-noteye_options]\fR
.SH "DESCRIPTION"
.IX Header "DESCRIPTION"
Hydra Slayer is a Roguelike game focused on one thing: slaying Hydras. It
is inspired by Greek mythology, Dungeon Crawl, MathRL seven day roguelike,
and some mathematical puzzles about brave heroes slaying many headed
beasts. Hydra Slayer features an original combat system, based on
mathematical puzzles. Since Hydra Slayer is a flagship roguelike for
NotEye, the two are distributed together.
.PP
This man page doesn't attempt to document gameplay. To learn the game,
select the tutorial from the game's menu system.
.SH "OPTIONS"
.IX Header "OPTIONS"
Most options can also be set interactively in the game's menus.
.IP "\fB\-s\fR \fIseed\fR" 4
.IX Item "-s seed"
start a new game with random seed set to \fIseed\fR
.IP "\fB\-f\fR \fIsavefile\fR" 4
.IX Item "-f savefile"
use \fIsavefile\fR as filename for saving/loading
.IP "\fB\-b\fR \fIsavefile\fR" 4
.IX Item "-b savefile"
use \fIsavefile\fR as filename for backup cheat
.IP "\fB\-t\fR \fIlogfile\fR" 4
.IX Item "-t logfile"
use \fIlogfile\fR to save log files
.IP "\fB\-g\fR \fIscorefile\fR" 4
.IX Item "-g scorefile"
use \fIscorefile\fR as a scoretable
.IP "\fB\-c\fR \fIname\fR" 4
.IX Item "-c name"
use \fIname\fR as the character name
.IP "\fB\-u\fR \fIusername\fR" 4
.IX Item "-u username"
use \fIusername\fR as the username
.IP "\fB\-v\fR" 4
.IX Item "-v"
just view the Hall of Fame without playing the game
.IP "\fB\-l\fR \fIn\fR" 4
.IX Item "-l n"
output \fIn\fR last message in log files
.IP "\fB\-d\fR \fIlevel\fR" 4
.IX Item "-d level"
start in debug mode, from level \fIlevel\fR
.IP "\fB\-m\fR \fIdirs\fR" 4
.IX Item "-m dirs"
use \fIdirs\fR directional movement. Default is 4 (allows moving up/down/left/right),
6 is hex tile mode. Other allowed values are 3, 8, and 16.
.IP "\fB\-N\fR" 4
.IX Item "-N"
Any further arguments after \fB\-N\fR are passed to \fBnoteye\fR(6). One use of
this option is to play \fBhydraslayer\fR in a terminal, with \fBhydraslayer \-N \-\-ascii\fR.
.SH "FILES"
.IX Header "FILES"
.IP "~/.config/hydraslayerconfig.noe" 4
.IX Item "~/.config/hydraslayerconfig.noe"
Config file. Can be edited, but normally the in-game \s-1GUI\s0 is used.
.IP "~/.config/hydraslayer/hydralog.txt" 4
.IX Item "~/.config/hydraslayer/hydralog.txt"
Game log. Basically a copy of standard output and error during gameplay.
.IP "~/.config/hydraslayer/hydra.sav" 4
.IX Item "~/.config/hydraslayer/hydra.sav"
Default location for savegame files (change with \fB\-b\fR option).
.IP "/var/games/hydrascores.sav" 4
.IX Item "/var/games/hydrascores.sav"
Default location for score file (change with \fB\-g\fR option).
.SH "SEE ALSO"
.IX Header "SEE ALSO"
\&\fBnoteye\fR(6)
.PP
The game's homepage: http://www.roguetemple.com/z/hydra.php
.SH "AUTHORS"
.IX Header "AUTHORS"
hydraslayer and noteye are written by Zeno Rogue <zeno at attnam dot com>.
.PP
This man page written by B. Watson for the SlackBuilds.org project, and may be used
by anyone.

View file

@ -0,0 +1,8 @@
[Desktop Entry]
Name=Hydra Slayer
Exec=hydraslayer
Icon=hydraslayer
Type=Application
Terminal=false
Comment=Rogue-like Game
Categories=Game;RolePlaying;

Binary file not shown.

After

Width:  |  Height:  |  Size: 2.4 KiB

View file

@ -0,0 +1,116 @@
# pod source for hydraslayer man page. convert with:
# pod2man --stderr -s6 -cSlackBuilds.org -r15.6 hydraslayer.pod > hydraslayer.6
=head1 NAME
hydraslayer - roguelike game with combat system based on math puzzles
=head1 SYNOPSIS
B<hydraslayer> I<[-options]> I<[-N -noteye_options]>
=head1 DESCRIPTION
Hydra Slayer is a Roguelike game focused on one thing: slaying Hydras. It
is inspired by Greek mythology, Dungeon Crawl, MathRL seven day roguelike,
and some mathematical puzzles about brave heroes slaying many headed
beasts. Hydra Slayer features an original combat system, based on
mathematical puzzles. Since Hydra Slayer is a flagship roguelike for
NotEye, the two are distributed together.
This man page doesn't attempt to document gameplay. To learn the game,
select the tutorial from the game's menu system.
=head1 OPTIONS
Most options can also be set interactively in the game's menus.
=over 4
=item B<-s> I<seed>
start a new game with random seed set to I<seed>
=item B<-f> I<savefile>
use I<savefile> as filename for saving/loading
=item B<-b> I<savefile>
use I<savefile> as filename for backup cheat
=item B<-t> I<logfile>
use I<logfile> to save log files
=item B<-g> I<scorefile>
use I<scorefile> as a scoretable
=item B<-c> I<name>
use I<name> as the character name
=item B<-u> I<username>
use I<username> as the username
=item B<-v>
just view the Hall of Fame without playing the game
=item B<-l> I<n>
output I<n> last message in log files
=item B<-d> I<level>
start in debug mode, from level I<level>
=item B<-m> I<dirs>
use I<dirs> directional movement. Default is 4 (allows moving up/down/left/right),
6 is hex tile mode. Other allowed values are 3, 8, and 16.
=item B<-N>
Any further arguments after B<-N> are passed to B<noteye>(6). One use of
this option is to play B<hydraslayer> in a terminal, with B<hydraslayer -N --ascii>.
=back
=head1 FILES
=over 4
=item ~/.config/hydraslayerconfig.noe
Config file. Can be edited, but normally the in-game GUI is used.
=item ~/.config/hydraslayer/hydralog.txt
Game log. Basically a copy of standard output and error during gameplay.
=item ~/.config/hydraslayer/hydra.sav
Default location for savegame files (change with B<-b> option).
=item /var/games/hydrascores.sav
Default location for score file (change with B<-g> option).
=back
=head1 SEE ALSO
B<noteye>(6)
The game's homepage: http://www.roguetemple.com/z/hydra.php
=head1 AUTHORS
hydraslayer and noteye are written by Zeno Rogue <zeno at attnam dot com>.
This man page written by B. Watson for the SlackBuilds.org project, and may be used
by anyone.

206
games/noteye/noteye.6 Normal file
View file

@ -0,0 +1,206 @@
.\" Automatically generated by Pod::Man 2.27 (Pod::Simple 3.28)
.\"
.\" Standard preamble:
.\" ========================================================================
.de Sp \" Vertical space (when we can't use .PP)
.if t .sp .5v
.if n .sp
..
.de Vb \" Begin verbatim text
.ft CW
.nf
.ne \\$1
..
.de Ve \" End verbatim text
.ft R
.fi
..
.\" Set up some character translations and predefined strings. \*(-- will
.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
.\" double quote, and \*(R" will give a right double quote. \*(C+ will
.\" give a nicer C++. Capital omega is used to do unbreakable dashes and
.\" therefore won't be available. \*(C` and \*(C' expand to `' in nroff,
.\" nothing in troff, for use with C<>.
.tr \(*W-
.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
.ie n \{\
. ds -- \(*W-
. ds PI pi
. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
. ds L" ""
. ds R" ""
. ds C` ""
. ds C' ""
'br\}
.el\{\
. ds -- \|\(em\|
. ds PI \(*p
. ds L" ``
. ds R" ''
. ds C`
. ds C'
'br\}
.\"
.\" Escape single quotes in literal strings from groff's Unicode transform.
.ie \n(.g .ds Aq \(aq
.el .ds Aq '
.\"
.\" If the F register is turned on, we'll generate index entries on stderr for
.\" titles (.TH), headers (.SH), subsections (.SS), items (.Ip), and index
.\" entries marked with X<> in POD. Of course, you'll have to process the
.\" output yourself in some meaningful fashion.
.\"
.\" Avoid warning from groff about undefined register 'F'.
.de IX
..
.nr rF 0
.if \n(.g .if rF .nr rF 1
.if (\n(rF:(\n(.g==0)) \{
. if \nF \{
. de IX
. tm Index:\\$1\t\\n%\t"\\$2"
..
. if !\nF==2 \{
. nr % 0
. nr F 2
. \}
. \}
.\}
.rr rF
.\"
.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
.\" Fear. Run. Save yourself. No user-serviceable parts.
. \" fudge factors for nroff and troff
.if n \{\
. ds #H 0
. ds #V .8m
. ds #F .3m
. ds #[ \f1
. ds #] \fP
.\}
.if t \{\
. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
. ds #V .6m
. ds #F 0
. ds #[ \&
. ds #] \&
.\}
. \" simple accents for nroff and troff
.if n \{\
. ds ' \&
. ds ` \&
. ds ^ \&
. ds , \&
. ds ~ ~
. ds /
.\}
.if t \{\
. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
.\}
. \" troff and (daisy-wheel) nroff accents
.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
.ds ae a\h'-(\w'a'u*4/10)'e
.ds Ae A\h'-(\w'A'u*4/10)'E
. \" corrections for vroff
.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
. \" for low resolution devices (crt and lpr)
.if \n(.H>23 .if \n(.V>19 \
\{\
. ds : e
. ds 8 ss
. ds o a
. ds d- d\h'-1'\(ga
. ds D- D\h'-1'\(hy
. ds th \o'bp'
. ds Th \o'LP'
. ds ae ae
. ds Ae AE
.\}
.rm #[ #] #H #V #F C
.\" ========================================================================
.\"
.IX Title "NOTEYE 6"
.TH NOTEYE 6 "2014-09-03" "7.6" "SlackBuilds.org"
.\" For nroff, turn off justification. Always turn off hyphenation; it makes
.\" way too many mistakes in technical documents.
.if n .ad l
.nh
.SH "NAME"
noteye \- graphical front\-end for rogue\-like games
.SH "SYNOPSIS"
.IX Header "SYNOPSIS"
\&\fBnoteye\fR \fI[\-options]\fR
.SH "DESCRIPTION"
.IX Header "DESCRIPTION"
Necklace of the Eye (NotEye in short) is a roguelike frontend. It can
modify the output of console and libtcod roguelikes, and it also works
as a library which allows to easily port old \s-1ASCII\s0 roguelikes like \s-1ADOM\s0
into 21st century. NotEye is a complicated piece of software, and it is
constantly in development, and not documented very well.
.PP
This man page is incomplete and possibly inaccurate, but is perhaps
better than having no documentation at all.
.SH "OPTIONS"
.IX Header "OPTIONS"
.IP "\fB\-N\fR" 4
.IX Item "-N"
Arguments are ignored (or passed to the game being run) until \fB\-N\fR
is seen. The options below only have effect if \fB\-N\fR is given first.
.IP "\fB\-N0\fR" 4
.IX Item "-N0"
Cancel the effect of a previously-given \fB\-N\fR option: options after this
are either ignored or passed to the game being run.
.IP "\fB\-\-ascii\fR" 4
.IX Item "--ascii"
Run in a terminal with a curses-like interface, rather than an X11 \s-1GUI\s0 window.
.IP "\fB\-C\fR \fIconfig-file\fR" 4
.IX Item "-C config-file"
Use \fIconfig-file\fR as the config.
.IP "\fB\-C1\fR \fIconfig-file-format\fR" 4
.IX Item "-C1 config-file-format"
Use \fIconfig-file-format\fR as the config, replacing any occurrence of \s-1GAMENAME\s0
with the name of the game being run (set via the \fB\-X\fR option).
.IP "\fB\-tcod\fR" 4
.IX Item "-tcod"
Automatically connect to \s-1TCOD\s0 server. The server hostname/IP and port
number must be defined in the config (probably by entering them in the
noteye networking menu).
.IP "\fB\-server\fR" 4
.IX Item "-server"
Automatically connect to noteye server. As with \fB\-tcod\fR, the server must
already be defined.
.IP "\fB\-L\fR \fIlogfile\fR" 4
.IX Item "-L logfile"
Write game log to \fIlogfile\fR.
.IP "\fB\-X\fR \fIgame\fR" 4
.IX Item "-X game"
Launch this game, instead of displaying the main noteye menu.
.SH "FILES"
.IX Header "FILES"
\&\fB~/.config/noteye/config.noe\fR is the main config file. Editable, but
normally updated using noteye's built-in menus instead of a text editor.
.SH "SEE ALSO"
.IX Header "SEE ALSO"
\&\fBhydraslayer\fR(6),
\&\fBrogue\fR(6)
.PP
The noteye homepage: http://www.roguetemple.com/z/noteye.php
.SH "AUTHORS"
.IX Header "AUTHORS"
hydraslayer and noteye are written by Zeno Rogue <zeno at attnam dot com>.
.PP
This man page written by B. Watson for the SlackBuilds.org project, and may be used
by anyone.

View file

@ -0,0 +1,144 @@
#!/bin/sh
# Slackware build script for noteye
# Written by B. Watson (yalhcru@gmail.com)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=noteye
VERSION=${VERSION:-7.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
SRCVER=${VERSION/./}
# don't bother to extract these files from the archive, don't need them.
EXCLUDES="-x '*.dll' '*.exe' '*.bat' '*.mgw'"
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
eval unzip $CWD/$PRGNAM-$SRCVER.zip $EXCLUDES
cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# these don't need to be executable.
chmod 0644 common/*.noe games/*.noe
# On SBo we have rogue, which installs to /usr/games/rogue, and we also
# have yamagi-quake2 which installs a /usr/bin/rogue. Patch hardcodes
# /usr/games/rogue so selecting rogue from the menu doesn't start up a
# game of Quake 2, and changes the Ubuntu-specific apt-get instructions
# to Slack-specific sbopkg.
patch -p1 < $CWD/sbo.diff
# apparently Ubuntu has liblua-5.1.so, we just have liblua.so (same version).
sed -i 's,-llua5.1,-llua,g' src/Makefile
# store the writable high score file in /var, not /usr/share.
sed -i 's,"hydrascores.sav","/var/games/hydrascores.sav",' hydra/hydra.cpp
make -C src CFLAGS="$SLKCFLAGS"
# The 'make install' target is bad and wrong. Don't use.
PKGLIB=$PKG/usr/lib$LIBDIRSUFFIX
PKGSHARE=$PKG/usr/share/$PRGNAM
SOVER=$( echo $VERSION | cut -d. -f1 )
mkdir -p $PKG/usr/games $PKGLIB/$PRGNAM $PKGSHARE
# shared lib needs to be in /usr/lib(64), *not* /usr/share.
# also put the game binary in a private dir instead of /usr/share,
# and make it setgid games so the high score file can be updated.
install -s -m2755 -oroot -ggames $PRGNAM $PKGLIB/$PRGNAM/
install -s -m0755 lib$PRGNAM.so $PKGLIB/lib$PRGNAM.so.$VERSION
ln -s lib$PRGNAM.so.$VERSION $PKGLIB/lib$PRGNAM.so.$SOVER
ln -s lib$PRGNAM.so.$VERSION $PKGLIB/lib$PRGNAM.so
# scripts in /usr/share are OK
install -m0755 src/calleri.sh $PKGSHARE/caller.sh
install -m0755 src/rogue.sh $PKGSHARE/rogue
# we've already set the permissions to 0644 for the files here, not
# 744 as the install target does.
cp -r gfx sound common games $PKGSHARE
# install the headers, in case someone wants to package up a game that
# uses this.
mkdir -p $PKG/usr/include
install -m0644 src/$PRGNAM.h src/$PRGNAM-curses.h $PKG/usr/include
# wrapper scripts
install -m0755 src/hydraslayer.sh $PKG/usr/games/hydraslayer
install -m0755 src/$PRGNAM.sh $PKG/usr/games/$PRGNAM
# have the wrapper scripts look in the right place for the game binary
sed -i \
"s,^\$NOTEYEDIR/,/usr/lib$LIBDIRSUFFIX/$PRGNAM/," \
$PKG/usr/games/*
# don't install a highscore file here, see doinst.sh.
# icons extracted from the .ico files in the source, with icotool.
mkdir -p $PKG/usr/share/pixmaps
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
cat $CWD/hydraslayer.png > $PKG/usr/share/pixmaps/hydraslayer.png
# .desktop files written for this build.
mkdir -p $PKG/usr/share/applications
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
cat $CWD/hydraslayer.desktop > $PKG/usr/share/applications/hydraslayer.desktop
# man pages written for this build.
mkdir -p $PKG/usr/man/man6
gzip -9c $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz
gzip -9c $CWD/hydraslayer.6 > $PKG/usr/man/man6/hydraslayer.6.gz
# We don't need licenses/* as we're linking with system-wide libs, which
# have already installed their own licenses in /usr/doc.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING README.txt sample $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,8 @@
[Desktop Entry]
Name=Necklace of the Eye
Exec=noteye
Icon=noteye
Type=Application
Terminal=false
Comment=GUI for Rogue-like Games
Categories=Game;RolePlaying;

10
games/noteye/noteye.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="noteye"
VERSION="7.6"
HOMEPAGE="http://www.roguetemple.com/z/noteye.php"
DOWNLOAD="http://www.roguetemple.com/z/noteye-76.zip"
MD5SUM="650d0fd56b6d5ba72527737596c92766"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lua"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"

BIN
games/noteye/noteye.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 3.8 KiB

88
games/noteye/noteye.pod Normal file
View file

@ -0,0 +1,88 @@
# pod source for noteye man page. convert with:
# pod2man --stderr -s6 -cSlackBuilds.org -r7.6 noteye.pod > noteye.6
=head1 NAME
noteye - graphical front-end for rogue-like games
=head1 SYNOPSIS
B<noteye> I<[-options]>
=head1 DESCRIPTION
Necklace of the Eye (NotEye in short) is a roguelike frontend. It can
modify the output of console and libtcod roguelikes, and it also works
as a library which allows to easily port old ASCII roguelikes like ADOM
into 21st century. NotEye is a complicated piece of software, and it is
constantly in development, and not documented very well.
This man page is incomplete and possibly inaccurate, but is perhaps
better than having no documentation at all.
=head1 OPTIONS
=over 4
=item B<-N>
Arguments are ignored (or passed to the game being run) until B<-N>
is seen. The options below only have effect if B<-N> is given first.
=item B<-N0>
Cancel the effect of a previously-given B<-N> option: options after this
are either ignored or passed to the game being run.
=item B<--ascii>
Run in a terminal with a curses-like interface, rather than an X11 GUI window.
=item B<-C> I<config-file>
Use I<config-file> as the config.
=item B<-C1> I<config-file-format>
Use I<config-file-format> as the config, replacing any occurrence of GAMENAME
with the name of the game being run (set via the B<-X> option).
=item B<-tcod>
Automatically connect to TCOD server. The server hostname/IP and port
number must be defined in the config (probably by entering them in the
noteye networking menu).
=item B<-server>
Automatically connect to noteye server. As with B<-tcod>, the server must
already be defined.
=item B<-L> I<logfile>
Write game log to I<logfile>.
=item B<-X> I<game>
Launch this game, instead of displaying the main noteye menu.
=back
=head1 FILES
B<~/.config/noteye/config.noe> is the main config file. Editable, but
normally updated using noteye's built-in menus instead of a text editor.
=head1 SEE ALSO
B<hydraslayer>(6),
B<rogue>(6)
The noteye homepage: http://www.roguetemple.com/z/noteye.php
=head1 AUTHORS
hydraslayer and noteye are written by Zeno Rogue <zeno at attnam dot com>.
This man page written by B. Watson for the SlackBuilds.org project, and may be used
by anyone.

43
games/noteye/sbo.diff Normal file
View file

@ -0,0 +1,43 @@
diff -Naur noteye/src/rogue.sh noteye.patched/src/rogue.sh
--- noteye/src/rogue.sh 2014-03-06 00:54:36.000000000 -0500
+++ noteye.patched/src/rogue.sh 2014-09-02 14:18:35.000000000 -0400
@@ -5,31 +5,31 @@
if test -e rogue.save
then
- rogue rogue.save
+ ./rogue rogue.save
else
- rogue
+ ./rogue
fi
-elif [ -n "`which rogue`" ]
+elif [ -x /usr/games/rogue ]
then
cd $NOTEYECONFIG
if test -e rogue.save
then
- rogue rogue.save
+ /usr/games/rogue rogue.save
else
- rogue
+ /usr/games/rogue
fi
else
echo Rogue not found on your system.
echo
-echo Make sure that it can be run as \'$2\' or \'./$2\'.
+echo Make sure that it can be run as \'/usr/games/rogue\' or \'./$2\'.
echo
-echo For example, in Ubuntu you can install Rogue with:
+echo For example, in Slackware you can install Rogue with:
echo
-echo sudo apt-get install bsdgames-nonfree
+echo sbopkg -i rogue
echo
echo Otherwise, you can also run it manually from the prompt below.
echo

19
games/noteye/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
noteye: noteye (frontend for roguelike games; includes hydraslayer)
noteye:
noteye: Necklace of the Eye (NotEye in short) is a roguelike frontend. It
noteye: can modify the output of console and libtcod roguelikes, and it also
noteye: works as a library which allows to easily port old ASCII roguelikes
noteye: like ADOM into 21st century.
noteye:
noteye:
noteye:
noteye:
noteye: