mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
network/airoscript: Added to 12.2 repository
This commit is contained in:
parent
17de40e589
commit
68535f1807
6 changed files with 130 additions and 0 deletions
31
network/airoscript/Makefile.patch
Normal file
31
network/airoscript/Makefile.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
diff -Naur airoscript.orig/Makefile airoscript.new/Makefile
|
||||
--- airoscript.orig/Makefile 2009-02-05 12:41:57.000000000 +0000
|
||||
+++ airoscript.new/Makefile 2009-03-13 03:43:04.000000000 +0000
|
||||
@@ -7,14 +7,14 @@
|
||||
|
||||
|
||||
# Dirs
|
||||
-PREF="/usr/local"
|
||||
+PREF="/usr"
|
||||
BINMODE="755"
|
||||
SBINDIR=$(DESTDIR)$(PREF)"/sbin"
|
||||
ETCDIR=$(DESTDIR)"/etc"
|
||||
SHAREDIR=$(DESTDIR)$(PREF)"/share/airoscript"
|
||||
-LOCALEDIR=$(DESTDIR)$(PREF)"/share/locale/"
|
||||
-MANDIR=$(DESTDIR)$(PREF)"/share/man/man1"
|
||||
-DOCDIR=$(DESTDIR)$(PREF)"/share/doc/airoscript"
|
||||
+LOCALEDIR=$(DESTDIR)$(PREF)"/share/locale"
|
||||
+MANDIR=$(DESTDIR)$(PREF)"/man/man1"
|
||||
+DOCDIR=$(DESTDIR)$(PREF)"/doc/airoscript-2.1.1"
|
||||
|
||||
install: airopdate
|
||||
@echo -en "Installing files into:$(BINDIR) $(ETCDIR) $(SHAREDIR) $(DOCDIR) $(SBINDIR) "
|
||||
@@ -23,7 +23,7 @@
|
||||
@cp -r $(CURDIR)/src/themes/* $(SHAREDIR)/themes/
|
||||
@chown $(UID):$(GID) $(SHAREDIR)/themes/*
|
||||
@chmod $(BINMODE) $(SHAREDIR)/themes/*.theme
|
||||
- @install -D -o $(UID) -g $(GID) -m $(BINMODE) $(CURDIR)/src/airoscript.conf $(ETCDIR)/airoscript.conf
|
||||
+ @install -D -o $(UID) -g $(GID) -m 644 $(CURDIR)/src/airoscript.conf $(ETCDIR)/airoscript.conf
|
||||
@install -o $(UID) -g $(GID) -m $(BINMODE) $(CURDIR)/src/airopdate.sh $(SHAREDIR)/airopdate
|
||||
@install -o $(UID) -g $(GID) -m $(BINMODE) $(CURDIR)/src/airoscfunc.sh $(SHAREDIR)/airoscfunc.sh
|
||||
@install -o $(UID) -g $(GID) -m $(BINMODE) $(CURDIR)/src/airoscfunc_screen.sh $(SHAREDIR)/airoscfunc_screen.sh
|
8
network/airoscript/README
Normal file
8
network/airoscript/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
Airoscript is a companion tool for aircrack-ng.
|
||||
Cutom configuration settings can be made in
|
||||
/etc/airoscript.conf.
|
||||
|
||||
Runtime requirements:
|
||||
aircrack-ng available at slackbuilds.org
|
||||
|
||||
Note: must be run with root priveleges.
|
50
network/airoscript/airoscript.SlackBuild
Normal file
50
network/airoscript/airoscript.SlackBuild
Normal file
|
@ -0,0 +1,50 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for airoscript
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=airoscript
|
||||
VERSION=${VERSION:-2.1.1}
|
||||
ARCH=${ARCH:-noarch}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Sed statement replaces /usr/local with /usr
|
||||
sed -i "s:\=\"\/usr\/local:\=\"\/usr:g" src/airoscript.conf
|
||||
# Cleans up the Makefile for easier compiling
|
||||
patch -p1 < $CWD/Makefile.patch
|
||||
|
||||
make install DESTDIR=$PKG
|
||||
make slackware DESTDIR=$PKG
|
||||
|
||||
# Let's not overwrite the config file if it already exists
|
||||
mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
|
||||
rm $PKG/etc/$PRGNAM.conf~
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
network/airoscript/airoscript.info
Normal file
8
network/airoscript/airoscript.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="airoscript"
|
||||
VERSION="2.1.1"
|
||||
HOMEPAGE="http://code.google.com/p/airoscript/"
|
||||
DOWNLOAD="http://airoscript.googlecode.com/files/airoscript-2.1.1.tar.gz"
|
||||
MD5SUM="c53698f51ae914586636183f79022051"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja [at] gmail [dot] com"
|
||||
APPROVED="dsomero"
|
14
network/airoscript/doinst.sh
Normal file
14
network/airoscript/doinst.sh
Normal file
|
@ -0,0 +1,14 @@
|
|||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/airoscript.conf.new
|
19
network/airoscript/slack-desc
Normal file
19
network/airoscript/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
airoscript: airoscript (A companion for aircrack-ng)
|
||||
airoscript:
|
||||
airoscript: Airoscript is a shell script designed to ease the use of aircrack-ng.
|
||||
airoscript: It allows you to: scan, select and attack any detected access point.
|
||||
airoscript: This is done by detecting encryption type and proposing attacks
|
||||
airoscript: accordingly. Various attacks are available, such as: chopchop,
|
||||
airoscript: fragmentation attack, fakeauth, deauth, dictionnary attacks and WPA
|
||||
airoscript: cracking.
|
||||
airoscript:
|
||||
airoscript: Homepage: http://code.google.com/p/airoscript/
|
||||
airoscript:
|
Loading…
Reference in a new issue