system/facter: Updated for version 3.0.1 (moved from ruby).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Thibaut Notteboom 2015-07-02 22:49:09 +07:00 committed by Willy Sudiarto Raharjo
parent b7ef32891c
commit 67ab739de3
7 changed files with 42 additions and 18 deletions

View file

@ -1,10 +0,0 @@
PRGNAM="facter"
VERSION="1.6.17"
HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
DOWNLOAD="http://puppetlabs.com/downloads/facter/facter-1.6.17.tar.gz"
MD5SUM="7dbefba6148d2c6b6034009c46b3ae14"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Thibaut Notteboom"
EMAIL="tib@tibux.org"

View file

@ -0,0 +1,11 @@
--- lib/CMakeLists.txt.orig 2015-06-30 22:48:00.309505706 +0200
+++ lib/CMakeLists.txt 2015-06-30 22:48:28.407734850 +0200
@@ -238,7 +238,7 @@
set(LIBFACTER_INSTALL_DESTINATION bin)
else()
# TODO: lib64 for certain operating systems?
- set(LIBFACTER_INSTALL_DESTINATION lib)
+ set(LIBFACTER_INSTALL_DESTINATION lib64)
endif()
if (JRUBY_SUPPORT)

View file

@ -2,7 +2,7 @@
# Slackware build script for facter
# Copyright 2012-2013 Thibaut Notteboom, Paris, FRANCE
# Copyright 2012-2015 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=facter
VERSION=${VERSION:-1.6.17}
VERSION=${VERSION:-3.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -69,14 +69,28 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
ruby install.rb install --destdir=$PKG
if [ "$ARCH" = "x86_64" ]; then
patch -p0 < $CWD/facter-lib64.patch
fi
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
#-DLIBDIR=lib${LIBDIRSUFFIX} \
mv $PKG/usr/share/man $PKG/usr/man
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/etc
cp -a etc/facter.conf $PKG/etc/facter.conf.new
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
@ -86,7 +100,6 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
system/facter/facter.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="facter"
VERSION="3.0.1"
HOMEPAGE="https://puppetlabs.com/facter/"
DOWNLOAD="https://downloads.puppetlabs.com/facter/facter-3.0.1.tar.gz"
MD5SUM="c5ce03ec246c10a0694dea397c59bc1f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="yaml-cpp"
MAINTAINER="Thibaut Notteboom"
EMAIL="thibaut.notteboom@gmail.com"

View file

@ -13,7 +13,7 @@ facter: about the hardware and operating system. Facter is especially useful
facter: for retrieving things like operating system names, hardware
facter: characteristics, IP addresses, MAC addresses, and SSH keys.
facter:
facter: Homepage: http://puppetlabs.com/puppet/related-projects/facter/
facter: Homepage: https://puppetlabs.com/facter/
facter:
facter:
facter: