office/org-mode: Added to 13.0 repository

This commit is contained in:
Valeriy Timchenko 2010-05-13 01:00:34 +02:00 committed by David Somero
parent 03e0b9e3ad
commit 65c913a079
6 changed files with 152 additions and 0 deletions

View file

@ -0,0 +1,25 @@
--- org-6.34c/Makefile 2010-01-18 02:10:45.000000000 +0300
+++ org-6.34c/Makefile.2 2010-01-19 04:11:10.324503966 +0300
@@ -14,13 +14,13 @@
EMACS=emacs
# Where local software is found
-prefix=/usr/local
+prefix=/usr
# Where local lisp files go.
lispdir = $(prefix)/share/emacs/site-lisp
# Where info files go.
-infodir = $(prefix)/share/info
+infodir = $(prefix)/info
##----------------------------------------------------------------------
## YOU MAY NEED TO EDIT THESE
@@ -381,4 +381,4 @@
lisp/org-vm.elc: lisp/org.el
lisp/org-w3m.elc: lisp/org.el
lisp/org-wl.elc: lisp/org.el
-lisp/org-xoxo.elc: lisp/org-exp.el
\ No newline at end of file
+lisp/org-xoxo.elc: lisp/org-exp.el

View file

@ -0,0 +1,11 @@
--- org-6.34c/Makefile 2010-01-19 04:12:47.314750357 +0300
+++ org-6.34c/Makefile.2 2010-01-19 04:11:53.197796741 +0300
@@ -14,7 +14,7 @@
EMACS=emacs
# Where local software is found
-prefix=/usr
+prefix=$(PKG)/usr
# Where local lisp files go.
lispdir = $(prefix)/share/emacs/site-lisp

18
office/org-mode/README Normal file
View file

@ -0,0 +1,18 @@
Org is a mode for keeping notes, maintaining TODO lists, and doing
project planning with a fast and effective plain-text system.
Org keeps simple things simple. When first fired up, it should feel
like a straightforward, easy to use outliner. Complexity is not
imposed, but a large amount of functionality is available when you
need it. Org is a toolbox and can be used in different ways, for
example as:
- an outline extension with visibility cycling and structure editing
- an ASCII system and table editor for taking structured notes
- an ASCII table editor with spreadsheet-like capabilities
- a TODO list editor
- a full agenda and planner with deadlines and work scheduling
- an environment to implement David Allen's GTD system
- a basic database application
- a simple hypertext system, with HTML and LaTeX export
- a publishing tool to create a set of interlinked webpages

View file

@ -0,0 +1,69 @@
#!/bin/sh
# Slackware build script for Org-mode
# Written by Valeriy Timchenko <ValTimchenko@gmail.com>
PRGNAM=org-mode
VERSION=${VERSION:-6.34c}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf org-$VERSION
tar xvf $CWD/org-$VERSION.tar.gz
cd org-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
patch Makefile $CWD/Makefile.1.patch
make
patch Makefile $CWD/Makefile.2.patch
PKG=$PKG make install
PKG=$PKG make install-info
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
)
rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog Changes.org README request-assign-future.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,10 @@
PRGNAM="org-mode"
VERSION="6.34c"
HOMEPAGE="http://orgmode.org"
DOWNLOAD="http://orgmode.org/org-6.34c.tar.gz"
MD5SUM="e15b22ed4e319c67aac8cdf3e6c72ebe"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Valeriy Timchenko"
EMAIL="ValTimchenko@gmail.com"
APPROVED="dsomero"

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
org-mode: Org-mode ("An Emacs mode for Notes, Project Planning, and Authoring")
org-mode:
org-mode: Org-mode is for keeping notes, maintaining ToDo lists, doing project
org-mode: planning, and authoring with a fast and effective plain-text system.
org-mode:
org-mode: "If humans could mate with software, I'd have org-mode's babies."
org-mode: Chris League on his Twitter feed.
org-mode:
org-mode: Org-mode home page is: http://orgmode.org
org-mode:
org-mode: