system/qemu-kvm: Updated for version 0.14.0.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Stu Miller 2011-05-10 22:23:47 -05:00 committed by Robby Workman
parent 49c0d6564b
commit 65282ac79c
3 changed files with 62 additions and 5 deletions

View file

@ -0,0 +1,51 @@
Replace obsolete qemu-kvm.h with kvm.h in pci.c and build that module
just like upstream does. This fixes non-x86 targets which have no PCI
support.
Signed-off-by: Jan Kiszka <jan.kiszka@xxxxxxxxxxx>
---
Makefile.objs | 2 +-
Makefile.target | 2 +-
hw/pci.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/Makefile.objs b/Makefile.objs
index f5702eb..3ec7121 100644
--- a/Makefile.objs
+++ b/Makefile.objs
@@ -170,7 +170,7 @@ hw-obj-y =
hw-obj-y += loader.o
hw-obj-$(CONFIG_VIRTIO) += virtio.o virtio-console.o
hw-obj-y += fw_cfg.o
-hw-obj-$(CONFIG_PCI) += pci_bridge.o
+hw-obj-$(CONFIG_PCI) += pci.o pci_bridge.o
hw-obj-$(CONFIG_PCI) += msix.o msi.o
hw-obj-$(CONFIG_PCI) += pci_host.o pcie_host.o
hw-obj-$(CONFIG_PCI) += ioh3420.o xio3130_upstream.o xio3130_downstream.o
diff --git a/Makefile.target b/Makefile.target
index 6e9a024..23367eb 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -195,7 +195,7 @@ endif #CONFIG_BSD_USER
# System emulator target
ifdef CONFIG_SOFTMMU
-obj-y = arch_init.o cpus.o monitor.o pci.o machine.o gdbstub.o vl.o balloon.o
+obj-y = arch_init.o cpus.o monitor.o machine.o gdbstub.o vl.o balloon.o
# virtio has to be here due to weird dependency between PCI and virtio-net.
# need to fix this properly
obj-$(CONFIG_NO_PCI) += pci-stub.o
diff --git a/hw/pci.c b/hw/pci.c
index 0c44939..1f6cebe 100644
--- a/hw/pci.c
+++ b/hw/pci.c
@@ -29,8 +29,8 @@
#include "net.h"
#include "sysemu.h"
#include "loader.h"
-#include "qemu-kvm.h"
#include "hw/pc.h"
+#include "kvm.h"
#include "device-assignment.h"
#include "qemu-objects.h"
#include "range.h"

View file

@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=qemu-kvm
VERSION=${VERSION:-0.13.0}
VERSION=${VERSION:-0.14.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -88,12 +88,18 @@ find . \
# group to be used (no real need to require a kvm group)
patch -p1 < $CWD/fixup_udev_rules.patch
# Replace obsolete qemu-kvm.h with kvm.h in pci.c and build that module
# just like upstream does. This fixes non-x86 targets which have no PCI
# support. http://www.mail-archive.com/kvm@vger.kernel.org/msg50038.html
patch -p1 < $CWD/fixup-undefined-pci-references.patch
# This translates the possible targets into the correct format for configure
TARGETS="$(for i in $BUILD_ARCH ; do printf "$i-softmmu " ; done)"
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--enable-mixemu \
--audio-drv-list=oss,alsa,sdl,esd \
--enable-system \

View file

@ -1,10 +1,10 @@
PRGNAM="qemu-kvm"
VERSION="0.13.0"
VERSION="0.14.0"
HOMEPAGE="http://www.linux-kvm.org/page/Main_Page"
DOWNLOAD="http://downloads.sourceforge.net/project/kvm/qemu-kvm/0.13.0/qemu-kvm-0.13.0.tar.gz"
MD5SUM="68d100da381284a3dee486d3b9690e6d"
DOWNLOAD="http://downloads.sourceforge.net/kvm/qemu-kvm-0.14.0.tar.gz"
MD5SUM="4ea6f412d85a826e0b0690f5c4c59f13"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Stu Miller"
EMAIL="slackbuilds@go4it2day.com"
APPROVED="dsomero"
APPROVED="rworkman"