mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-25 10:03:03 +01:00
libraries/sdformat: Patch for cmake >= 3.9.x.
For this version, upstream code is already fixed Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
aff08d2b6d
commit
646cf7ae87
2 changed files with 23 additions and 0 deletions
20
libraries/sdformat/cmake.patch
Normal file
20
libraries/sdformat/cmake.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
diff -Naur osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt
|
||||
--- osrf-sdformat-e5ac5aaa49f2.orig/CMakeLists.txt 2016-10-10 23:51:37.000000000 +0200
|
||||
+++ osrf-sdformat-e5ac5aaa49f2/CMakeLists.txt 2017-07-29 19:46:16.021921859 +0200
|
||||
@@ -186,11 +186,13 @@
|
||||
# OS Specific initialization
|
||||
if (UNIX)
|
||||
sdf_setup_unix()
|
||||
-else (WIN32)
|
||||
+endif ()
|
||||
+if (WIN32)
|
||||
sdf_setup_windows()
|
||||
-else (APPLE)
|
||||
+endif ()
|
||||
+if (APPLE)
|
||||
sdf_setup_apple()
|
||||
-endif()
|
||||
+endif ()
|
||||
|
||||
#################################################
|
||||
# Print warnings and errors
|
|
@ -71,6 +71,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Patch for cmake >= 3.9.x
|
||||
patch -p1 < $CWD/cmake.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
|
Loading…
Reference in a new issue