mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
development/THE: Updated for version 3.3.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
cb6c419f97
commit
6430d8464a
6 changed files with 64 additions and 79 deletions
|
@ -5,7 +5,8 @@ Mansfield Software's Kedit.
|
|||
THE uses Regina Rexx as its macro language. It uses a command line,
|
||||
key bindings and a prefix area to operate.
|
||||
|
||||
Two version of THE are created:
|
||||
- command line version of the program using ncurses
|
||||
- X11 graphical version of the program using the PDCursesMod
|
||||
|
||||
Optional Dependency
|
||||
|
||||
If PDCurses is installed then the X11 version of the program (xthe)
|
||||
will be created.
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for The Hessling Editor
|
||||
|
||||
# Copyright 2012-2023 Richard Narron, California, USA
|
||||
# Copyright 2012-2022 Richard Narron, California, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,12 +25,12 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=THE
|
||||
VERSION=${VERSION:-4.0}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-3.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
TARFILE=the-${VERSION}
|
||||
TARFILE=the-3.3
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
|
@ -81,13 +81,7 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# patch INSTALL file: --with-curses=pdcurses-x11
|
||||
patch -b -p1 < $CWD/install.patch
|
||||
|
||||
# patch Makefile.in to make sure manext is built early
|
||||
patch -b -p1 < $CWD/makefile-in.patch
|
||||
|
||||
# Make the ncurses version of THE and the documentation
|
||||
# make the ncurses version of THE and the documentation
|
||||
mkdir ncurses
|
||||
cd ncurses
|
||||
|
||||
|
@ -105,26 +99,39 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc
|
||||
|
||||
make
|
||||
make -j1 install DESTDIR=$PKG
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
rm -rf doc/html
|
||||
make html
|
||||
|
||||
rm -f $PKG/usr/bin/the
|
||||
ln -sf the-con $PKG/usr/bin/the
|
||||
ln -sf the-con $PKG/usr/bin/nthe
|
||||
ln -fs the-con $PKG/usr/bin/the
|
||||
ln -fs the-con $PKG/usr/bin/nthe
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
|
||||
install -m0644 the64.gif the64.png doc/html/*.html \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION/html
|
||||
|
||||
cd $TMP/$PRGNAM-$VERSION
|
||||
install -m0644 COPYING FAQ HISTORY INSTALL README* TODO \
|
||||
install -m0644 COPYING FAQ HISTORY INSTALL README* THE_Help.txt TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
install -m0644 $CWD/README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION/README.slackware
|
||||
|
||||
# Make the X11 version of THE by using the included PDCursesMod source.
|
||||
# Try to make the X11 version of THE by using PDCurses (XCurses)
|
||||
|
||||
if ldconfig -p | grep -q libXCurses.so; then
|
||||
mkdir xcurses
|
||||
cd xcurses
|
||||
|
||||
# for XCurses, create pdcurses-x11.pc pkg-config
|
||||
XLIBDIR=lib${LIBDIRSUFFIX}
|
||||
XVERSION=$(xcurses-config --version)
|
||||
mkdir -p pkgconfig
|
||||
sed -e "s/XLIBDIR/${XLIBDIR}/" \
|
||||
-e "s/XVERSION/${XVERSION}/" \
|
||||
< $CWD/libpdcurses-x11.pc \
|
||||
> pkgconfig/libpdcurses-x11.pc
|
||||
|
||||
PKG_CONFIG_PATH=pkgconfig \
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
../configure \
|
||||
|
@ -139,9 +146,9 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc
|
||||
|
||||
make the-x11
|
||||
|
||||
install -m0755 the-x11 $PKG/usr/bin
|
||||
ln -sf the-x11 $PKG/usr/bin/xthe
|
||||
ln -fs the-x11 $PKG/usr/bin/xthe
|
||||
fi
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="THE"
|
||||
VERSION="4.0"
|
||||
VERSION="3.3"
|
||||
HOMEPAGE="http://hessling-editor.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/hessling-editor/the-4.0.tar.gz"
|
||||
MD5SUM="a172cad447fb7fe9332eecdbf6f583ac"
|
||||
DOWNLOAD="https://sourceforge.net/projects/hessling-editor/files/hessling-editor/3.3 Release Candidate 8/the-3.3.tar.gz"
|
||||
MD5SUM="27cea01b790a1a57a80f578f69602411"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="regina-rexx"
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- THE-4.0/INSTALL.orig 2022-12-28 14:20:28.000000000 -0800
|
||||
+++ THE-4.0/INSTALL 2023-01-07 16:32:48.849598481 -0800
|
||||
@@ -32,7 +32,7 @@
|
||||
|
||||
% mkdir xcurses
|
||||
% cd xcurses
|
||||
-% ../configure --with-curses=x11
|
||||
+% ../configure --with-curses=pdcurses-x11
|
||||
--with-rexx=oorexx
|
||||
--with-rexxincdir=[where oorexx is installed]/api
|
||||
--with-rexxlibdir=[where oorexx is installed]/api
|
14
development/THE/libpdcurses-x11.pc
Normal file
14
development/THE/libpdcurses-x11.pc
Normal file
|
@ -0,0 +1,14 @@
|
|||
prefix=/usr
|
||||
exec_prefix=${prefix}
|
||||
libdir=${prefix}/XLIBDIR
|
||||
includedir=${prefix}/include/xcurses
|
||||
version=XVERSION
|
||||
|
||||
Name: PDCurses
|
||||
Description: PDCurses ${version} X11 library
|
||||
Version: ${version}
|
||||
URL: https://pdcurses.org
|
||||
Requires.private:
|
||||
Libs: -lXCurses
|
||||
Libs.private: -l:libXCurses.a -lXaw -lXmu -lXt -lX11 -lXpm -lSM -lICE -lXext
|
||||
Cflags: -DXCURSES -I${includedir} -I/usr/include/X11
|
|
@ -1,26 +0,0 @@
|
|||
--- THE-4.0/Makefile.in.orig 2022-12-28 21:50:18.000000000 -0800
|
||||
+++ THE-4.0/Makefile.in 2023-01-07 17:58:35.946838735 -0800
|
||||
@@ -176,9 +176,9 @@
|
||||
doc/html:
|
||||
mkdir -p doc/html
|
||||
|
||||
-html: manext doc/html doc/html/index.html
|
||||
+html: doc/html doc/html/index.html
|
||||
|
||||
-doc/html/index.html: $(sourcedir)/*.c $(APPENDIX) $(GLOSSARY) $(OVERVIEW)
|
||||
+doc/html/index.html: manext $(sourcedir)/*.c $(APPENDIX) $(GLOSSARY) $(OVERVIEW)
|
||||
# -rm -fr *$(HTML_EXT) *.man
|
||||
cp $(imagedir)/the64.png .
|
||||
rexx $(srcdir)/makehtml.rex src=$(srcdir) ext=$(HTML_EXT) ver=$(VERSION) dest=./doc/html doc=$(srcdocdir) \
|
||||
@@ -197,9 +197,9 @@
|
||||
doc/helpviewer:
|
||||
mkdir -p doc/helpviewer
|
||||
|
||||
-helpviewer: manext doc/helpviewer doc/helpviewer/index.html
|
||||
+helpviewer: doc/helpviewer doc/helpviewer/index.html
|
||||
|
||||
-doc/helpviewer/index.html: $(sourcedir)/*.c $(APPENDIX) $(GLOSSARY) $(OVERVIEW)
|
||||
+doc/helpviewer/index.html: manext $(sourcedir)/*.c $(APPENDIX) $(GLOSSARY) $(OVERVIEW)
|
||||
# -rm -f *$(HTML_EXT) *.man comm/* commsos/* commset/* misc/*
|
||||
cp $(imagedir)/the64.png .
|
||||
rexx $(srcdir)/makehv.rex src=$(srcdir) ext=$(HTML_EXT) ver=$(VERSION) dest=./doc/helpviewer doc=$(srcdocdir) \
|
Loading…
Reference in a new issue