academic/amd: Updated for version 2.4.6.

Signed-off-by: Kyle Guinn <elyk03@gmail.com>
This commit is contained in:
Kyle Guinn 2016-11-19 00:00:57 -06:00 committed by David Spencer
parent d1283f4227
commit 640897d194
3 changed files with 26 additions and 21 deletions

View file

@ -25,14 +25,14 @@
PRGNAM=amd PRGNAM=amd
SRCNAM=SuiteSparse SRCNAM=SuiteSparse
SUBDIR=AMD SUBDIR=AMD
VERSION=${VERSION:-2.4.1} VERSION=${VERSION:-2.4.6}
SRCVER=${SRCVER:-4.4.6} SRCVER=${SRCVER:-4.5.3}
BUILD=${BUILD:-2} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then if [ -z "$ARCH" ]; then
case "$(uname -m)" in case "$(uname -m)" in
i?86) ARCH=i486 ;; i?86) ARCH=i586 ;;
arm*) ARCH=arm ;; arm*) ARCH=arm ;;
*) ARCH=$(uname -m) ;; *) ARCH=$(uname -m) ;;
esac esac
@ -48,6 +48,9 @@ DOCS="README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt"
if [ "$ARCH" = "i486" ]; then if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686" SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX="" LIBDIRSUFFIX=""
elif [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686" SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX="" LIBDIRSUFFIX=""
@ -73,11 +76,12 @@ cd $SRCNAM/$SUBDIR
chown -R root:root . chown -R root:root .
chmod -R u+w,go-w,a+rX-st . chmod -R u+w,go-w,a+rX-st .
patch -p1 < $CWD/autotoolize.diff patch -p1 < $CWD/patches/autotoolize.diff
autoreconf -vif autoreconf -vif
CFLAGS="$SLKCFLAGS" \ # Avoid rebuilding the docs.
FFLAGS="$SLKCFLAGS" \ touch Doc/AMD_UserGuide.pdf
./configure \ ./configure \
--prefix=/usr \ --prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \ --libdir=/usr/lib${LIBDIRSUFFIX} \
@ -89,7 +93,9 @@ FFLAGS="$SLKCFLAGS" \
--enable-shared \ --enable-shared \
--disable-static \ --disable-static \
--disable-dependency-tracking \ --disable-dependency-tracking \
--build=$ARCH-slackware-linux --build=$ARCH-slackware-linux \
CFLAGS="$SLKCFLAGS" \
FFLAGS="$SLKCFLAGS" \
make make
make check make check

View file

@ -1,8 +1,8 @@
PRGNAM="amd" PRGNAM="amd"
VERSION="2.4.1" VERSION="2.4.6"
HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html" HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.6.tar.gz" DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.3.tar.gz"
MD5SUM="131a3a5e2dee784cd946284e44ce9af2" MD5SUM="8ec57324585df3c6483ad7f556afccbd"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
REQUIRES="suitesparseconfig" REQUIRES="suitesparseconfig"

View file

@ -98,11 +98,10 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644 new file mode 100644
--- /dev/null --- /dev/null
+++ b/Makefile.am +++ b/Makefile.am
@@ -0,0 +1,5 @@ @@ -0,0 +1,4 @@
+SUBDIRS = Include Source Demo Doc +SUBDIRS = Include Source Demo Doc
+EXTRA_DIST = README.txt +EXTRA_DIST = README.txt
+ +
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = amd.pc +pkgconfig_DATA = amd.pc
diff --git a/Source/Makefile.am b/Source/Makefile.am diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644 new file mode 100644
@ -169,26 +168,24 @@ new file mode 100644
+# Process this file with autoconf to produce a configure script. +# Process this file with autoconf to produce a configure script.
+ +
+AC_PREREQ([2.69]) +AC_PREREQ([2.69])
+AC_INIT([AMD],[2.4.1],[DrTimothyAldenDavis@gmail.com],[amd],[http://www.suitesparse.com/]) +AC_INIT([AMD],[2.4.6],[DrTimothyAldenDavis@gmail.com],[amd],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/amd_order.c]) +AC_CONFIG_SRCDIR([Source/amd_order.c])
+AC_CONFIG_HEADERS([config.h]) +AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign]) +AM_INIT_AUTOMAKE([foreign])
+LT_INIT +LT_INIT
+ +
+# Checks for programs. +# Checks for programs.
+PKG_PROG_PKG_CONFIG
+AC_PROG_INSTALL +AC_PROG_INSTALL
+AC_PROG_CC +AC_PROG_CC
+AC_PROG_F77 +AC_PROG_F77
+ +
+LIBS_SAVED=$LIBS +AS_VAR_SET([LIBS_SAVED], [$LIBS])
+ +
+# Checks for libraries. +# Checks for libraries.
+AC_CHECK_LIB([m], [sqrt]) +AC_CHECK_LIB([m], [sqrt])
+ +
+PKG_PROG_PKG_CONFIG +PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
+ [],
+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
+ +
+# Checks for header files. +# Checks for header files.
+AC_CHECK_HEADERS([limits.h stddef.h stdlib.h]) +AC_CHECK_HEADERS([limits.h stddef.h stdlib.h])
@ -199,13 +196,15 @@ new file mode 100644
+# Checks for library functions. +# Checks for library functions.
+AC_CHECK_FUNCS([sqrt]) +AC_CHECK_FUNCS([sqrt])
+ +
+LIBS=$LIBS_SAVED +AS_VAR_SET([LIBS], [$LIBS_SAVED])
+ +
+PKG_INSTALLDIR
+AC_CONFIG_FILES([ +AC_CONFIG_FILES([
+ amd.pc + amd.pc
+ Makefile + Makefile
+ Demo/Makefile + Demo/Makefile
+ Doc/Makefile + Doc/Makefile
+ Include/Makefile + Include/Makefile
+ Source/Makefile]) + Source/Makefile
+])
+AC_OUTPUT +AC_OUTPUT