mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
office/abiword: Fixed building with gcc >= 4.6 and glib >= 2.31.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
3db421e8af
commit
63ea1bca9e
2 changed files with 47 additions and 1 deletions
|
@ -29,7 +29,7 @@
|
|||
PRGNAM=abiword
|
||||
VERSION=2.8.6
|
||||
DOCSVER=$VERSION # version of abiword-docs
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -82,6 +82,12 @@ patch -p1 < $CWD/patches/boost_asio.patch
|
|||
# This should make the help stuff work properly
|
||||
patch -p1 < $CWD/patches/url_show.patch
|
||||
|
||||
# This fixes building with gcc-4.7
|
||||
sed -i "s|--no-undefined||" src/Makefile.{am,in}
|
||||
|
||||
# This fixes building with glib >= 2.31 (thanks to gentoo)
|
||||
patch -p0 < $CWD/patches/abiword-2.8.6-glib-2.31.patch
|
||||
|
||||
CPPFLAGS="-I$TMP/$PRGNAM-$VERSION" \
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
|
40
office/abiword/patches/abiword-2.8.6-glib-2.31.patch
Normal file
40
office/abiword/patches/abiword-2.8.6-glib-2.31.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
------------------------------------------------------------------------
|
||||
r30479 | hub | 2011-11-29 00:39:09 -0500 (Tue, 29 Nov 2011) | 2 lines
|
||||
Changed paths:
|
||||
M /abiword/trunk/src/af/util/xp/ut_go_file.h
|
||||
|
||||
Bug 13197: only import glib.h
|
||||
Patch by Dominique Leuenberger.
|
||||
------------------------------------------------------------------------
|
||||
r30602 | hub | 2012-01-30 02:00:38 -0500 (Mon, 30 Jan 2012) | 2 lines
|
||||
Changed paths:
|
||||
M /abiword/trunk/goffice-bits/goffice/app/goffice-app.h
|
||||
|
||||
Bug 13247 - Fix glib headers. Patch by Funda Wang
|
||||
(safe to backport)
|
||||
------------------------------------------------------------------------
|
||||
Index: src/af/util/xp/ut_go_file.h
|
||||
===================================================================
|
||||
--- src/af/util/xp/ut_go_file.h (revision 30478)
|
||||
+++ src/af/util/xp/ut_go_file.h (revision 30479)
|
||||
@@ -31,7 +31,6 @@
|
||||
|
||||
#include <glib.h>
|
||||
#include <gsf/gsf.h>
|
||||
-#include <glib/gerror.h>
|
||||
#include <time.h>
|
||||
|
||||
G_BEGIN_DECLS
|
||||
Index: goffice-bits/goffice/app/goffice-app.h
|
||||
===================================================================
|
||||
--- goffice-bits/goffice/app/goffice-app.h (revision 30601)
|
||||
+++ goffice-bits/goffice/app/goffice-app.h (revision 30602)
|
||||
@@ -22,7 +22,7 @@
|
||||
#ifndef GOFFICE_APP_H
|
||||
#define GOFFICE_APP_H
|
||||
|
||||
-#include <glib/gmacros.h>
|
||||
+#include <glib.h>
|
||||
|
||||
G_BEGIN_DECLS
|
||||
|
Loading…
Reference in a new issue