mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
office/python-gcalcli: Updated for version git20140429.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
a0cba0803d
commit
62b19988a8
3 changed files with 36 additions and 28 deletions
|
@ -1,11 +0,0 @@
|
|||
--- a/gcalcli 2007-10-13 18:44:57.000000000 +0000
|
||||
+++ b/gcalcli 2010-08-12 03:05:45.000000000 +0000
|
||||
@@ -223,7 +223,7 @@
|
||||
allCals = None
|
||||
workCals = []
|
||||
now = datetime.now(tzlocal())
|
||||
- feedPrefix = 'http://www.google.com/calendar/feeds/'
|
||||
+ feedPrefix = 'https?://www.google.com/calendar/feeds/'
|
||||
agendaLength = 5
|
||||
username = ''
|
||||
password = ''
|
|
@ -1,7 +1,7 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for gcalcli
|
||||
# Copyright 2010 David Woodfall <dave@dawoodfall.net>
|
||||
# Slackware build script for python-gcalcli
|
||||
# Copyright 2014 David Woodfall <dave@dawoodfall.net>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -21,9 +21,9 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=python-gcalcli
|
||||
SRCNAM=gcalcli
|
||||
VERSION=${VERSION:-1.4}
|
||||
PRGNAM=python-$SRCNAM
|
||||
VERSION=${VERSION:-git20140429}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -40,24 +40,43 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG/usr/bin $OUTPUT
|
||||
cd $PKG
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tgz
|
||||
patch -p1 --verbose < $CWD/feedPrefix-fix.diff
|
||||
mv gcalcli usr/bin
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
|
||||
cd $SRCNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
$CWD/README $CWD/HOWTO \
|
||||
ChangeLog README.md docs \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="python-gcalcli"
|
||||
VERSION="1.4"
|
||||
VERSION="git20140429"
|
||||
HOMEPAGE="http://code.google.com/p/gcalcli/"
|
||||
DOWNLOAD="http://gcalcli.googlecode.com/files/gcalcli-1.4.tgz"
|
||||
MD5SUM="6f01ff01750e06083857347e2a5f11f8"
|
||||
DOWNLOAD="http://unrealize.co.uk/source/gcalcli-git20140429.tar.xz"
|
||||
MD5SUM="c356c275b9e1b69b79a98aabb545d3c5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="gdata python-dateutil python-elementtree"
|
||||
|
|
Loading…
Reference in a new issue