mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
libraries/gtkextra: Updated for version 3.0.4.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
83db91f036
commit
628ff4751e
5 changed files with 31 additions and 84 deletions
|
@ -1,11 +0,0 @@
|
|||
--- gtk+extra-2.1.2_orig/gtkextra/gtkcolorcombo.c 2004-09-16 14:48:05.000000000 -0300
|
||||
+++ gtk+extra-2.1.2/gtkextra/gtkcolorcombo.c 2010-11-01 00:22:36.000000000 -0200
|
||||
@@ -146,7 +146,7 @@
|
||||
GTK_CLASS_TYPE(object_class),
|
||||
GTK_SIGNAL_OFFSET(GtkColorComboClass,
|
||||
changed),
|
||||
- gtkextra_VOID__INT_BOXED,
|
||||
+ gtkextra_VOID__BOXED_BOXED,
|
||||
GTK_TYPE_NONE,
|
||||
2, GTK_TYPE_INT, GDK_TYPE_COLOR);
|
||||
|
|
@ -3,16 +3,33 @@
|
|||
# Slackware build script for gtkextra
|
||||
# A set of extra widgets for GTK+
|
||||
|
||||
# Written by Niels Horn <niels.horn@gmail.com>
|
||||
# Revision date: 2011/03/09
|
||||
# Copyright 2010-2011,2013 Niels Horn, Rio de Janeiro, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# Revision date: 2013/03/30
|
||||
|
||||
PRGNAM=gtkextra
|
||||
VERSION=${VERSION:-2.1.2}
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=${VERSION:-3.0.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
SRCNAM=gtk+extra
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
|
@ -45,9 +62,9 @@ set -e
|
|||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
|
||||
cd $SRCNAM-$VERSION
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
|
@ -55,17 +72,8 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Solve a problem with spaces in gtkextra/Makefile.in
|
||||
patch -p1 < $CWD/make382.patch
|
||||
|
||||
# Resolve a bug in the code (thanks to the Gentoo people for finding it)
|
||||
patch -p1 < $CWD/gtkcolorcombo.patch
|
||||
|
||||
# Patch code for gtk >= 2.21 (based on work by the folks from GTKada)
|
||||
patch -p1 < $CWD/gtkextra_gtk2.21.patch
|
||||
|
||||
# Fix for glib>=2.31.x
|
||||
sed -i "s|glib/gunicode\.h|glib.h|" gtkextra/gtkcharsel.c
|
||||
# Fix an error creating the html pages
|
||||
sed "s/\(db2html\)/\1 -o gtkextra-tutorial/" -i docs/tutorial/Makefile.in
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="gtkextra"
|
||||
VERSION="2.1.2"
|
||||
VERSION="3.0.4"
|
||||
HOMEPAGE="http://gtkextra.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/gtkextra/gtk+extra-2.1.2.tar.gz"
|
||||
MD5SUM="10779394f39d39115fa3fd0f3dea4436"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/gtkextra/gtkextra-3.0.4.tar.gz"
|
||||
MD5SUM="67e5a254b883b5b961fc640efb006aad"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
--- gtk+extra-2.1.2/gtkextra/gtkitementry.c 2010-03-13 02:49:00.000000000 -0300
|
||||
+++ gtk+extra-2.1.2_patched/gtkextra/gtkitementry.c 2011-03-09 00:29:54.000000000 -0300
|
||||
@@ -131,7 +131,6 @@
|
||||
static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
|
||||
gboolean include_preedit);
|
||||
static void gtk_entry_queue_draw (GtkEntry *entry);
|
||||
-static void gtk_entry_reset_im_context (GtkEntry *entry);
|
||||
static void gtk_entry_recompute (GtkEntry *entry);
|
||||
static void gtk_entry_get_cursor_locations (GtkEntry *entry,
|
||||
CursorType type,
|
||||
@@ -1755,16 +1754,6 @@
|
||||
}
|
||||
|
||||
static void
|
||||
-gtk_entry_reset_im_context (GtkEntry *entry)
|
||||
-{
|
||||
- if (entry->need_im_reset)
|
||||
- {
|
||||
- entry->need_im_reset = 0;
|
||||
- gtk_im_context_reset (entry->im_context);
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-static void
|
||||
gtk_entry_get_cursor_locations (GtkEntry *entry,
|
||||
CursorType type,
|
||||
gint *strong_x,
|
|
@ -1,23 +0,0 @@
|
|||
--- gtk+extra-2.1.2_orig/gtkextra/Makefile.in 2010-03-20 21:05:56.000000000 -0300
|
||||
+++ gtk+extra-2.1.2/gtkextra/Makefile.in 2010-10-31 23:56:00.000000000 -0200
|
||||
@@ -1028,13 +1028,14 @@
|
||||
$(libgtkextra_x11_2_0_la_OBJECTS) $(libgtkextra_linux_fb_2_0_la_OBJECTS) $(libgtkextra_win32_2_0_la_OBJECTS): ${gtkextra_built_public_sources} ${gtkextra_built_private_headers}
|
||||
|
||||
$(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
|
||||
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
|
||||
- && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
|
||||
- || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
|
||||
+ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
|
||||
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
+
|
||||
$(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
|
||||
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
|
||||
- && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
|
||||
- || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
|
||||
+ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
|
||||
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
|
||||
$(srcdir)/gtkextratypebuiltins.h: $(gtkextra_public_h_sources)
|
||||
( cd $(srcdir) && glib-mkenums \
|
Loading…
Reference in a new issue