libraries/GLee: Added (GL Easy Extension library)

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
Matthew Fillpot 2010-10-24 22:13:26 -04:00 committed by Erik Hanson
parent 78a30bcf37
commit 622b02fed5
5 changed files with 153 additions and 0 deletions

View file

@ -0,0 +1,102 @@
#!/bin/sh
# SlackBuild Script for GLee
# Copyright 2010 Matthew "mfillpot" Fillpot
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM="GLee"
VERSION=${VERSION:-5.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir -p $TMP/$PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
# Apply a patch to support DESTDIR
patch -t Makefile.in< $CWD/destdir.patch
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
libraries/GLee/GLee.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="GLee"
VERSION="5.4.0"
HOMEPAGE="http://elf-stone.com/glee.php"
DOWNLOAD="http://elf-stone.com/downloads/GLee/GLee-5.4.0-src.tar.gz"
MD5SUM="0bd03db136dbc075488b6c6e83f326ae"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Matthew Fillpot"
EMAIL="mfilpot@gmail.com"
APPROVED="dsomero"

3
libraries/GLee/README Normal file
View file

@ -0,0 +1,3 @@
(GL Easy Extension library) is a free cross-platform extension
loading library for OpenGL. It provides seamless support for OpenGL
functions up to version 3.0 and 399 extensions.

View file

@ -0,0 +1,19 @@
--- Makefile.in 2010-09-25 21:34:18.609679235 -0400
+++ /tmp/SBo/GLee-5.4.0/Makefile.in 2009-02-07 15:45:53.000000000 -0500
@@ -41,12 +41,10 @@
${CXXFLAGS} ${DEFS} -o ${SRCDIR}/${LIBNAME}
install:
- ${MKDIR} -p ${DESTDIR}${INCLUDEDIR}/GL
- ${INSTALLD} ${HEADER} ${DESTDIR}${INCLUDEDIR}/GL
- ${MKDIR} -p ${DESTDIR}${LIBDIR}
- ${INSTALLP} ${LIBNAME} ${DESTDIR}${LIBDIR}
- ${MKDIR} -p ${DESTDIR}${DATADIR}/doc/GLee
- ${INSTALLD} ${README} ${DESTDIR}${DATADIR}/doc/GLee
+ ${INSTALLD} ${HEADER} ${INCLUDEDIR}/GL
+ ${INSTALLP} ${LIBNAME} ${LIBDIR}
+ ${MKDIR} -p ${DATADIR}/doc/GLee
+ ${INSTALLD} ${README} ${DATADIR}/doc/GLee
${LDCONFIG}
dists: dist bindist redist

19
libraries/GLee/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
GLee: GLee (GL Easy Extension library)
GLee:
GLee: GLee (GL Easy Extension library) is a free cross-platform extension
GLee: loading library for OpenGL. It provides seamless support for OpenGL
GLee: functions up to version 3.0 and 399 extensions.
GLee:
GLee: Homepage: http://elf-stone.com/glee.php
GLee:
GLee:
GLee:
GLee: