mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
graphics/pr0ntools: Added (IC Reverse Engineering tools).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
1e54fa3978
commit
614719408c
5 changed files with 158 additions and 0 deletions
5
graphics/pr0ntools/README
Normal file
5
graphics/pr0ntools/README
Normal file
|
@ -0,0 +1,5 @@
|
|||
This is a collection of tools for automating tasks while learning about
|
||||
ICs. The most developed tools are related to image stitching and are
|
||||
certainly useful for more than just IC work.
|
||||
|
||||
See stitch_README.txt for imaging stitching info.
|
90
graphics/pr0ntools/pr0ntools.SlackBuild
Normal file
90
graphics/pr0ntools/pr0ntools.SlackBuild
Normal file
|
@ -0,0 +1,90 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for pr0ntools
|
||||
|
||||
# Copyright 2016 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=pr0ntools
|
||||
VERSION=${VERSION:-20170617}
|
||||
COMVER=3ce25e7e39cc195f3681a4d8d84633a2885b74da
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$COMVER
|
||||
tar xvf $CWD/$PRGNAM-$COMVER.tar.gz
|
||||
cd $PRGNAM-$COMVER
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# lib path fix.
|
||||
patch -p0 --verbose < $CWD/setup.py.patch
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README COPYING TODO $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a stitch/README.txt $PKG/usr/doc/$PRGNAM-$VERSION/stitch_README.txt
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
graphics/pr0ntools/pr0ntools.info
Normal file
10
graphics/pr0ntools/pr0ntools.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="pr0ntools"
|
||||
VERSION="20170617"
|
||||
HOMEPAGE="https://github.com/JohnDMcMaster/pr0ntools"
|
||||
DOWNLOAD="https://github.com/JohnDMcMaster/pr0ntools/archive/3ce25e7/pr0ntools-3ce25e7e39cc195f3681a4d8d84633a2885b74da.tar.gz"
|
||||
MD5SUM="39a78877c128b0efad52c760fa69854d"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Fernando Lopez Jr."
|
||||
EMAIL="fernando.lopezjr@gmail.com"
|
34
graphics/pr0ntools/setup.py.patch
Normal file
34
graphics/pr0ntools/setup.py.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- setup.py 2017-06-17 09:13:43.000000000 -0600
|
||||
+++ setup.py 2017-08-14 19:56:12.899404271 -0600
|
||||
@@ -9,15 +9,14 @@
|
||||
description='Integrated circuit reverse engineering research and development',
|
||||
long_description = long_description,
|
||||
package_dir={
|
||||
- 'pr0ntools': 'lib/pr0ntools',
|
||||
- 'pr0ntools.image': 'lib/pr0ntools/image',
|
||||
- 'pr0ntools.jssim': 'lib/pr0ntools/jssim',
|
||||
- 'pr0ntools.jssim.cif': 'lib/pr0ntools/jssim/cif',
|
||||
- 'pr0ntools.jssim.files': 'lib/pr0ntools/jssim/files',
|
||||
- 'pr0ntools.stitch': 'lib/pr0ntools/stitch',
|
||||
- 'pr0ntools.stitch.pto': 'lib/pr0ntools/stitch/pto',
|
||||
- 'pr0ntools.tile': 'lib/pr0ntools/tile',
|
||||
- 'pr0ntools.util': 'lib/pr0ntools/util',
|
||||
+ 'pr0ntools': 'pr0ntools',
|
||||
+ 'pr0ntools.image': 'pr0ntools/image',
|
||||
+ 'pr0ntools.jssim': 'pr0ntools/jssim',
|
||||
+ 'pr0ntools.jssim.cif': 'pr0ntools/jssim/cif',
|
||||
+ 'pr0ntools.jssim.files': 'pr0ntools/jssim/files',
|
||||
+ 'pr0ntools.stitch': 'pr0ntools/stitch',
|
||||
+ 'pr0ntools.stitch.pto': 'pr0ntools/stitch/pto',
|
||||
+ 'pr0ntools.tile': 'pr0ntools/tile',
|
||||
},
|
||||
packages=[
|
||||
'pr0ntools',
|
||||
@@ -28,7 +27,6 @@
|
||||
'pr0ntools.stitch',
|
||||
'pr0ntools.stitch.pto',
|
||||
'pr0ntools.tile',
|
||||
- 'pr0ntools.util',
|
||||
],
|
||||
scripts=[
|
||||
'stitch/pr0nhugin.py',
|
19
graphics/pr0ntools/slack-desc
Normal file
19
graphics/pr0ntools/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
pr0ntools: pr0ntools (Integrated Circuit (IC) Reverse Engineering (RE) tools)
|
||||
pr0ntools:
|
||||
pr0ntools: This is a collection of tools for automating tasks while learning
|
||||
pr0ntools: about ICs. The most developed tools are related to image stitching
|
||||
pr0ntools: and are certainly useful for more than just IC work.
|
||||
pr0ntools:
|
||||
pr0ntools:
|
||||
pr0ntools:
|
||||
pr0ntools:
|
||||
pr0ntools:
|
||||
pr0ntools:
|
Loading…
Reference in a new issue