graphics/shotwell: Removed (build failure)

This package is not compatible with the boost version
in Slackware 14.1.  As an additional hurdle, it needs
an older version of LibRaw than we currently have in
our repo, while some of the other stuff requires the
newer version.  Given the circumstances, shotwell goes.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2013-11-20 08:07:10 +07:00 committed by Robby Workman
parent ebe1c15116
commit 609e01ddac
7 changed files with 0 additions and 277 deletions

View file

@ -1,3 +0,0 @@
Shotwell is a digital photo organizer for GNOME. It allows the user to import
photos from a digital camera or disk, organize them in various ways, and export
to share with others.

View file

@ -1,16 +0,0 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
if [ -e usr/share/glib-2.0/schemas ]; then
if [ -x /usr/bin/glib-compile-schemas ]; then
/usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
fi
fi

View file

@ -1,65 +0,0 @@
--- src/photos/GRaw.vala.orig 2012-02-15 17:13:51.000000000 -0800
+++ src/photos/GRaw.vala 2012-02-15 17:15:48.000000000 -0800
@@ -34,11 +34,11 @@
OUT_OF_ORDER_CALL,
NO_THUMBNAIL,
UNSUPPORTED_THUMBNAIL,
- CANNOT_ADDMASK,
OUT_OF_MEMORY,
DATA_ERROR,
IO_ERROR,
CANCELLED_BY_CALLBACK,
+ BAD_CROP,
SYSTEM_ERROR
}
@@ -163,10 +163,6 @@
proc = new LibRaw.Processor(options);
}
- public void add_masked_borders_to_bitmap() {
- proc.add_masked_borders_to_bitmap();
- }
-
public void adjust_sizes_info_only() throws Exception {
throw_exception("adjust_sizes_info_only", proc.adjust_sizes_info_only());
}
@@ -215,10 +211,6 @@
throw_exception("ppm_tiff_writer", proc.ppm_tiff_writer(filename));
}
- public void rotate_fuji_raw() throws Exception {
- throw_exception("rotate_fuji_raw", proc.rotate_fuji_raw());
- }
-
public void thumb_writer(string filename) throws Exception {
throw_exception("thumb_writer", proc.thumb_writer(filename));
}
@@ -262,7 +254,6 @@
// camera_profile
// bad_pixels
// dark_frame
- output_params->filtering_mode = LibRaw.Filtering.AUTOMATIC;
output_params->output_bps = 8;
// output_tiff
output_params->user_flip = GRaw.Flip.FROM_SOURCE;
@@ -303,9 +294,6 @@
case LibRaw.Result.UNSUPPORTED_THUMBNAIL:
throw new Exception.UNSUPPORTED_THUMBNAIL(msg);
- case LibRaw.Result.CANNOT_ADDMASK:
- throw new Exception.CANNOT_ADDMASK(msg);
-
case LibRaw.Result.UNSUFFICIENT_MEMORY:
throw new Exception.OUT_OF_MEMORY(msg);
@@ -317,6 +305,9 @@
case LibRaw.Result.CANCELLED_BY_CALLBACK:
throw new Exception.CANCELLED_BY_CALLBACK(msg);
+
+ case LibRaw.Result.BAD_CROP:
+ throw new Exception.BAD_CROP(msg);
default:
return;

View file

@ -1,81 +0,0 @@
--- vapi/libraw.vapi.orig 2012-02-15 17:16:39.000000000 -0800
+++ vapi/libraw.vapi 2012-02-15 17:18:38.000000000 -0800
@@ -14,17 +14,6 @@
public unowned string versionNumber();
-[CCode (cname="enum libraw_Filtering", cprefix="LIBRAW_FILTERING_")]
-public enum Filtering {
- DEFAULT,
- NOZEROES,
- NOBLACK,
- NORAWCURVE,
- NONE,
- LIBRAWOWN,
- AUTOMATIC
-}
-
[SimpleType]
[CCode (cname="libraw_imgother_t")]
public struct ImageOther {
@@ -121,7 +110,6 @@
public bool use_camera_wb;
public bool use_camera_matrix;
public int output_color;
- public Filtering filtering_mode;
public int output_bps;
public bool output_tiff;
public int user_flip;
@@ -132,6 +120,30 @@
public bool no_auto_bright;
public float auto_bright_thr;
public int use_fuji_rotate;
+ public int green_matching;
+
+ /* DCB parameters */
+ public int dcb_iterations;
+ public int dcb_enhance_fl;
+ public int fbdd_noiserd;
+
+ /* VCD parameters */
+ public int eeci_refine;
+ public int es_med_passes;
+ /* AMaZE*/
+ public int ca_correc;
+ public float cared;
+ public float cablue;
+ public int cfaline;
+ public float linenoise;
+ public int cfa_clean;
+ public float lclean;
+ public float cclean;
+ public int cfa_green;
+ public float green_thresh;
+ public int exp_correc;
+ public float exp_shift;
+ public float exp_preser;
public void set_chromatic_aberrations(double red_multiplier, double green_multiplier) {
aber[0] = red_multiplier;
@@ -171,7 +183,6 @@
[CCode (cname="libraw_init")]
public Processor(Options flags = Options.NONE);
- public void add_masked_borders_to_bitmap();
public Result adjust_sizes_info_only();
[CCode (cname="libraw_dcraw_document_mode_processing")]
public Result document_mode_processing();
@@ -216,11 +227,11 @@
OUT_OF_ORDER_CALL,
NO_THUMBNAIL,
UNSUPPORTED_THUMBNAIL,
- CANNOT_ADDMASK,
UNSUFFICIENT_MEMORY,
DATA_ERROR,
IO_ERROR,
- CANCELLED_BY_CALLBACK;
+ CANCELLED_BY_CALLBACK,
+ BAD_CROP;
[CCode (cname="LIBRAW_FATAL_ERROR")]
public bool is_fatal_error();

View file

@ -1,83 +0,0 @@
#!/bin/sh
# Brad Hermanson <apeitheo@gmail.com>
PRGNAM=shotwell
VERSION=0.11.6
BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Fix building with LibRaw 0.14
patch -p0 -i $CWD/patch-src-photos-GRaw.vala
patch -p0 -i $CWD/patch-vapi-libraw.vapi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--lib=lib${LIBDIRSUFFIX} \
--disable-schemas-compile \
--disable-desktop-update \
--disable-icon-update \
--enable-build-for-glade \
--install-headers \
--release
# Allow shotwell to find our tweaked vala-12 package.
sed -e 's/valac/valac-0.12/' -i plugins/Makefile.plugin.mk
sed -e 's/valac/valac-0.12/' -i Makefile
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING INSTALL MAINTAINERS NEWS README THANKS \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="shotwell"
VERSION="0.11.6"
HOMEPAGE="http://yorba.org/shotwell/"
DOWNLOAD="http://www.yorba.org/download/shotwell/0.11/shotwell-0.11.6.tar.bz2"
MD5SUM="bbbf2843eb98b6f0ef1dfcfb934e15cf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="LibRaw libgee libgexiv2 libunique vala-12 webkitgtk"
MAINTAINER="Brad Hermanson"
EMAIL="apeitheo@gmail.com"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
shotwell: shotwell (Open source photo manager for GNOME)
shotwell:
shotwell: Digital photo organizer for Linux.
shotwell:
shotwell: Homepage: http://www.yorba.org/shotwell/
shotwell:
shotwell:
shotwell:
shotwell:
shotwell:
shotwell: