audio/yabridge: Fix dbus problem

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Martin Bångens 2024-07-19 02:51:20 +02:00 committed by Willy Sudiarto Raharjo
parent 86e728e6e9
commit 5d7290c295
2 changed files with 51 additions and 1 deletions

View file

@ -0,0 +1,48 @@
commit 8d508dc2fefe9745ffa9cb14e1d7519a7852aa95
Author: Robbert van der Helm <mail@robbertvanderhelm.nl>
Date: Sun Apr 7 22:49:00 2024 +0200
Fix segfault destroying libdbus connection
diff --git a/CHANGELOG.md b/CHANGELOG.md
index a1739b3d..429880a6 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -6,6 +6,12 @@ The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic
Versioning](https://semver.org/spec/v2.0.0.html).
+## [Unreleased]
+
+### Fixed
+
+- Fixed a potential segfault when unloading yabridge.
+
## [5.1.0] - 2023-12-23
### Added
diff --git a/src/common/notifications.cpp b/src/common/notifications.cpp
index 403103bf..654b6c83 100644
--- a/src/common/notifications.cpp
+++ b/src/common/notifications.cpp
@@ -57,9 +57,19 @@ std::mutex libdbus_mutex;
LIBDBUS_FUNCTIONS
#undef X
+/**
+ * The deleter used for `libdbus_connection`. `libdbus_connection` can't
+ * directly reference `libdbus_connection_unref` directly because it will not
+ * yet have been initialized until just before `libdbus_connection` gets
+ * initialized.
+ */
+static void close_dbus_connection(DBusConnection* connection) {
+ libdbus_connection_unref(connection);
+}
+
std::unique_ptr<DBusConnection, void (*)(DBusConnection*)> libdbus_connection(
nullptr,
- libdbus_connection_unref);
+ close_dbus_connection);
/**
* Try to set up D-Bus. Returns `false` if a function could not be resolved or

View file

@ -26,7 +26,7 @@ cd $(dirname $0) || exit 1 ; CWD=$(pwd)
PRGNAM=yabridge
VERSION=${VERSION:-5.1.0}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARG_CLAP=${ARG_CLAP:-NO}
@ -121,6 +121,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/fix-libdbus-connection.patch
#Build only capitalized
sed -i "s|bitsery_dep = dependency('bitsery', version : '>=5.2.0')|bitsery_dep = dependency('Bitsery', version : '>=5.2.0')|g" meson.build
sed -i "s|bitsery_dep = dependency('bitsery', 'Bitsery', version : '>=5.2.0')|bitsery_dep = dependency('Bitsery', version : '>=5.2.0')|g" meson.build