network/arptables: Initial import

This commit is contained in:
Menno E. Duursma 2010-05-11 15:01:25 +02:00 committed by Robby Workman
parent 88a7e78ac4
commit 5d0d367915
5 changed files with 138 additions and 0 deletions

View file

@ -0,0 +1,35 @@
--- arptables-v0.0.3-2/Makefile.orig 2006-08-22 10:40:51.826701081 -0500
+++ arptables-v0.0.3-2/Makefile 2006-08-22 10:41:38.379149449 -0500
@@ -50,11 +50,11 @@
$(MANDIR)/man8/arptables.8: arptables.8
mkdir -p $(@D)
- install -m 0644 -o root -g root $< $@
+ install -m 0644 $< $@
.PHONY: exec
exec: arptables
- install -m 0755 -o root -g root $< $(BINFILE)
+ install -m 0755 $< $(BINFILE)
.PHONY: install
install: $(MANDIR)/man8/arptables.8 exec
@@ -71,14 +71,14 @@
.PHONY: release
release:
mkdir -p include/linux/netfilter_arp
- install -m 0644 -o root -g root \
+ install -m 0644 \
$(KERNEL_DIR)/include/linux/netfilter_arp.h include/linux/
- install -m 0644 -o root -g root \
+ install -m 0644 \
$(KERNEL_DIR)/include/linux/netfilter_arp/*.h \
include/linux/netfilter_arp/
- install -m 0644 -o root -g root \
+ install -m 0644 \
include/netfilter_arp.h include/linux/netfilter_arp.h
- install -m 0644 -o root -g root \
+ install -m 0644 \
include/arp_tables.h include/linux/netfilter_arp/arp_tables.h
make clean
cd ..;tar -c $(DIR) | gzip >$(DIR).tar.gz

12
network/arptables/README Normal file
View file

@ -0,0 +1,12 @@
Arptables is used to set up, maintain, and inspect the tables of ARP rules
in the Linux kernel. It is analogous to iptables, but operates at the ARP
layer rather than the IP layer.
Currently, only support for specifying hardware addresses for Ethernet
is available. This tool is not luser-proof: you can specify an Ethernet
source address and set hardware length to something different than 6, f.e.
arptables was written by Bart De Schuymer based on code from iptables
Arptables Frequently (and less frequently) Asked Questions:
http://ebtables.sourceforge.net/arptables-faq.html

View file

@ -0,0 +1,72 @@
#!/bin/sh
# Slackware build script for arptables
# Written by Menno E. Duursma
# Modified by the SlackBuilds.org project
PRGNAM=arptables
VERSION=0.0.3
ARCH=${ARCH:-i386}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=`pwd`
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
rm -rf $PRGNAM-v0.0.3-2
tar xzvf $CWD/$PRGNAM-v0.0.3-2.tar.gz || exit 1
cd $PRGNAM-v0.0.3-2 || exit 1
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
mkdir -p $PKG/usr/{man,sbin}
# Don't set uid and gid of installed files in the Makefile
# This breaks stuff for anyone who might want to test the
# script as a normal user. We'll take care of ownership
# and permissions in the build script
cat $CWD/Makefile.diff | patch -p1 || exit 1
make || exit 1
make install PREFIX=$PKG/usr || exit 1
( cd $PKG
find . -type f \
| xargs file \
| grep "executable" \
| grep ELF | cut -f 1 -d : \
| xargs strip --strip-unneeded \
2> /dev/null
find . -type f | xargs file \
| grep "shared object" \
| grep ELF \
| cut -f 1 -d : \
| xargs strip --strip-unneeded \
2> /dev/null
)
if [ -d $PKG/usr/man ]; then
gzip -9 $PKG/usr/man/man?/*
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
# Clean up the extra stuff
if [ "$1" = "--cleanup" ]; then
rm -rf $TMP/$PRGNAM-$VERSION
rm -rf $PKG
fi

View file

@ -0,0 +1,8 @@
PRGNAM="arptables"
VERSION="0.0.3"
HOMEPAGE="http://ebtables.sourceforge.net/"
DOWNLOAD="http://dl.sourceforge.net/ebtables/arptables-v0.0.3-2.tar.gz"
MD5SUM="283d19292bd99913dc3a42842826c286"
MAINTAINER="Menno E. Duursma"
EMAIL="druiloor@zonnet.nl"
APPROVED="robw810,elohim"

View file

@ -0,0 +1,11 @@
arptables: arptables - ARP filter table administration
arptables:
arptables: arptables is a user space tool used to set up and maintain
arptables: tables of ARP filter rules in the Linux kernel.
arptables:
arptables: Only support for specifying hardware addresses for
arptables: Ethernet is currently available.
arptables:
arptables: arptables was written by Bart De Schuymer
arptables:
arptables: