network/transmission-remote-gtk: Updated for version 1.6.0.

Signed-off-by: B. Watson <urchlay@slackware.uk>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
B. Watson 2023-07-14 05:12:26 -04:00 committed by Willy Sudiarto Raharjo
parent 039acd2118
commit 5b001b8fe4
No known key found for this signature in database
GPG key ID: 3F617144D7238786
4 changed files with 21 additions and 34 deletions

View file

@ -16,7 +16,6 @@ interface.
Optional dependencies, detected at compile time:
GeoIP - used to display country flags next to IP addresses.
libmrss - used for built-in RSS reader.
If you want to build without libappindicator (systray and
notification) support, set NOTIFY=no in the script's environment.

View file

@ -1,25 +0,0 @@
From b20655081332847426a7d10189bb1e2369efea42 Mon Sep 17 00:00:00 2001
From: David Seifert <soap@gentoo.org>
Date: Fri, 20 Mar 2020 20:30:24 +0100
Subject: [PATCH] Fix building under GCC 10 / -fno-common
* Add a `typedef` to avoid defining a variable.
Bug: https://bugs.gentoo.org/706980
---
src/trg-tree-view.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/trg-tree-view.h b/src/trg-tree-view.h
index 435848f..78cd76e 100644
--- a/src/trg-tree-view.h
+++ b/src/trg-tree-view.h
@@ -51,7 +51,7 @@ GtkWidget *trg_tree_view_new(void);
G_END_DECLS GList *trg_tree_view_get_selected_refs_list(GtkTreeView * tv);
-enum {
+typedef enum {
TRG_COLTYPE_ICONTEXT,
TRG_COLTYPE_FILEICONTEXT,
TRG_COLTYPE_WANTED,

View file

@ -3,7 +3,7 @@
# Slackware build script for transmission-remote-gtk
# Copyright 2012-2016 Chris Walker Copperas Cove, TX
# Copyright 2020 B. Watson <urchlay@slackware.uk>
# Copyright 2020-2023 B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@ -32,6 +32,11 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20230713 bkw: update for v1.6.0.
# - new hard dep libsoup3.
# - no more optional mrss dep (upstream dropped the RSS reader).
# 20220623 bkw: update for v1.5.1.
# 20210926 bkw: BUILD=2, make NOTIFY=no also disable libappindicator.
# 20200526 bkw:
# - take over maintenance
@ -47,7 +52,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=transmission-remote-gtk
VERSION=${VERSION:-1.5.1}
VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -95,6 +100,14 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# 20230713 bkw: mangle the meson.build so it works with Slackware
# 15.0's meson-0.59.x. Eventually this will become difficult or
# impossible, hopefully by then we have a new Slackware release with a
# new enough meson.
sed -i -e '/meson_version:/s,0.60.0,0.59.0,' \
-e "s/'ayatana-appindicator3-0.1', //" \
meson.build
[ "${NOTIFY:-yes}" = "no" ] && NOTIFYOPT="-Dlibappindicator=disabled"
mkdir build
@ -118,8 +131,8 @@ cd ..
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
# 20200526 bkw: lots of optional deps, let the slack-desc keep track of them
ldd $PKG/usr/bin/$PRGNAM > ldd.tmp
for i in libappindicator libmrss GeoIP; do
objdump -p $PKG/usr/bin/$PRGNAM | grep NEEDED > ldd.tmp
for i in libappindicator GeoIP; do
opts+="$i:"
grep -q $i ldd.tmp && opts+="yes " || opts+="no "
done

View file

@ -1,10 +1,10 @@
PRGNAM="transmission-remote-gtk"
VERSION="1.5.1"
VERSION="1.6.0"
HOMEPAGE="https://github.com/transmission-remote-gtk/transmission-remote-gtk/"
DOWNLOAD="https://github.com/transmission-remote-gtk/transmission-remote-gtk/releases/download/1.5.1/transmission-remote-gtk-1.5.1.tar.xz"
MD5SUM="6ba9fe9273bbc0b2bd889ff981e7c449"
DOWNLOAD="https://github.com/transmission-remote-gtk/transmission-remote-gtk/releases/download/1.6.0/transmission-remote-gtk-1.6.0.tar.xz"
MD5SUM="cd284fab5d3919e11f3d0415d7b75078"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="transmission"
REQUIRES="transmission libsoup3"
MAINTAINER="B. Watson"
EMAIL="urchlay@slackware.uk"