mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
libraries/lapack: Updated for version 3.10.1
Signed-off-by: Kyle Guinn <elyk03@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
3c68d3011c
commit
5a140dce96
3 changed files with 78 additions and 31 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for LAPACK
|
||||
|
||||
# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
|
||||
# Copyright 2014-2022 Kyle Guinn <elyk03@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=lapack
|
||||
SRCNAM=lapack
|
||||
VERSION=${VERSION:-3.10.0}
|
||||
VERSION=${VERSION:-3.10.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
|
|||
esac
|
||||
fi
|
||||
|
||||
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
||||
# the name of the created package would be, and then exit. This information
|
||||
# could be useful to other scripts.
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="lapack"
|
||||
VERSION="3.10.0"
|
||||
VERSION="3.10.1"
|
||||
HOMEPAGE="https://www.netlib.org/lapack/"
|
||||
DOWNLOAD="https://github.com/Reference-LAPACK/lapack/archive/v3.10.0/lapack-3.10.0.tar.gz"
|
||||
MD5SUM="d70fc27a8bdebe00481c97c728184f09"
|
||||
DOWNLOAD="https://github.com/Reference-LAPACK/lapack/archive/v3.10.1/lapack-3.10.1.tar.gz"
|
||||
MD5SUM="722407217a080a0012ae3d6913fb8008"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="blas"
|
||||
|
|
|
@ -10,7 +10,7 @@ diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
|
|||
# Create a header file cblas.h for the routines called in my C programs
|
||||
include(FortranCInterface)
|
||||
## Ensure that the fortran compiler and c compiler specified are compatible
|
||||
@@ -51,22 +49,3 @@
|
||||
@@ -49,22 +47,3 @@
|
||||
DESTINATION ${PKG_CONFIG_DIR}
|
||||
COMPONENT Development
|
||||
)
|
||||
|
@ -101,7 +101,7 @@ diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt
|
|||
target_compile_definitions(${CBLASLIB} PRIVATE HAS_ATTRIBUTE_WEAK_SUPPORT)
|
||||
endif()
|
||||
-target_include_directories(${CBLASLIB} PUBLIC
|
||||
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/../include>
|
||||
- $<BUILD_INTERFACE:${LAPACK_BINARY_DIR}/../include>
|
||||
- $<INSTALL_INTERFACE:include>
|
||||
-)
|
||||
target_link_libraries(${CBLASLIB} PRIVATE ${BLAS_LIBRARIES})
|
||||
|
@ -152,7 +152,7 @@ deleted file mode 100644
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -157,11 +157,8 @@
|
||||
@@ -173,11 +173,8 @@
|
||||
|
||||
|
||||
# --------------------------------------------------
|
||||
|
@ -164,7 +164,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development
|
||||
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries
|
||||
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT RuntimeLibraries
|
||||
@@ -201,21 +198,6 @@
|
||||
@@ -217,21 +214,6 @@
|
||||
include(CheckLAPACKCompilerFlags)
|
||||
CheckLAPACKCompilerFlags()
|
||||
|
||||
|
@ -186,8 +186,8 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
# deprecated LAPACK and LAPACKE routines
|
||||
option(BUILD_DEPRECATED "Build deprecated routines" OFF)
|
||||
message(STATUS "Build deprecated routines: ${BUILD_DEPRECATED}")
|
||||
@@ -239,8 +221,9 @@
|
||||
endif()
|
||||
@@ -256,8 +238,9 @@
|
||||
|
||||
|
||||
# --------------------------------------------------
|
||||
-# Subdirectories that need to be processed
|
||||
|
@ -197,7 +197,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
|
||||
# Check the usage of the user provided BLAS libraries
|
||||
if(BLAS_LIBRARIES)
|
||||
@@ -251,131 +234,105 @@
|
||||
@@ -268,133 +251,109 @@
|
||||
if(BLAS_FOUND)
|
||||
message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.")
|
||||
else()
|
||||
|
@ -368,18 +368,20 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
- endif()
|
||||
- endif()
|
||||
- add_subdirectory(TESTING/MATGEN)
|
||||
-endif()
|
||||
+if(BUILD_LAPACKE)
|
||||
+ set(NEED_LAPACK TRUE)
|
||||
endif()
|
||||
-# Reset export target
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME ${LAPACK_INSTALL_EXPORT_NAME_CACHE})
|
||||
-unset(LAPACK_INSTALL_EXPORT_NAME_CACHE)
|
||||
-
|
||||
-if(LAPACKE)
|
||||
+if(BUILD_LAPACKE)
|
||||
+ set(NEED_LAPACK TRUE)
|
||||
add_subdirectory(LAPACKE)
|
||||
endif()
|
||||
|
||||
@@ -428,111 +385,16 @@
|
||||
add_subdirectory(LAPACKE)
|
||||
|
||||
-
|
||||
#-------------------------------------
|
||||
# BLAS++ / LAPACK++
|
||||
option(BLAS++ "Build BLAS++" OFF)
|
||||
@@ -444,111 +403,16 @@
|
||||
ExternalProject_Add_StepDependencies(lapackpp build blaspp ${BLAS_LIBRARIES} ${LAPACK_LIBRARIES})
|
||||
endif()
|
||||
|
||||
|
@ -500,21 +502,38 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
|
||||
--- a/LAPACKE/CMakeLists.txt
|
||||
+++ b/LAPACKE/CMakeLists.txt
|
||||
@@ -1,8 +1,6 @@
|
||||
message(STATUS "LAPACKE enable")
|
||||
@@ -14,7 +14,7 @@
|
||||
add_subdirectory(include)
|
||||
|
||||
|
||||
-if(NOT LAPACKE)
|
||||
+if(NOT BUILD_LAPACKE)
|
||||
return()
|
||||
endif()
|
||||
|
||||
@@ -22,8 +22,6 @@
|
||||
message(STATUS "LAPACKE enabled")
|
||||
enable_language(C)
|
||||
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME ${LAPACKELIB}-targets)
|
||||
-
|
||||
# Create a header file lapacke_mangling.h for the routines called in my C programs
|
||||
include(FortranCInterface)
|
||||
## Ensure that the fortran compiler and c compiler specified are compatible
|
||||
@@ -79,14 +77,6 @@
|
||||
include_directories(include ${LAPACK_BINARY_DIR}/include)
|
||||
add_subdirectory(src)
|
||||
add_subdirectory(utils)
|
||||
@@ -54,7 +52,6 @@
|
||||
message(STATUS "Build LAPACKE single precision complex: ${LAPACKE_BUILD_COMPLEX}")
|
||||
message(STATUS "Build LAPACKE double precision complex: ${LAPACKE_BUILD_COMPLEX16}")
|
||||
|
||||
-append_subdir_files(LAPACKE_INCLUDE "include")
|
||||
append_subdir_files(SOURCES "src")
|
||||
if (LAPACKE_BUILD_SINGLE)
|
||||
append_subdir_files(SOURCES_SINGLE "src")
|
||||
@@ -95,14 +92,6 @@
|
||||
VERSION ${LAPACK_VERSION}
|
||||
SOVERSION ${LAPACK_MAJOR_VERSION}
|
||||
)
|
||||
-target_include_directories(${LAPACKELIB} PUBLIC
|
||||
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
|
||||
- $<BUILD_INTERFACE:${LAPACK_BINARY_DIR}/include>
|
||||
- $<INSTALL_INTERFACE:include>
|
||||
-)
|
||||
-if(WIN32 AND NOT UNIX)
|
||||
|
@ -524,7 +543,16 @@ diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
|
|||
|
||||
if(LAPACKE_WITH_TMG)
|
||||
target_link_libraries(${LAPACKELIB} PRIVATE ${TMGLIB})
|
||||
@@ -111,22 +101,3 @@
|
||||
@@ -111,7 +100,7 @@
|
||||
|
||||
lapack_install_library(${LAPACKELIB})
|
||||
install(
|
||||
- FILES ${LAPACKE_INCLUDE} ${LAPACK_BINARY_DIR}/include/lapacke_mangling.h
|
||||
+ FILES ${LAPACK_BINARY_DIR}/include/lapacke_mangling.h
|
||||
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
|
||||
COMPONENT Development
|
||||
)
|
||||
@@ -127,22 +116,3 @@
|
||||
DESTINATION ${PKG_CONFIG_DIR}
|
||||
COMPONENT Development
|
||||
)
|
||||
|
@ -613,3 +641,25 @@ deleted file mode 100644
|
|||
- endif()
|
||||
-endif()
|
||||
-
|
||||
diff --git a/LAPACKE/include/CMakeLists.txt b/LAPACKE/include/CMakeLists.txt
|
||||
--- a/LAPACKE/include/CMakeLists.txt
|
||||
+++ b/LAPACKE/include/CMakeLists.txt
|
||||
@@ -1,7 +1,13 @@
|
||||
-set(LAPACKE_INCLUDE lapack.h)
|
||||
-
|
||||
-IF(LAPACKE)
|
||||
- list(APPEND LAPACKE_INCLUDE lapacke.h lapacke_config.h lapacke_utils.h)
|
||||
+set(LAPACKE_INCLUDE)
|
||||
+if(BUILD_LAPACK)
|
||||
+ list(APPEND LAPACKE_INCLUDE lapack.h)
|
||||
+endif()
|
||||
+if(BUILD_LAPACKE)
|
||||
+ list(APPEND LAPACKE_INCLUDE lapacke.h lapacke_config.h lapacke_utils.h)
|
||||
endif()
|
||||
|
||||
-file(COPY ${LAPACKE_INCLUDE} DESTINATION ${LAPACK_BINARY_DIR}/include)
|
||||
+install(
|
||||
+ FILES ${LAPACKE_INCLUDE}
|
||||
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
|
||||
+ COMPONENT Development
|
||||
+ )
|
||||
|
|
Loading…
Reference in a new issue