desktop/cdfs: Removed (as per maintainer request).

Upstream inactive + won't build even with AUR patches

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2013-11-16 09:16:05 +01:00 committed by Robby Workman
parent 6fb0e3847d
commit 57e08a4fc0
6 changed files with 0 additions and 259 deletions

View file

@ -1,10 +0,0 @@
CDfs is a file system for Linux systems that "exports" all tracks and boot
images on a CD as normal files. These files can then be mounted (e.g. for
ISO and boot images), copied, played (audio and VCD tracks) The primary goal
for developing this file system was to "unlock" information in old ISO images.
For instance, if you have a multisession CD with two ISO images that both
contain the file 'a', you only see the file 'a' in the second session if you
use the iso9660 file system.
Because this installs a kernel module, you will need to rebuild the package
if you change kernels.

View file

@ -1,144 +0,0 @@
---
Makefile | 14 +++++---------
cddata.c | 2 +-
proc.c | 6 +++---
root.c | 25 +++++++++++--------------
4 files changed, 20 insertions(+), 27 deletions(-)
Index: cdfs-2.6.27/Makefile
===================================================================
--- cdfs-2.6.27.orig/Makefile
+++ cdfs-2.6.27/Makefile
@@ -1,18 +1,14 @@
-ifneq ($(KERNELRELEASE),)
obj-m := cdfs.o
cdfs-objs := root.o audio.o cdXA.o cddata.o hfs.o iso.o proc.o root.o utils.o daemon.o discid.o toc.o
-else
KDIR := /lib/modules/$(shell uname -r)/build
PWD := $(shell pwd)
-all:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-
-install:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
-endif
+all modules:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+install modules_install:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules_install
clean:
- -rm *.o *.ko .*.cmd *.mod.c *~
+ $(MAKE) -C $(KDIR) M=$(PWD) clean
Index: cdfs-2.6.27/cddata.c
===================================================================
--- cdfs-2.6.27.orig/cddata.c
+++ cdfs-2.6.27/cddata.c
@@ -108,7 +108,7 @@ int cdfs_read_rawDATA_frame(struct super
bh=cdfs_bread(sb, lba, CD_FRAMESIZE);
if (!bh) {
// dit gebeurt indien track1!=ISO is, bv. De Morgen CD
- printk("cdfs_read_rawDATA(%x, %u, %x) FAILED!\n", (unsigned)sb, lba, (unsigned)buf);
+ printk("cdfs_read_rawDATA(%lx, %u, %lx) FAILED!\n", (unsigned long)sb, lba, (unsigned long)buf);
} else {
memcpy(buf, bh->b_data, CD_FRAMESIZE);
brelse(bh);
Index: cdfs-2.6.27/proc.c
===================================================================
--- cdfs-2.6.27.orig/proc.c
+++ cdfs-2.6.27/proc.c
@@ -262,7 +262,7 @@ cdfs_show(struct seq_file *file_p, void
if (track_p->iso_size) {
seq_printf(
file_p,
- "Track %2d: data track (%s), [%d-%d/%d], length=%d MB\n",
+ "Track %2ld: data track (%s), [%d-%d/%d], length=%d MB\n",
TRACK_POINTER_TO_TRACK_NUMBER(track_p),
track_p->name,
track_p->start_lba,
@@ -313,7 +313,7 @@ cdfs_show(struct seq_file *file_p, void
} else {
seq_printf(
file_p,
- "Track %2d: data track (%s), [%d-%d], length=%d kB\n",
+ "Track %2ld: data track (%s), [%d-%d], length=%d kB\n",
TRACK_POINTER_TO_TRACK_NUMBER(track_p),
track_p->name,
track_p->start_lba,
@@ -362,7 +362,7 @@ cdfs_show(struct seq_file *file_p, void
cdfs_constructMSFsize(MSFsize, track_p->size);
seq_printf(
file_p,
- "Track %2d: audio track (%s), [%8d -%8d], length=%s\n",
+ "Track %2ld: audio track (%s), [%8d -%8d], length=%s\n",
TRACK_POINTER_TO_TRACK_NUMBER(track_p),
track_p->name,
track_p->start_lba,
Index: cdfs-2.6.27/root.c
===================================================================
--- cdfs-2.6.27.orig/root.c
+++ cdfs-2.6.27/root.c
@@ -25,6 +25,7 @@
#include "cdfs.h"
#include <linux/module.h>
+#include <linux/sched.h>
/*++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++*
@@ -375,7 +376,9 @@ out:
PRINT("retinode = %ld\n", retinode->i_ino);
- sb->s_root = d_alloc_root(retinode);
+ sb->s_root = d_make_root(retinode);
+ if (sb->s_root != NULL)
+ return -ENOMEM;
cdfs_proc_cd = this_cd;
@@ -517,7 +520,7 @@ static void cdfs_read_inode(struct inode
i->i_uid = this_cd->uid;
i->i_gid = this_cd->gid;
- i->i_nlink = 1;
+ set_nlink(i, 1);
i->i_op = &cdfs_inode_operations;
i->i_fop = NULL;
i->i_data.a_ops = NULL;
@@ -594,26 +597,20 @@ static struct super_operations cdfs_ops
.statfs = cdfs_statfs
};
-#ifdef OLD_KERNEL
-static DECLARE_FSTYPE_DEV(cdfs_fs_type, FSNAME, cdfs_mount);
-#else
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)
-static int cdfs_get_sb(struct file_system_type *fs_type, int flags, const char *dev_name, void *data, struct vfsmount *mnt) {
- return get_sb_bdev(fs_type, flags, dev_name, data, cdfs_fill_super, mnt);
-#else
-static struct super_block *cdfs_get_sb(struct file_system_type *fs_type, int flags, const char *dev_name, void *data) {
- return get_sb_bdev(fs_type, flags, dev_name, data, cdfs_fill_super);
-#endif
+static struct dentry *
+cdfs_mount_modern(struct file_system_type *fstype, int flags,
+ const char *dev_name, void *data)
+{
+ return mount_bdev(fstype, flags, dev_name, data, cdfs_fill_super);
}
static struct file_system_type cdfs_fs_type = {
.owner = THIS_MODULE,
.name = "cdfs",
- .get_sb = cdfs_get_sb,
+ .mount = cdfs_mount_modern,
.kill_sb = kill_block_super,
.fs_flags = FS_REQUIRES_DEV
};
-#endif
/******************************************************/

View file

@ -1,75 +0,0 @@
#!/bin/sh
# Slackware build script for cdfs
# Copyright 2009, 2010 Robby Workman Northport, AL, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Maintained by markus reichelt <slackbuilds@mareichelt.de> 0xCCEEF115
# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
PRGNAM=cdfs
VERSION=${VERSION:-2.6.27}
ARCH=$(uname -m)
BUILD=${BUILD:-5}
TAG=${TAG:-_SBo}
KERNEL=${KERNEL:-"$(uname -r)"}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# include new upstream patches
patch -p1 < $CWD/cdfs-3.3.diff
make KDIR=/lib/modules/${KERNEL}/build
mkdir -p $PKG/lib/modules/${KERNEL}/extra
install -m 0644 cdfs.ko $PKG/lib/modules/${KERNEL}/extra
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CHANGES COPYING INSTALL cdfs.html \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
sed "s%@KERNEL@%$KERNEL%" $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="cdfs"
VERSION="2.6.27"
HOMEPAGE="http://users.elis.ugent.be/~mronsse/cdfs/"
DOWNLOAD="http://users.elis.ugent.be/~mronsse/cdfs/download/cdfs-2.6.27.tar.bz2"
MD5SUM="ac64c014a90e3c488394832ea29605b3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="markus reichelt"
EMAIL="slackbuilds@mareichelt.de"

View file

@ -1 +0,0 @@
chroot . /sbin/depmod -a @KERNEL@

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
cdfs: CDfs (cd filesystem driver)
cdfs:
cdfs: CDfs is a file system for Linux systems that `exports' all tracks and
cdfs: boot images on a CD as normal files. These files can then be mounted
cdfs: (e.g. for ISO and boot images), copied, played (audio and VCD tracks)
cdfs: The primary goal for developing this file system was to "unlock"
cdfs: information in old ISO images.
cdfs:
cdfs: Homepage: http://users.elis.ugent.be/~mronsse/cdfs/
cdfs:
cdfs: