mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
libraries/opencv: Updated for version 2.4.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
d5db4462bd
commit
575e2a1663
5 changed files with 11 additions and 57 deletions
|
@ -4,3 +4,6 @@ OpenCV is a library of programming functions mainly
|
|||
aimed at real-time computer vision.
|
||||
|
||||
FFmpeg and Numpy are optional runtime dependencies.
|
||||
|
||||
*NOTE*
|
||||
If compiling with FFmpeg you must use 0.8.7 or newer.
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff -up OpenCV-2.3.1/CMakeLists.txt.00 OpenCV-2.3.1/CMakeLists.txt
|
||||
--- OpenCV-2.3.1/CMakeLists.txt.00 2011-12-28 14:46:28.825000098 -0600
|
||||
+++ OpenCV-2.3.1/CMakeLists.txt 2011-12-28 14:48:31.277000108 -0600
|
||||
@@ -18,7 +18,7 @@ if(NOT CMAKE_TOOLCHAIN_FILE)
|
||||
# Add these standard paths to the search paths for FIND_LIBRARY
|
||||
# to find libraries from these locations first
|
||||
if(UNIX)
|
||||
- set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /lib /usr/lib)
|
||||
+ set(CMAKE_LIBRARY_PATH ${CMAKE_LIBRARY_PATH} /lib${LIB_SUFFIX} /usr/lib${LIB_SUFFIX})
|
||||
endif()
|
||||
|
||||
# it _must_ go before PROJECT(OpenCV) in order to work
|
||||
@@ -117,7 +117,7 @@ endif()
|
||||
|
||||
# SUBDIRECTORIES:
|
||||
# Save libs and executables in the same place
|
||||
-set(LIBRARY_OUTPUT_PATH "${CMAKE_BINARY_DIR}/lib" CACHE PATH "Output directory for libraries" )
|
||||
+set(LIBRARY_OUTPUT_PATH "${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}" CACHE PATH "Output directory for libraries" )
|
||||
set(EXECUTABLE_OUTPUT_PATH "${CMAKE_BINARY_DIR}/bin" CACHE PATH "Output directory for applications" )
|
||||
|
||||
if(ANDROID OR WIN32)
|
||||
@@ -665,9 +665,9 @@ if(CMAKE_HOST_UNIX)
|
||||
OUTPUT_VARIABLE PYTHON_STD_PACKAGES_PATH
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
if("${PYTHON_STD_PACKAGES_PATH}" MATCHES "site-packages")
|
||||
- set(PYTHON_PACKAGES_PATH lib/python${PYTHON_VERSION_MAJOR_MINOR}/site-packages CACHE PATH "Where to install the python packages.")
|
||||
+ set(PYTHON_PACKAGES_PATH lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR_MINOR}/site-packages CACHE PATH "Where to install the python packages.")
|
||||
else() #debian based assumed, install to the dist-packages.
|
||||
- set(PYTHON_PACKAGES_PATH lib/python${PYTHON_VERSION_MAJOR_MINOR}/dist-packages CACHE PATH "Where to install the python packages.")
|
||||
+ set(PYTHON_PACKAGES_PATH lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR_MINOR}/site-packages CACHE PATH "Where to install the python packages.")
|
||||
endif()
|
||||
endif()
|
||||
if(CMAKE_HOST_WIN32)
|
|
@ -1,11 +0,0 @@
|
|||
diff -up OpenCV-2.3.1/modules/highgui/src/cap_ffmpeg_impl.hpp.00 OpenCV-2.3.1/modules/highgui/src/cap_ffmpeg_impl.hpp
|
||||
--- OpenCV-2.3.1/modules/highgui/src/cap_ffmpeg_impl.hpp.00 2011-12-28 14:50:07.038000125 -0600
|
||||
+++ OpenCV-2.3.1/modules/highgui/src/cap_ffmpeg_impl.hpp 2011-12-28 14:51:11.687000116 -0600
|
||||
@@ -104,6 +104,7 @@ extern "C" {
|
||||
#endif
|
||||
#if defined(HAVE_LIBAVCODEC_AVCODEC_H)
|
||||
#include <libavcodec/avcodec.h>
|
||||
+ #include <libavutil/mathematics.h>
|
||||
#endif
|
||||
#if defined(HAVE_LIBSWSCALE_SWSCALE_H)
|
||||
#include <libswscale/swscale.h>
|
|
@ -6,8 +6,8 @@
|
|||
|
||||
PRGNAM=opencv
|
||||
SRCNAM=OpenCV
|
||||
VERSION=${VERSION:-2.3.1a}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.4.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -44,7 +44,7 @@ mkdir -p $TMP $PKG $OUTPUT
|
|||
cd $TMP
|
||||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
|
||||
cd $SRCNAM-2.3.1
|
||||
cd $SRCNAM-2.4.0
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
|
@ -52,12 +52,6 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Honor LIB_SUFFIX
|
||||
patch -p1 < $CWD/libopencv-2.3.1a-libdir.patch
|
||||
|
||||
# Fix building with ffmmpeg 0.6/0.8
|
||||
patch -p1 < $CWD/opencv-2.3.1a-libav-0.7.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
PRGNAM="opencv"
|
||||
VERSION="2.3.1a"
|
||||
VERSION="2.4.0"
|
||||
HOMEPAGE="http://opencv.willowgarage.com/wiki/"
|
||||
DOWNLOAD="http://sourceforge.net/projects/opencvlibrary/files/opencv-unix/2.3.1/OpenCV-2.3.1a.tar.bz2"
|
||||
MD5SUM="82e4b6bfa349777233eea09b075e931e"
|
||||
DOWNLOAD="http://sourceforge.net/projects/opencvlibrary/files/opencv-unix/2.4.0/OpenCV-2.4.0.tar.bz2"
|
||||
MD5SUM="1fcda4ed3d0655f033ac30be8bad4882"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="M.Dinslage"
|
||||
EMAIL="daedra1980@gmail.com"
|
||||
APPROVED="rworkman"
|
||||
APPROVED="dsomero"
|
||||
|
||||
|
|
Loading…
Reference in a new issue