mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
network/youtube-dl: Updated for version 2018.06.25.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
42fc2daf44
commit
56125c1528
5 changed files with 15 additions and 2650 deletions
|
@ -1,44 +1,5 @@
|
|||
--- youtube-dl-2018.05.01/Makefile.orig 2018-05-06 18:08:39.581459715 +0200
|
||||
+++ youtube-dl-2018.05.01/Makefile 2018-05-06 18:10:24.291462210 +0200
|
||||
@@ -5,11 +5,11 @@
|
||||
find . -name "*.pyc" -delete
|
||||
find . -name "*.class" -delete
|
||||
|
||||
-PREFIX ?= /usr/local
|
||||
+PREFIX ?= /usr
|
||||
BINDIR ?= $(PREFIX)/bin
|
||||
MANDIR ?= $(PREFIX)/man
|
||||
SHAREDIR ?= $(PREFIX)/share
|
||||
-PYTHON ?= /usr/bin/env python
|
||||
+PYTHON ?= /usr/bin/python
|
||||
|
||||
# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
|
||||
SYSCONFDIR = $(shell if [ $(PREFIX) = /usr -o $(PREFIX) = /usr/local ]; then echo /etc; else echo $(PREFIX)/etc; fi)
|
||||
@@ -55,7 +55,7 @@
|
||||
|
||||
.PHONY: all clean install test tar bash-completion pypi-files zsh-completion fish-completion ot offlinetest codetest supportedsites
|
||||
|
||||
-pypi-files: youtube-dl.bash-completion README.txt youtube-dl.1 youtube-dl.fish
|
||||
+pypi-files: youtube-dl.bash-completion README.md youtube-dl.1 youtube-dl.fish
|
||||
|
||||
youtube-dl: youtube_dl/*.py youtube_dl/*/*.py
|
||||
mkdir -p zip
|
||||
@@ -85,11 +85,11 @@
|
||||
$(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
|
||||
|
||||
README.txt: README.md
|
||||
- pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
|
||||
+ #pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
|
||||
|
||||
youtube-dl.1: README.md
|
||||
$(PYTHON) devscripts/prepare_manpage.py youtube-dl.1.temp.md
|
||||
- pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
+ #pandoc -s -f $(MARKDOWN) -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
rm -f youtube-dl.1.temp.md
|
||||
|
||||
youtube-dl.bash-completion: youtube_dl/*.py youtube_dl/*/*.py devscripts/bash-completion.in
|
||||
--- youtube-dl-2018.05.01/setup.py.orig 2018-05-06 18:08:48.362459924 +0200
|
||||
+++ youtube-dl-2018.05.01/setup.py 2018-05-06 18:11:02.935463131 +0200
|
||||
--- youtube-dl-2018.06.25/setup.py.orig 2018-06-30 08:56:35.007072725 +0200
|
||||
+++ youtube-dl-2018.06.25/setup.py 2018-06-30 08:56:54.365073186 +0200
|
||||
@@ -59,10 +59,10 @@
|
||||
params = py2exe_params
|
||||
else:
|
||||
|
@ -49,8 +10,8 @@
|
|||
- ('share/man/man1', ['youtube-dl.1'])
|
||||
+ ('/etc/bash_completion.d', ['youtube-dl.bash-completion']),
|
||||
+ ('/etc/fish/completions', ['youtube-dl.fish']),
|
||||
+ ('usr/doc/youtube_dl', ['README.txt']),
|
||||
+ ('usr/man/man1', ['youtube-dl.1'])
|
||||
+ ('doc/youtube_dl', ['README.txt']),
|
||||
+ ('man/man1', ['youtube-dl.1'])
|
||||
]
|
||||
root = os.path.dirname(os.path.abspath(__file__))
|
||||
data_files = []
|
||||
|
|
|
@ -11,7 +11,7 @@ youtube-dl:
|
|||
youtube-dl: youtube-dl is a small command-line program to download videos
|
||||
youtube-dl: from YouTube.com. It's licensed under the MIT License.
|
||||
youtube-dl:
|
||||
youtube-dl: Homepage: http://rg3.github.com/youtube-dl/
|
||||
youtube-dl: Homepage: http://www.yt-dl.org/
|
||||
youtube-dl:
|
||||
youtube-dl:
|
||||
youtube-dl:
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -24,7 +24,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=youtube-dl
|
||||
VERSION=${VERSION:-2018.06.02}
|
||||
VERSION=${VERSION:-2018.06.25}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -61,7 +61,8 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
mkdir $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz -C $PRGNAM-$VERSION --strip-components 1
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
@ -73,7 +74,6 @@ find -L . \
|
|||
# setup.py patch
|
||||
patch -p1 < $CWD/setup.patch
|
||||
|
||||
make
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
# Python 3 support.
|
||||
|
@ -81,21 +81,11 @@ if $(python3 -c 'import sys' 2>/dev/null); then
|
|||
python3 setup.py install --root=$PKG
|
||||
fi
|
||||
|
||||
# enable bash and fish completion file
|
||||
chmod 0755 $PKG/etc/bash_completion.d/${PRGNAM}.bash-completion
|
||||
chmod 0755 $PKG/etc/fish/completions/${PRGNAM}.fish
|
||||
|
||||
# remove strange folders.
|
||||
rm -rf $PKG/usr/usr
|
||||
|
||||
# install man page
|
||||
mkdir -p $PKG/usr/man/man1
|
||||
install -D -m0644 $CWD/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
|
||||
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README.md LICENSE AUTHORS ${PRGNAM}.plugin.zsh docs/*.md \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README.md LICENSE AUTHORS ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="youtube-dl"
|
||||
VERSION="2018.06.02"
|
||||
HOMEPAGE="https://rg3.github.io/youtube-dl"
|
||||
DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2018.06.02/youtube-dl-2018.06.02.tar.gz"
|
||||
MD5SUM="2e778de1495872791dfc7eaec1bf0ef0"
|
||||
VERSION="2018.06.25"
|
||||
HOMEPAGE="http://www.yt-dl.org/"
|
||||
DOWNLOAD="http://www.yt-dl.org/downloads/latest/youtube-dl-2018.06.25.tar.gz"
|
||||
MD5SUM="3f73e5bcaf7db086146c3c9d3d527b0b"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue