mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
desktop/ratpoison: Updated for version 1.4.5
This commit is contained in:
parent
5898152d34
commit
555bf07141
6 changed files with 56 additions and 47 deletions
2
desktop/ratpoison/doinst.sh
Normal file
2
desktop/ratpoison/doinst.sh
Normal file
|
@ -0,0 +1,2 @@
|
|||
chroot . /usr/bin/install-info /usr/info/ratpoison.info.gz /usr/info/dir 2> /dev/null
|
||||
|
12
desktop/ratpoison/ratpoison-1.4.5-fixup_docdir.diff
Normal file
12
desktop/ratpoison/ratpoison-1.4.5-fixup_docdir.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur ratpoison-1.4.5.orig/Makefile.in ratpoison-1.4.5/Makefile.in
|
||||
--- ratpoison-1.4.5.orig/Makefile.in 2009-07-12 07:07:06.000000000 -0500
|
||||
+++ ratpoison-1.4.5/Makefile.in 2009-09-07 22:07:47.339074257 -0500
|
||||
@@ -145,7 +145,7 @@
|
||||
builddir = @builddir@
|
||||
datadir = @datadir@
|
||||
datarootdir = @datarootdir@
|
||||
-docdir = $(datadir)/doc/$(PACKAGE)
|
||||
+docdir = @docdir@
|
||||
dvidir = @dvidir@
|
||||
exec_prefix = @exec_prefix@
|
||||
host_alias = @host_alias@
|
|
@ -1,11 +1,10 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for ratpoison
|
||||
|
||||
# Written by Grigorios Bouzakis (grbzks@gmail.com)
|
||||
# Written by Grigorios Bouzakis (grbzks@xsmail.com)
|
||||
|
||||
PRGNAM=ratpoison
|
||||
VERSION=${VERSION:-1.4.3}
|
||||
VERSION=${VERSION:-1.4.5}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
@ -17,14 +16,15 @@ OUTPUT=${OUTPUT:-/tmp}
|
|||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRDSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRDSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRDSUFFIX="64"
|
||||
fi
|
||||
|
||||
DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README TODO"
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
|
@ -40,6 +40,8 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix the docdir declaration
|
||||
patch -p1 < $CWD/ratpoison-1.4.5-fixup_docdir.diff
|
||||
|
||||
# Set the terminal emulator to be used as default by ratpoison
|
||||
# The default is xterm if it's not specified in ./configure, so
|
||||
|
@ -51,17 +53,26 @@ CFLAGS="$SLKCFLAGS" \
|
|||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--with-xterm=$XTERM
|
||||
--infodir=/usr/info \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--with-xterm=$XTERM \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
mkdir -p $PKG/etc/X11/xinit
|
||||
install -m 0755 $CWD/xinitrc.ratpoison $PKG/etc/X11/xinit/xinitrc.ratpoison
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man
|
||||
|
@ -69,21 +80,16 @@ make install DESTDIR=$PKG
|
|||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
mv $PKG/usr/share/info $PKG/usr/
|
||||
rm -f $PKG/usr/info/dir
|
||||
gzip -9 $PKG/usr/info/*.info*
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mv $PKG/usr/share/doc/ratpoison/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rm -rf $PKG/usr/share/doc
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
# Add some missed docs
|
||||
cp -a INSTALL TODO $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
mkdir -p $PKG/etc/X11/xinit
|
||||
install -m 0755 $CWD/xinitrc.ratpoison $PKG/etc/X11/xinit/xinitrc.ratpoison
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
PRGNAM="ratpoison"
|
||||
VERSION="1.4.3"
|
||||
VERSION="1.4.5"
|
||||
HOMEPAGE="http://www.nongnu.org/ratpoison/"
|
||||
DOWNLOAD="http://savannah.nongnu.org/download/ratpoison/ratpoison-1.4.3.tar.gz"
|
||||
MD5SUM="c1899e3e2549d29825cdb1b8d042c836"
|
||||
DOWNLOAD="http://savannah.nongnu.org/download/ratpoison/ratpoison-1.4.5.tar.gz"
|
||||
MD5SUM="330a08dbed6be88cab54f6947e9f0b60"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Grigorios Bouzakis"
|
||||
EMAIL="grbzks@gmail.com"
|
||||
APPROVED="dsomero"
|
||||
EMAIL="grbzks@xsmail.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
|
@ -7,13 +7,13 @@
|
|||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
ratpoison: ratpoison (a light tiling window manager for X)
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
ratpoison: ratpoison is a simple Window Manager with no fat library dependencies,
|
||||
ratpoison: no fancy graphics, no window decorations, and no rodent dependence.
|
||||
ratpoison: It is largely modelled after GNU Screen which has done wonders in the
|
||||
ratpoison: virtual terminal market.
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
ratpoison: Homepage: http://www.nongnu.org/ratpoison/
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
ratpoison:
|
||||
|
|
|
@ -1,29 +1,16 @@
|
|||
#!/bin/sh
|
||||
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $
|
||||
|
||||
userresources=$HOME/.Xresources
|
||||
usermodmap=$HOME/.Xmodmap
|
||||
sysresources=/usr/lib/X11/xinit/.Xresources
|
||||
sysmodmap=/usr/lib/X11/xinit/.Xmodmap
|
||||
sysresources=/etc/X11/xinit/.Xresources
|
||||
sysmodmap=/etc/X11/xinit/.Xmodmap
|
||||
|
||||
# merge in defaults and keymaps
|
||||
|
||||
if [ -f $sysresources ]; then
|
||||
/usr/X11R6/bin/xrdb -merge $sysresources
|
||||
fi
|
||||
|
||||
if [ -f $sysmodmap ]; then
|
||||
/usr/X11R6/bin/xmodmap $sysmodmap
|
||||
fi
|
||||
|
||||
if [ -f $userresources ]; then
|
||||
/usr/X11R6/bin/xrdb -merge $userresources
|
||||
fi
|
||||
|
||||
if [ -f $usermodmap ]; then
|
||||
/usr/X11R6/bin/xmodmap $usermodmap
|
||||
fi
|
||||
|
||||
# start some nice programs
|
||||
[ -f $sysresources ] && xrdb -merge $sysresources
|
||||
[ -f $sysmodmap ] && xmodmap $sysmodmap
|
||||
[ -f $userresources ] && xrdb -merge $userresources
|
||||
[ -f $usermodmap ] && xmodmap $usermodmap
|
||||
|
||||
exec ratpoison
|
||||
|
||||
|
|
Loading…
Reference in a new issue