system/pdksh: Added (the Public Domain Korn Shell)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Azure Zanculmarktum 2017-07-06 00:53:43 -05:00 committed by Willy Sudiarto Raharjo
parent 3a40360171
commit 5494138f2b
6 changed files with 178 additions and 0 deletions

View file

@ -0,0 +1,29 @@
diff --git a/Makefile.in b/Makefile.in
index 10d7b32..25e79b0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -133,7 +133,7 @@ config.status: configure
# two steps to prevent the creation of a bogus siglist.out
siglist.out: config.h sh.h siglist.in siglist.sh
- $(srcdir)/siglist.sh "$(CPP) $(CPPFLAGS) $(DEFS) -I. -I$(srcdir)" < $(srcdir)/siglist.in > tmpsiglist.out
+ $(srcdir)/siglist.sh "$(CPP) $(CPPFLAGS) $(DEFS) -I. -I$(srcdir) -P" < $(srcdir)/siglist.in > tmpsiglist.out
mv tmpsiglist.out siglist.out
# two steps to prevent the creation of a bogus emacs.out
diff --git a/Makefile.in b/Makefile.in
index 25e79b0..5779948 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -80,8 +80,8 @@ all: $(SHELL_PROG)$(exe_suffix) $(SHELL_PROG).1
$(CC) -c $(CPPFLAGS) $(DEFS) -I. -I$(srcdir) $(CFLAGS) $<
install: installdirs all
- $(INSTALL_PROGRAM) $(SHELL_PROG)$(exe_suffix) $(bindir)/`echo $(SHELL_PROG)|sed '$(transform)'`$(exe_suffix)
- -$(INSTALL_DATA) $(SHELL_PROG).1 $(mandir)/`echo $(SHELL_PROG)|sed '$(transform)'`.$(manext)
+ $(INSTALL_PROGRAM) $(SHELL_PROG)$(exe_suffix) -D $(DESTDIR)$(bindir)/`echo $(SHELL_PROG)|sed '$(transform)'`$(exe_suffix)
+ -$(INSTALL_DATA) $(SHELL_PROG).1 -D $(DESTDIR)$(mandir)/`echo $(SHELL_PROG)|sed '$(transform)'`.$(manext)
-@prog=$(bindir)/`echo $(SHELL_PROG)|sed '$(transform)'`$(exe_suffix);\
test -f /etc/shells \
&& (grep "^$$prog\$$" /etc/shells > /dev/null \

5
system/pdksh/README Normal file
View file

@ -0,0 +1,5 @@
PD-ksh is a clone of the AT&T; Korn shell. At the moment, it has most of
the ksh88 features, not much of the ksh93 features, and a number of its
own features. pdksh was initially created by Eric Gisin using Charles
Forsyth's public domain V7 shell as a base as well as parts of the BRL
shell.

10
system/pdksh/doinst.sh Normal file
View file

@ -0,0 +1,10 @@
# Add entries to /etc/shells if we need them
if [ ! -r etc/shells ] ; then
touch etc/shells
chmod 644 etc/shells
fi
if ! grep -Fqs "/bin/pdksh" etc/shells ; then
echo "/bin/pdksh" >> etc/shells
fi

View file

@ -0,0 +1,105 @@
#!/bin/sh
# Slackware build script for pdksh
# Copyright 2017 Azure Zanculmarktum <zanculmarktum@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pdksh
VERSION=${VERSION:-5.2.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 -i $CWD/Makefile.in.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--program-prefix="pd" \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--build=$ARCH-slackware-linux
make
make install bindir=/bin DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
BUG-REPORTS CONTRIBUTORS ChangeLog IAFA-PACKAGE LEGAL NEWS NOTES PROJECTS README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
system/pdksh/pdksh.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="pdksh"
VERSION="5.2.14"
HOMEPAGE="https://web.archive.org/web/20141127103527/http://www.cs.mun.ca/~michael/pdksh/"
DOWNLOAD="https://mirrors.slackware.com/slackware/slackware-8.0/contrib/contrib-sources/pdksh-5.2.14/pdksh-5.2.14.tar.gz"
MD5SUM="871106b3bd937e1afba9f2ef7c43aef3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Azure Zanculmarktum"
EMAIL="zanculmarktum@gmail.com"

19
system/pdksh/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
pdksh: pdksh (the Public Domain Korn Shell)
pdksh:
pdksh: PD-ksh is a clone of the AT&T; Korn shell. At the moment, it has most
pdksh: of the ksh88 features, not much of the ksh93 features, and a number of
pdksh: its own features. pdksh was initially created by Eric Gisin using
pdksh: Charles Forsyth's public domain V7 shell as a base as well as parts of
pdksh: the BRL shell.
pdksh:
pdksh:
pdksh:
pdksh: