mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
office/pdftk: Updated for version 1.41
This commit is contained in:
parent
78d31b3e0d
commit
53ab76d880
6 changed files with 285 additions and 25 deletions
|
@ -1,7 +1,9 @@
|
||||||
If PDF is electronic paper, then pdftk is an electronic
|
If PDF is electronic paper, then pdftk is an electronic staple-remover,
|
||||||
staple-remover, hole-punch, binder, secret-decoder-ring, and
|
hole-punch, binder, secret-decoder-ring, and X-Ray-glasses. Pdftk is a
|
||||||
X-Ray-glasses. Pdftk is a command-line tool for doing everyday things
|
command-line tool for doing everyday things with PDF documents. Keep one
|
||||||
with PDF documents. Keep one in the top drawer of your desktop and
|
in the top drawer of your desktop and use it to merge PDF documents,
|
||||||
use it to: Merge PDF documents, split PDF documents, apply watermark,
|
split PDF documents, apply watermarks, repair corrupt PDF, update PDF
|
||||||
repair corrupt PDF, update PDF metadata and much more.
|
metadata, and more. pdftk does not require Acrobat and is free software.
|
||||||
pdftk does not require Acrobat and is free software (GPL)
|
|
||||||
|
While not strictly required, you probably want to have the jdk package
|
||||||
|
from extra installed (instead of L/jre) when building pdftk.
|
||||||
|
|
20
office/pdftk/pdftk-1.41-add_custom_optflags.patch
Normal file
20
office/pdftk/pdftk-1.41-add_custom_optflags.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
diff -Nur pdftk-1.41.orig/pdftk/Makefile.Generic pdftk-1.41/pdftk/Makefile.Generic
|
||||||
|
--- pdftk-1.41.orig/pdftk/Makefile.Generic 2006-09-21 12:37:12.000000000 -0500
|
||||||
|
+++ pdftk-1.41/pdftk/Makefile.Generic 2009-11-26 00:03:40.823641779 -0600
|
||||||
|
@@ -23,12 +23,13 @@
|
||||||
|
# if you want pdftk to ask before overwriting a file, set
|
||||||
|
# ASK_ABOUT_WARNINGS to true; otherwise: false; override this default
|
||||||
|
# with the dont_ask or do_ask command-line options
|
||||||
|
-CPPFLAGS= -O2 -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -fdollars-in-identifiers
|
||||||
|
-CXXFLAGS= -lgcj
|
||||||
|
+OPT= -O2
|
||||||
|
+CPPFLAGS= $(OPT) -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -fdollars-in-identifiers
|
||||||
|
+CXXFLAGS= $(OPT) -lgcj
|
||||||
|
|
||||||
|
# itext compiler flags
|
||||||
|
# -O3 might cause pdftk to segfault on cat operation (gcc 3.4.4)
|
||||||
|
-export GCJFLAGS= -O2
|
||||||
|
+export GCJFLAGS= $(OPT) -w
|
||||||
|
|
||||||
|
#
|
||||||
|
export ARFLAGS= rs
|
229
office/pdftk/pdftk-1.41-slackware64-13.patch
Normal file
229
office/pdftk/pdftk-1.41-slackware64-13.patch
Normal file
|
@ -0,0 +1,229 @@
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/bc/asn1/Makefile pdftk-1.41/java_libs/com/lowagie/bc/asn1/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/bc/asn1/Makefile 2006-07-28 01:18:06.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/bc/asn1/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/Makefile pdftk-1.41/java_libs/com/lowagie/text/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/Makefile 2006-07-26 23:14:34.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -25,13 +25,12 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
|
||||||
|
-all : $(library) $(headers)
|
||||||
|
+all : $(library) $(headers) $(classes)
|
||||||
|
|
||||||
|
$(library) : $(objects)
|
||||||
|
$(AR) $(ARFLAGS) $(library) $(objects);
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/markup/Makefile pdftk-1.41/java_libs/com/lowagie/text/markup/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/markup/Makefile 2006-07-26 23:14:54.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/markup/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/Makefile 2006-07-26 23:15:20.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/Makefile 2009-11-16 15:37:55.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile 2006-07-28 01:21:06.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile 2009-11-16 15:38:15.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile 2006-07-26 23:15:32.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile 2009-11-16 15:38:34.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/fonts/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/fonts/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/fonts/Makefile 2006-07-26 23:15:48.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/fonts/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -34,8 +34,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/Makefile 2006-07-26 23:15:10.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfDate.java pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfDate.java
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfDate.java 2006-07-27 01:56:42.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfDate.java 2009-11-16 15:33:37.000000000 +0100
|
||||||
|
@@ -76,7 +76,7 @@
|
||||||
|
// ssteward; static builds of pdftk (Windows, gcc 3.3.1) would
|
||||||
|
// omit this class because of its reference by reflection;
|
||||||
|
// this treatment ensures that ld will include it
|
||||||
|
- private static Class c1= gnu.java.locale.Calendar.class;
|
||||||
|
+ private static Class c1= java.util.Calendar.class;
|
||||||
|
|
||||||
|
private static final int dateSpace[] = {Calendar.YEAR, 4, 0, Calendar.MONTH, 2, -1, Calendar.DAY_OF_MONTH, 2, 0,
|
||||||
|
Calendar.HOUR_OF_DAY, 2, 0, Calendar.MINUTE, 2, 0, Calendar.SECOND, 2, 0};
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfEncryption.java pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfEncryption.java
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/pdf/PdfEncryption.java 2006-07-27 02:02:28.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfEncryption.java 2009-11-16 15:46:10.000000000 +0100
|
||||||
|
@@ -50,7 +50,7 @@
|
||||||
|
|
||||||
|
package com.lowagie.text.pdf;
|
||||||
|
|
||||||
|
-import java_local.security.MessageDigest; // ssteward
|
||||||
|
+import java.security.MessageDigest;
|
||||||
|
import com.lowagie.text.ExceptionConverter;
|
||||||
|
|
||||||
|
/**
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/com/lowagie/text/xml/xmp/Makefile pdftk-1.41/java_libs/com/lowagie/text/xml/xmp/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/com/lowagie/text/xml/xmp/Makefile 2006-07-27 02:53:34.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/com/lowagie/text/xml/xmp/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -25,8 +25,7 @@
|
||||||
|
# the "$*" automatic variable, here
|
||||||
|
#
|
||||||
|
%.h : %.class
|
||||||
|
- $(GCJH) --classpath="." $*;
|
||||||
|
- $(RM) $<
|
||||||
|
+ $(GCJH) --classpath="$(java_libs_root):." $*;
|
||||||
|
|
||||||
|
##
|
||||||
|
# targets
|
||||||
|
diff -u -r pdftk-1.41-orig/java_libs/Makefile pdftk-1.41/java_libs/Makefile
|
||||||
|
--- pdftk-1.41-orig/java_libs/Makefile 2006-08-29 08:44:26.000000000 +0200
|
||||||
|
+++ pdftk-1.41/java_libs/Makefile 2009-11-16 15:33:23.000000000 +0100
|
||||||
|
@@ -13,13 +13,7 @@
|
||||||
|
# append gcj flags
|
||||||
|
export GCJFLAGS+= --encoding=UTF-8 --classpath="$(java_libs_root)"
|
||||||
|
|
||||||
|
-all : libgcj_local itext
|
||||||
|
-
|
||||||
|
-libgcj_local :
|
||||||
|
- $(MAKE) -C "$(java_libs_root)/gnu_local/java/security";
|
||||||
|
- $(MAKE) -C "$(java_libs_root)/gnu_local/java/security/provider";
|
||||||
|
- $(MAKE) -C "$(java_libs_root)/gnu/gcj/convert";
|
||||||
|
- $(MAKE) -C "$(java_libs_root)/java_local/security";
|
||||||
|
+all : itext
|
||||||
|
|
||||||
|
itext :
|
||||||
|
$(MAKE) -C "$(java_libs_root)/com/lowagie/text";
|
||||||
|
@@ -35,13 +29,7 @@
|
||||||
|
$(MAKE) -C "$(java_libs_root)/com/lowagie/bc/asn1";
|
||||||
|
$(MAKE) -C "$(java_libs_root)/com/lowagie/text/pdf/codec/postscript";
|
||||||
|
|
||||||
|
-clean : libgcj_local_clean itext_clean
|
||||||
|
-
|
||||||
|
-libgcj_local_clean :
|
||||||
|
- $(MAKE) -iC "$(java_libs_root)/gnu_local/java/security" clean;
|
||||||
|
- $(MAKE) -iC "$(java_libs_root)/gnu_local/java/security/provider" clean;
|
||||||
|
- $(MAKE) -iC "$(java_libs_root)/gnu/gcj/convert" clean;
|
||||||
|
- $(MAKE) -iC "$(java_libs_root)/java_local/security" clean;
|
||||||
|
+clean : itext_clean
|
||||||
|
|
||||||
|
itext_clean :
|
||||||
|
$(MAKE) -iC "$(java_libs_root)/com/lowagie/text" clean;
|
||||||
|
diff -u -r pdftk-1.41-orig/pdftk/Makefile.Base pdftk-1.41/pdftk/Makefile.Base
|
||||||
|
--- pdftk-1.41-orig/pdftk/Makefile.Base 2006-10-25 01:44:06.000000000 +0200
|
||||||
|
+++ pdftk-1.41/pdftk/Makefile.Base 2009-11-16 15:36:00.000000000 +0100
|
||||||
|
@@ -31,18 +31,6 @@
|
||||||
|
afms= $(wildcard $(java_libs_root)/com/lowagie/text/pdf/fonts/*.afm)
|
||||||
|
afm_objects= $(patsubst %.afm, %.o, $(afms))
|
||||||
|
|
||||||
|
-# older versions of libgcj might not have the MD5 algorithm,
|
||||||
|
-# so I added it here; these *_local java files were grabbed from
|
||||||
|
-# libgcj CVS on March 7, 2004; diffed September 5, 2006 w/ gcc 4.1.1
|
||||||
|
-#
|
||||||
|
-# gnu/gcj/convert/Input_UnicodeBig.java was grabbed March 26, 2004; diffed September 5, 2006 w/ gcc 4.1.1
|
||||||
|
-#
|
||||||
|
-libgcj_local_libs = \
|
||||||
|
-$(java_libs_root)/java_local/security/security.a \
|
||||||
|
-$(java_libs_root)/gnu_local/java/security/provider/provider.a \
|
||||||
|
-$(java_libs_root)/gnu_local/java/security/security.a \
|
||||||
|
-$(java_libs_root)/gnu/gcj/convert/convert.a
|
||||||
|
-
|
||||||
|
# this must already be set according to your platform Makefile;
|
||||||
|
# we're just appending to it, here
|
||||||
|
#
|
||||||
|
@@ -63,10 +51,10 @@
|
||||||
|
$(CXX) pdftk.cc -I$(java_libs_root) $(CPPFLAGS) -c
|
||||||
|
|
||||||
|
pdftk : pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects)
|
||||||
|
- $(CXX) pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects) -I$(java_libs_root) $(CPPFLAGS) $(CXXFLAGS) -o pdftk
|
||||||
|
+ $(CXX) pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects) -I$(java_libs_root) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o pdftk
|
||||||
|
|
||||||
|
install:
|
||||||
|
- /usr/bin/install pdftk /usr/local/bin
|
||||||
|
+ /usr/bin/install pdftk $(DESTDIR)$(PREFIX)/bin
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
rm -vf /usr/local/bin/pdftk
|
||||||
|
diff -u -r pdftk-1.41-orig/pdftk/Makefile.Generic pdftk-1.41/pdftk/Makefile.Generic
|
||||||
|
--- pdftk-1.41-orig/pdftk/Makefile.Generic 2006-09-21 19:37:12.000000000 +0200
|
||||||
|
+++ pdftk-1.41/pdftk/Makefile.Generic 2009-11-16 15:35:27.000000000 +0100
|
||||||
|
@@ -10,6 +10,10 @@
|
||||||
|
# Clean: make -f Makefile.Generic clean
|
||||||
|
#
|
||||||
|
|
||||||
|
+# prefixes and destination dir for packaging
|
||||||
|
+PREFIX= /usr/local
|
||||||
|
+DESTDIR=
|
||||||
|
+
|
||||||
|
# tools
|
||||||
|
TOOLPATH=
|
||||||
|
VERSUFF=
|
|
@ -2,7 +2,7 @@
|
||||||
|
|
||||||
# Slackware build script for pdftk
|
# Slackware build script for pdftk
|
||||||
|
|
||||||
# Copyright 2006-2007 Yalla-One <yallaone@gmail.com>
|
# Copyright 2006-2009 Yalla-One <yallaone@gmail.com>
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use of this script, with or without modification, is
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
@ -23,12 +23,15 @@
|
||||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
# Modified by the SlackBuilds.org project
|
# Modified by the SlackBuilds.org project
|
||||||
|
# THANK YOU to Martinezio from LinuxQuestions.org for the patch to make this
|
||||||
|
# work on Slackware64 13.0
|
||||||
|
|
||||||
PRGNAM=pdftk
|
PRGNAM=pdftk
|
||||||
VERSION=1.41
|
VERSION=1.41
|
||||||
ARCH=${ARCH:-i486}
|
ARCH=${ARCH:-i486}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-2}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
CWD=$(pwd)
|
CWD=$(pwd)
|
||||||
TMP=${TMP:-/tmp/SBo}
|
TMP=${TMP:-/tmp/SBo}
|
||||||
PKG=$TMP/package-$PRGNAM
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
@ -50,27 +53,31 @@ case "$ARCH" in
|
||||||
;;
|
;;
|
||||||
esac
|
esac
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
rm -rf $PKG
|
rm -rf $PKG
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
cd $TMP || exit 1
|
cd $TMP
|
||||||
rm -rf $PRGNAM-$VERSION
|
rm -rf $PRGNAM-$VERSION
|
||||||
tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
|
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||||
cd $PRGNAM-$VERSION || exit 1
|
cd $PRGNAM-$VERSION
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
chmod -R a-s,u+w,go+r-w .
|
chmod -R a-s,u+w,go+r-w .
|
||||||
|
|
||||||
|
# Fix build on x86_64
|
||||||
|
patch -p1 <$CWD/pdftk-1.41-slackware64-13.patch
|
||||||
|
|
||||||
|
# Use our SLKCFLAGS
|
||||||
|
patch -p1 < $CWD/pdftk-1.41-add_custom_optflags.patch
|
||||||
|
|
||||||
cd $PRGNAM
|
cd $PRGNAM
|
||||||
CFLAGS="$SLKCFLAGS" \
|
make OPT="$SLKCFLAGS" -f Makefile.Generic
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
mkdir -p $PKG/usr/{bin,man/man1,doc/$PRGNAM-$VERSION}
|
||||||
make -f Makefile.Generic || exit 1
|
cp -a pdftk $PKG/usr/bin
|
||||||
|
strip --strip-unneeded $PKG/usr/bin/pdftk 2> /dev/null
|
||||||
mkdir -p $PKG/usr/{bin,man/man1,doc/$PRGNAM-$VERSION}
|
|
||||||
|
|
||||||
cp -a pdftk $PKG/usr/bin
|
|
||||||
strip --strip-unneeded $PKG/usr/bin/pdftk 2> /dev/null
|
|
||||||
|
|
||||||
cd ..
|
cd ..
|
||||||
cat debian/pdftk.1 | gzip -9c > $PKG/usr/man/man1/pdftk.1.gz
|
|
||||||
|
gzip -9c debian/pdftk.1 > $PKG/usr/man/man1/pdftk.1.gz
|
||||||
cat pdftk.1.txt > $PKG/usr/doc/$PRGNAM-$VERSION/pdftk.1.txt
|
cat pdftk.1.txt > $PKG/usr/doc/$PRGNAM-$VERSION/pdftk.1.txt
|
||||||
cat pdftk.1.html > $PKG/usr/doc/$PRGNAM-$VERSION/pdftk.1.html
|
cat pdftk.1.html > $PKG/usr/doc/$PRGNAM-$VERSION/pdftk.1.html
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
@ -79,4 +86,4 @@ mkdir -p $PKG/install
|
||||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
|
||||||
cd $PKG
|
cd $PKG
|
||||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||||
|
|
|
@ -3,6 +3,8 @@ VERSION="1.41"
|
||||||
HOMEPAGE="http://www.pdfhacks.com/pdftk/"
|
HOMEPAGE="http://www.pdfhacks.com/pdftk/"
|
||||||
DOWNLOAD="http://www.pdfhacks.com/pdftk/pdftk-1.41.tar.bz2"
|
DOWNLOAD="http://www.pdfhacks.com/pdftk/pdftk-1.41.tar.bz2"
|
||||||
MD5SUM="7214230b937dc996d209c05b7b7b3518"
|
MD5SUM="7214230b937dc996d209c05b7b7b3518"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
MAINTAINER="Yalla-One"
|
MAINTAINER="Yalla-One"
|
||||||
EMAIL="yallaone@gmail.com"
|
EMAIL="yallaone@gmail.com"
|
||||||
APPROVED="rworkman"
|
APPROVED="rworkman"
|
||||||
|
|
|
@ -15,5 +15,5 @@ pdftk: with PDF documents. Keep one in the top drawer of your desktop and
|
||||||
pdftk: use it to: Merge PDF documents, split PDF documents, apply watermark,
|
pdftk: use it to: Merge PDF documents, split PDF documents, apply watermark,
|
||||||
pdftk: repair corrupt PDF, update PDF metadata and much more.
|
pdftk: repair corrupt PDF, update PDF metadata and much more.
|
||||||
pdftk: pdftk does not require Acrobat and is free software (GPL)
|
pdftk: pdftk does not require Acrobat and is free software (GPL)
|
||||||
pdftk:
|
pdftk:
|
||||||
pdftk:
|
pdftk:
|
||||||
|
|
Loading…
Reference in a new issue