mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
system/unison: Fix build with OCAML 4.0.
This requires the update of lablgtk which fixed the ld.conf. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
48174e5106
commit
51d72ba0f5
2 changed files with 31 additions and 4 deletions
22
system/unison/01-change-ocamllibdir-for-ocaml-40.patch
Normal file
22
system/unison/01-change-ocamllibdir-for-ocaml-40.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- a/Makefile.OCaml 2011-04-16 17:35:38.000000000 -0300
|
||||
+++ b/Makefile.OCaml 2014-09-25 13:18:43.239151396 -0300
|
||||
@@ -71,8 +71,8 @@ OCAMLLIBDIR=$(shell ocamlc -v | tail -1
|
||||
#
|
||||
# This should be set to an appropriate value automatically, depending
|
||||
# on whether the lablgtk library is available
|
||||
-LABLGTKLIB=$(OCAMLLIBDIR)/lablgtk
|
||||
-LABLGTK2LIB=$(OCAMLLIBDIR)/lablgtk2
|
||||
+LABLGTKLIB=$(OCAMLLIBDIR)/site-lib/lablgtk
|
||||
+LABLGTK2LIB=$(OCAMLLIBDIR)/site-lib/lablgtk2
|
||||
##BCP [3/2007]: Removed temporarily, since the OSX UI is not working well
|
||||
## at the moment and we don't want to confuse people by building it by default
|
||||
ifeq ($(OSARCH),osx)
|
||||
@@ -92,7 +92,7 @@ buildexecutable::
|
||||
|
||||
INCLFLAGS=-I lwt -I ubase -I system
|
||||
CAMLFLAGS+=$(INCLFLAGS)
|
||||
-CAMLFLAGS+=-I system/$(SYSTEM) -I lwt/$(SYSTEM)
|
||||
+CAMLFLAGS+=-I system/$(SYSTEM) -I lwt/$(SYSTEM) -I $(LABLGTK2LIB)
|
||||
|
||||
ifeq ($(OSARCH),win32)
|
||||
# Win32 system
|
|
@ -23,8 +23,8 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=unison
|
||||
VERSION=2.40.63
|
||||
BUILD=${BUILD:-1}
|
||||
VERSION=${VERSION:-2.40.63}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -53,7 +53,12 @@ find -L . \
|
|||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Apply patches
|
||||
for _p in $(ls $CWD/*.patch); do
|
||||
patch -p1 -i $_p
|
||||
done
|
||||
|
||||
# no need to set CFLAGS
|
||||
|
||||
|
@ -73,7 +78,7 @@ make UISTYLE=$FLAVOR DEBUGGING=false THREADS=true NATIVE=true
|
|||
mkdir -p $PKG/usr/bin
|
||||
install -m 0755 $PRGNAM $PKG/usr/bin
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
|
|
Loading…
Reference in a new issue