mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
games/FlightGear: Updated for version 2016.4.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
7438ceeee9
commit
512fdb6235
4 changed files with 6 additions and 45 deletions
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=FlightGear
|
||||
SRCNAM=flightgear
|
||||
VERSION=${VERSION:-2016.3.1}
|
||||
VERSION=${VERSION:-2016.4.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -77,9 +77,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix underlinking (patch thanks to Arch Linux)
|
||||
patch -p1 < $CWD/explicitly-link-with-libX11.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="FlightGear"
|
||||
VERSION="2016.3.1"
|
||||
VERSION="2016.4.3"
|
||||
HOMEPAGE="http://www.flightgear.org/"
|
||||
DOWNLOAD="https://sourceforge.net/projects/flightgear/files/release-2016.3/flightgear-2016.3.1.tar.bz2"
|
||||
MD5SUM="70936a91c80ee18a7dd7ed663c0273e3"
|
||||
DOWNLOAD="https://heanet.dl.sourceforge.net/project/flightgear/release-2016.4/flightgear-2016.4.3.tar.bz2"
|
||||
MD5SUM="a437fff65fc1922b4410c280a78f99f9"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="FlightGear-data SimGear"
|
||||
|
|
|
@ -2,5 +2,5 @@ FlightGear is a flight-simulator created by an international group of
|
|||
volunteers, and released as free, open-source GPL software.
|
||||
It has been used for academic research, education, and for fun.
|
||||
|
||||
To build the internal Qt launcher, you will require QT5 and pass
|
||||
QT5=yes to the script
|
||||
To build the internal Qt launcher, you will require QT5 and libxkbcommon
|
||||
and then pass QT5=yes to the script
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
From 04ca64edc46cfb54ecff5bddf12370b2c7a0f192 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Bellet <fabrice@bellet.info>
|
||||
Date: Tue, 17 Feb 2015 22:49:50 +0100
|
||||
Subject: [PATCH] explicitely link with libX11
|
||||
|
||||
---
|
||||
src/Main/CMakeLists.txt | 1 +
|
||||
utils/fgviewer/CMakeLists.txt | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/Main/CMakeLists.txt b/src/Main/CMakeLists.txt
|
||||
index 12c0961..78c4163 100644
|
||||
--- a/src/Main/CMakeLists.txt
|
||||
+++ b/src/Main/CMakeLists.txt
|
||||
@@ -142,6 +142,7 @@ target_link_libraries(fgfs
|
||||
${SIMGEAR_CORE_LIBRARY_DEPENDENCIES}
|
||||
${SIMGEAR_SCENE_LIBRARY_DEPENDENCIES}
|
||||
${PLATFORM_LIBS}
|
||||
+ ${X11_X11_LIB}
|
||||
)
|
||||
|
||||
if(ENABLE_FLITE)
|
||||
diff --git a/utils/fgviewer/CMakeLists.txt b/utils/fgviewer/CMakeLists.txt
|
||||
index 165be74..065b8f1 100644
|
||||
--- a/utils/fgviewer/CMakeLists.txt
|
||||
+++ b/utils/fgviewer/CMakeLists.txt
|
||||
@@ -48,5 +48,6 @@ target_link_libraries(fgviewer
|
||||
${OPENGL_LIBRARIES}
|
||||
${FGVIEWER_RTI_LIBRARIES}
|
||||
${SIMGEAR_CORE_LIBRARY_DEPENDENCIES}
|
||||
+ ${X11_X11_LIB}
|
||||
)
|
||||
install(TARGETS fgviewer RUNTIME DESTINATION bin)
|
||||
--
|
||||
2.1.0
|
||||
|
Loading…
Reference in a new issue