development/openjdk: Updated for version 7u71b14.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Strahil Yordanov 2015-01-21 06:51:07 +07:00 committed by Willy Sudiarto Raharjo
parent 238c6e3558
commit 50b183f7f3
4 changed files with 57 additions and 21 deletions

View file

@ -0,0 +1,11 @@
--- icedtea-2.5.3/Makefile.am 2014-10-15 06:57:54.000000000 +0300
+++ icedtea-2.5.3.patched/Makefile.am 2015-01-17 22:36:01.000000000 +0200
@@ -242,7 +242,7 @@
# Patch list
-ICEDTEA_PATCHES =
+ICEDTEA_PATCHES = patches/currencyexpire.patch
# Conditional patches

View file

@ -0,0 +1,14 @@
diff -Nru openjdk.orig/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
--- openjdk.orig/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java 2015-01-17 19:19:33.000000000 +0200
+++ openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java 2015-01-17 22:29:32.000000000 +0200
@@ -281,8 +281,8 @@
checkCurrencyCode(newCurrency);
String timeString = currencyInfo.substring(4, length - 4);
long time = format.parse(timeString).getTime();
- if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
- throw new RuntimeException("time is more than 10 years from present: " + time);
+ if (Math.abs(time - System.currentTimeMillis()) > ((long) 20) * 365 * 24 * 60 * 60 * 1000) {
+ throw new RuntimeException("time is more than 20 years from present: " + time);
}
specialCaseCutOverTimes[specialCaseCount] = time;
specialCaseOldCurrencies[specialCaseCount] = oldCurrency;

View file

@ -2,7 +2,7 @@
# Slackware build scripts for OpenJDK
# Copyright 2014 Strahil Yordanov, Sofia, Bulgaria
# Copyright 2015 Strahil Yordanov, Sofia, Bulgaria
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,12 +23,12 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=openjdk
VERSION=${VERSION:-7u60}
VERSION=${VERSION:-7u71b14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
DVER=1.7.0_$(printf $VERSION | cut -du -f2)
ICEDTEA=icedtea-2.5.0
ICEDTEA=icedtea-2.5.3
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@ -58,8 +58,15 @@ rm -rf $BUILD_DIR $PKG
mkdir -p $TMP $BUILD_DIR $PKG $OUTPUT
cd $BUILD_DIR
tar -xvf $CWD/${ICEDTEA}.tar.xz
tar -xvf $CWD/${ICEDTEA}.tar.gz
cd $ICEDTEA
patch Makefile.am $CWD/Makefile.am.patch
cp $CWD/currencyexpire.patch ./patches
aclocal
autoconf
cd ..
mkdir icedtea-build
cd icedtea-build
@ -120,5 +127,9 @@ cp -a $PKG/usr/lib${LIBDIRSUFFIX}/openjdk/{THIRD_PARTY_README,LICENSE,ASSEMBLY_E
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mv $PKG/usr/lib${LIBDIRSUFFIX}/openjdk/man/ $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,22 +1,22 @@
PRGNAM="openjdk"
VERSION="7u60"
VERSION="7u71b14"
HOMEPAGE="http://openjdk.java.net"
DOWNLOAD="http://icedtea.classpath.org/download/source/icedtea-2.5.0.tar.xz \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/openjdk.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/corba.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/jaxp.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/jaxws.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/jdk.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/langtools.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5/hotspot.tar.bz2"
MD5SUM="a14305c61f704b33369c433955572362 \
5a32302cc14e7bb113d399bc9a017b23 \
bfcdcf4d91e511056fc81a0d771fbdff \
34ce2eab91aaba3efb500a3b02051cca \
590460868b1c4911d3f57c4f5a80ecc7 \
2f2e28645f2203576d416115d5cdbd85 \
83a383d30ebc7edaa857430ec997091b \
964b7e610177db849dbe0b2483a564a1"
DOWNLOAD="http://icedtea.classpath.org/download/source/icedtea-2.5.3.tar.gz \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/openjdk.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/corba.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/jaxp.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/jaxws.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/jdk.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/hotspot.tar.bz2 \
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/langtools.tar.bz2"
MD5SUM="dfd8f5f356a5fc05e63bb38e7c4c030a \
730679eec8f645c05c0c518ae73a6f6d \
b7dbab5f1ca314d613a9e7cf0a5939e1 \
40e6d2e0e6b35a671bf1b0908c63ef9d \
1615b1c82ac6a189d6805eedb8692402 \
7cc129b8ff8f195583cf40620588e013 \
e58128728b81b99bf94d9cac39015975 \
fd28b781a95a609cd966c7048486e4ca"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="apache-ant"