libraries/pyftpdlib: Updated for version 1.5.1.

Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
Dimitris Zlatanidis 2016-07-09 15:46:24 +03:00 committed by Willy Sudiarto Raharjo
parent 4436f930ac
commit 4f9e9a32f2
No known key found for this signature in database
GPG key ID: 887B8374D7333381
4 changed files with 32 additions and 9 deletions

View file

@ -6,5 +6,3 @@ available for Python programming language.
It is used in projects like Google Chromium and Bazaar and included in Linux
Fedora and FreeBSD package repositories.
*Optional dependences: pysendfile (module to speedup transfers)

View file

@ -2,7 +2,7 @@
# Slackware build script for pyftpdlib
# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -22,9 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyftpdlib
VERSION=${VERSION:-1.4.0}
VERSION=${VERSION:-1.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -68,7 +67,10 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix setup install messages
patch -p1 < $CWD/setup.patch
python setup.py install --root=$PKG

View file

@ -1,8 +1,8 @@
PRGNAM="pyftpdlib"
VERSION="1.4.0"
VERSION="1.5.1"
HOMEPAGE="http://code.google.com/p/pyftpdlib/"
DOWNLOAD="https://pypi.python.org/packages/source/p/pyftpdlib/pyftpdlib-1.4.0.tar.gz"
MD5SUM="5aeda8287f4e5ba263e48a79f2a246fd"
DOWNLOAD="https://pypi.python.org/packages/a8/f8/0f6db156898616dbcbd7bf865660295c81479071ab0fcd1898fe1b3a4fc4/pyftpdlib-1.5.1.tar.gz"
MD5SUM="61b23e2362df23d0dfa5fe76f6e2ab55"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysendfile pyOpenSSL"

View file

@ -0,0 +1,23 @@
--- pyftpdlib-1.5.1/setup.orig 2016-07-09 15:38:35.715719570 +0300
+++ pyftpdlib-1.5.1/setup.py 2016-07-09 15:40:26.852330171 +0300
@@ -134,9 +134,7 @@
except ImportError:
msg = textwrap.dedent("""
'pysendfile' third-party module is not installed. This is not
- essential but it considerably speeds up file transfers.
- You can install it with 'pip install pysendfile'.
- More at: https://github.com/giampaolo/pysendfile""")
+ essential but it considerably speeds up file transfers'.""")
print(hilite(msg, ok=False), file=sys.stderr)
try:
@@ -144,8 +142,7 @@
except ImportError:
msg = textwrap.dedent("""
'pyopenssl' third-party module is not installed. This means
- FTPS support will be disabled. You can install it with:
- 'pip install pyopenssl'.""")
+ FTPS support will be disabled'.""")
print(hilite(msg, ok=False), file=sys.stderr)