mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
development/ocaml: Updated for version 3.12.1.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
c77efa0419
commit
4f9a8266f9
5 changed files with 35 additions and 21 deletions
|
@ -1,8 +1,9 @@
|
|||
Caml is a general-purpose programming language, designed with program safety
|
||||
and reliability in mind. It is very expressive, yet easy to learn and use.
|
||||
Caml supports functional, imperative, and object-oriented programming styles.
|
||||
The Objective Caml system is the main implementation of the Caml language.
|
||||
It features a powerful module system and a full-fledged object-oriented layer.
|
||||
It comes with a native-code compiler that supports numerous architectures, for
|
||||
high performance; a bytecode compiler, for increased portability; and an
|
||||
interactive loop, for experimentation and rapid development.
|
||||
Caml is a general-purpose programming language, designed with program
|
||||
safety and reliability in mind. It is very expressive, yet easy to learn
|
||||
and use. Caml supports functional, imperative, and object-oriented
|
||||
programming styles. The Objective Caml system is the main implementation
|
||||
of the Caml language. It features a powerful module system and a
|
||||
full-fledged object-oriented layer. It comes with a native-code
|
||||
compiler that supports numerous architectures, for high performance;
|
||||
a bytecode compiler, for increased portability; and an interactive loop,
|
||||
for experimentation and rapid development.
|
||||
|
|
13
development/ocaml/configure.patch
Normal file
13
development/ocaml/configure.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- configure.orig 2011-07-04 23:15:01.000000000 +0200
|
||||
+++ configure 2011-11-05 15:17:01.946744829 +0100
|
||||
@@ -1600,6 +1600,10 @@
|
||||
nativecccompopts="$nativecccompopts -fomit-frame-pointer";;
|
||||
esac
|
||||
|
||||
+# Add additional flags from the environment
|
||||
+bytecccompopts="$bytecccompopts $CFLAGS"
|
||||
+nativecccompopts="$nativecccompopts $CFLAGS"
|
||||
+
|
||||
# Finish generated files
|
||||
|
||||
cclibs="$cclibs $mathlib"
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for ocaml
|
||||
|
||||
# Copyright 2007-2009 Ferenc Deak <ferenc.deak@gmail.com>
|
||||
# Copyright 2007-2011 Ferenc Deak <ferenc.deak@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,16 +23,14 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=ocaml
|
||||
VERSION=3.11.1
|
||||
VERSION=3.12.1
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -67,14 +65,13 @@ cd $PRGNAM-$VERSION
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
./configure \
|
||||
patch < $CWD/configure.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" ./configure \
|
||||
--prefix /usr \
|
||||
--libdir /usr/lib${LIBDIRSUFFIX}/ocaml \
|
||||
--host $ARCH-slackware-linux
|
||||
|
||||
sed -i -e "s/\\(BYTECCCOMPOPTS=.*\\)/\\1 ${SLKCFLAGS}/" config/Makefile
|
||||
sed -i -e "s/\\(NATIVECCCOMPOPTS=.*\\)/\\1 ${SLKCFLAGS}/" config/Makefile
|
||||
|
||||
make world.opt
|
||||
make install \
|
||||
PREFIX=$PKG/usr \
|
||||
|
@ -88,6 +85,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
|
|||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a Changes INSTALL LICENSE README README.win32 Upgrading VERSION \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/ocaml-3.12-refman.html > $PKG/usr/doc/$PRGNAM-$VERSION/ocaml-refman.html
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,10 +1,12 @@
|
|||
PRGNAM="ocaml"
|
||||
VERSION="3.11.1"
|
||||
VERSION="3.12.1"
|
||||
HOMEPAGE="http://caml.inria.fr"
|
||||
DOWNLOAD="http://caml.inria.fr/pub/distrib/ocaml-3.11/ocaml-3.11.1.tar.bz2"
|
||||
MD5SUM="fe011781f37f6b41fe08e0706969a89e"
|
||||
DOWNLOAD="http://caml.inria.fr/pub/distrib/ocaml-3.12/ocaml-3.12.1.tar.bz2 \
|
||||
http://caml.inria.fr/pub/distrib/ocaml-3.12/ocaml-3.12-refman.html"
|
||||
MD5SUM="227a3daaedb150bf5037a3db01f5bf42 \
|
||||
dbefdc669251e67a6b6fdd28fb6c8777"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Ferenc Deak"
|
||||
EMAIL="ferenc.deak@gmail.com"
|
||||
APPROVED="dsomero"
|
||||
APPROVED="dsomero,Niels Horn"
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
ocaml: ocaml (A functional programming language)
|
||||
ocaml:
|
||||
ocaml:
|
||||
ocaml: Caml is a general-purpose programming language, designed with program
|
||||
ocaml: safety and reliability in mind. It is very expressive, yet easy to
|
||||
ocaml: learn and use. Caml supports functional, imperative, and
|
||||
|
|
Loading…
Reference in a new issue