mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/CSparse: Updated for version 2.2.5.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
cece546129
commit
4f98c71e04
3 changed files with 42 additions and 12 deletions
|
@ -4,7 +4,7 @@
|
|||
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||
|
||||
PRGNAM=CSparse
|
||||
VERSION=${VERSION:-2.2.4}
|
||||
VERSION=${VERSION:-2.2.5}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -37,6 +37,9 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
# Recommended by SuiteSparse
|
||||
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
|
@ -52,14 +55,16 @@ patch -p1 < $CWD/autotoolize.diff
|
|||
autoreconf -vif
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="CSparse"
|
||||
VERSION="2.2.4"
|
||||
VERSION="2.2.5"
|
||||
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CSparse/"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/CSparse/versions/CSparse-2.2.4.tar.gz"
|
||||
MD5SUM="99b02361ba0083427ef16ca9610b7e76"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/CSparse/versions/CSparse-2.2.5.tar.gz"
|
||||
MD5SUM="74da840c9de1312e5575d0b21b00b12e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Kyle Guinn"
|
||||
|
|
|
@ -49,16 +49,23 @@ new file mode 100644
|
|||
+ -./cs_demo2 < ../Matrix/bcsstk16
|
||||
+ -./cs_demo3 < ../Matrix/bcsstk01
|
||||
+ -./cs_demo3 < ../Matrix/bcsstk16
|
||||
diff --git a/Include/Makefile.am b/Include/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Include/Makefile.am
|
||||
@@ -0,0 +1,2 @@
|
||||
+pkgincludedir = $(includedir)/csparse
|
||||
+pkginclude_HEADERS = cs.h
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,5 @@
|
||||
+SUBDIRS = Source Matrix Demo
|
||||
+SUBDIRS = Include Source Matrix Demo
|
||||
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
|
||||
+
|
||||
+pkgincludedir = $(includedir)/csparse
|
||||
+pkginclude_HEADERS = Include/cs.h
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = csparse.pc
|
||||
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
|
@ -141,14 +148,14 @@ new file mode 100644
|
|||
+lib_LTLIBRARIES = libcsparse.la
|
||||
+libcsparse_la_SOURCES = $(CSPARSESRC)
|
||||
+libcsparse_la_LIBADD = -lm
|
||||
+libcsparse_la_LDFLAGS = -no-undefined -version-info 4:4:2
|
||||
+libcsparse_la_LDFLAGS = -no-undefined -version-info 4:5:2
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,30 @@
|
||||
+AC_PREREQ([2.65])
|
||||
+AC_INIT([CSparse], [2.2.4], [davis@cise.ufl.edu])
|
||||
@@ -0,0 +1,32 @@
|
||||
+AC_PREREQ([2.68])
|
||||
+AC_INIT([CSparse],[2.2.5],[davis@cise.ufl.edu])
|
||||
+AC_CONFIG_SRCDIR([Source/cs_print.c])
|
||||
+AC_CONFIG_HEADER([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
|
@ -172,8 +179,26 @@ new file mode 100644
|
|||
+LIBS=$LIBS_SAVED
|
||||
+
|
||||
+AC_CONFIG_FILES([
|
||||
+ csparse.pc
|
||||
+ Makefile
|
||||
+ Demo/Makefile
|
||||
+ Include/Makefile
|
||||
+ Matrix/Makefile
|
||||
+ Source/Makefile])
|
||||
+AC_OUTPUT
|
||||
diff --git a/csparse.pc.in b/csparse.pc.in
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/csparse.pc.in
|
||||
@@ -0,0 +1,11 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: @PACKAGE_NAME@
|
||||
+Description: A concise sparse matrix package
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Libs: -L${libdir} -lcsparse
|
||||
+Libs.private: -lm
|
||||
+Cflags: -I${includedir}/csparse
|
||||
|
|
Loading…
Reference in a new issue