mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
python/python-magick: Updated for version 0.9.12.
This should compile with latest boost. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
2b8be947c3
commit
4e3dfee60a
5 changed files with 6 additions and 64 deletions
|
@ -1,13 +0,0 @@
|
|||
diff -Naur PythonMagick-0.9.8.orig/PythonMagick/__init__.py PythonMagick-0.9.8/PythonMagick/__init__.py
|
||||
--- PythonMagick-0.9.8.orig/PythonMagick/__init__.py 2012-01-25 21:03:38.000000000 +0100
|
||||
+++ PythonMagick-0.9.8/PythonMagick/__init__.py 2012-09-20 06:04:26.032241745 +0200
|
||||
@@ -1,7 +1,5 @@
|
||||
-from . import _PythonMagick
|
||||
-
|
||||
-class Image(_PythonMagick.Image):
|
||||
- pass
|
||||
+import PythonMagick._PythonMagick as _PythonMagick
|
||||
+from PythonMagick._PythonMagick import *
|
||||
|
||||
class Blob(_PythonMagick.Blob):
|
||||
def __init__(self,*args):
|
|
@ -1,21 +0,0 @@
|
|||
--- m4/ax_python.m4
|
||||
+++ m4/ax_python.m4
|
||||
@@ -58,13 +58,14 @@
|
||||
AC_DEFUN([AX_PYTHON],
|
||||
[AC_MSG_CHECKING(for python build information)
|
||||
AC_MSG_RESULT([])
|
||||
-for python in python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
|
||||
+for python in python python2.6 python2.5 python2.4 python2.3 python2.2 python2.1; do
|
||||
AC_CHECK_PROGS(PYTHON_BIN, [$python])
|
||||
ax_python_bin=$PYTHON_BIN
|
||||
if test x$ax_python_bin != x; then
|
||||
- AC_CHECK_LIB($ax_python_bin, main, ax_python_lib=$ax_python_bin, ax_python_lib=no)
|
||||
- AC_CHECK_HEADER([$ax_python_bin/Python.h],
|
||||
- [[ax_python_header=`locate $ax_python_bin/Python.h | sed -e s,/Python.h,,`]],
|
||||
+ [python_version=`$ax_python_bin -c 'import sys; print(".".join(str(x) for x in sys.version_info[:2]))'`]
|
||||
+ AC_CHECK_LIB(python$python_version, main, ax_python_lib=python$python_version, ax_python_lib=no)
|
||||
+ AC_CHECK_HEADER([python$python_version/Python.h],
|
||||
+ [[ax_python_header=`locate python$python_version/Python.h | sed -e s,/Python.h,,`]],
|
||||
ax_python_header=no)
|
||||
if test $ax_python_lib != no; then
|
||||
if test $ax_python_header != no; then
|
|
@ -1,11 +0,0 @@
|
|||
--- m4/ax_python.m4
|
||||
+++ m4/ax_python.m4
|
||||
@@ -65,7 +65,7 @@
|
||||
[python_version=`$ax_python_bin -c 'import sys; print(".".join(str(x) for x in sys.version_info[:2]))'`]
|
||||
AC_CHECK_LIB(python$python_version, main, ax_python_lib=python$python_version, ax_python_lib=no)
|
||||
AC_CHECK_HEADER([python$python_version/Python.h],
|
||||
- [[ax_python_header=`locate python$python_version/Python.h | sed -e s,/Python.h,,`]],
|
||||
+ [[ax_python_header=`$ax_python_bin -c 'import sys; print(sys.prefix + "/include/python%s.%s" % sys.version_info[:2])'`]],
|
||||
ax_python_header=no)
|
||||
if test $ax_python_lib != no; then
|
||||
if test $ax_python_header != no; then
|
|
@ -23,8 +23,8 @@
|
|||
|
||||
PRGNAM=python-magick
|
||||
SRCNAM=PythonMagick
|
||||
VERSION=${VERSION:-0.9.8}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-0.9.12}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -56,7 +56,7 @@ fi
|
|||
|
||||
DOCS="ChangeLog LICENSE README"
|
||||
|
||||
set -e
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
|
@ -71,19 +71,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Provide all objects in PythonMagick
|
||||
patch -p1 < $CWD/patches/__init__-fixup
|
||||
|
||||
# Use the default python on the system and fix detection of the python
|
||||
# include dir (thanks Gentoo)
|
||||
patch -p0 < $CWD/patches/pythonmagick-0.9.1-use_active_python_version.patch
|
||||
patch -p0 < $CWD/patches/pythonmagick-0.9.2-fix_detection_of_python_includedir.patch
|
||||
|
||||
# We have 1.11.5 so it must suffice
|
||||
sed -i "s|1\.12|1.11.5|" configure.ac
|
||||
|
||||
autoreconf -fi
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="python-magick"
|
||||
VERSION="0.9.8"
|
||||
VERSION="0.9.12"
|
||||
HOMEPAGE="http://www.imagemagick.org"
|
||||
DOWNLOAD="http://www.imagemagick.org/download/python/releases/PythonMagick-0.9.8.tar.xz"
|
||||
MD5SUM="0b4c66c7f1e7785fa262e75526e1b46b"
|
||||
DOWNLOAD="http://www.imagemagick.org/download/python/releases/PythonMagick-0.9.12.tar.xz"
|
||||
MD5SUM="5fd807d1468c2d9b798a1e7de2040ba2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue