mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
games/ggmud: Added (console MUD client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
508c3af024
commit
4cd63afd3e
9 changed files with 178 additions and 0 deletions
5
games/ggmud/README
Normal file
5
games/ggmud/README
Normal file
|
@ -0,0 +1,5 @@
|
|||
GGMud is a terminal-based MUD/MOO/MUSH client designed to be light, extensible, and portable. It
|
||||
includes a custom scripting language which supports event triggers, timers, macros, aliases, speed
|
||||
walking, varibles and if clauses, Connection Wizard with auto login, among other features. It uses
|
||||
Lua as an external scripting language. GGMud supports MCCP (Mud Client Compression Protocol),
|
||||
support for 4/5 proxies, ANSI 16 colors, and MUD TELNET emulation.
|
3
games/ggmud/doinst.sh
Normal file
3
games/ggmud/doinst.sh
Normal file
|
@ -0,0 +1,3 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
9
games/ggmud/ggmud-link.diff
Normal file
9
games/ggmud/ggmud-link.diff
Normal file
|
@ -0,0 +1,9 @@
|
|||
diff -rupN ./CMakeLists.txt ./CMakeLists.txt
|
||||
--- ./CMakeLists.txt 2015-09-26 02:34:29.547077049 -0700
|
||||
+++ ./CMakeLists.txt 2015-09-25 22:58:00.000000000 -0700
|
||||
@@ -65,4 +65,4 @@ add_executable(ggmud WIN32 alias.c ansi.
|
||||
${ADDITIONAL_SOURCES}
|
||||
)
|
||||
|
||||
-target_link_libraries(ggmud tt lua sq3 httpfetch zlib ${GTK2_LIBRARIES} ${ADDITIONAL_LIBS} ${GTHREAD_LIBRARIES})
|
||||
+target_link_libraries(ggmud tt lua sq3 httpfetch zlib dl m ${GTK2_LIBRARIES} ${ADDITIONAL_LIBS} ${GTHREAD_LIBRARIES})
|
120
games/ggmud/ggmud.SlackBuild
Normal file
120
games/ggmud/ggmud.SlackBuild
Normal file
|
@ -0,0 +1,120 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for ggmud
|
||||
# Copyright 2015 Eric Underhill <uhillem@gmail.com>
|
||||
#
|
||||
# Based on slackbuild by Michael Bueker <m.bueker@berlin.de>
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=ggmud
|
||||
VERSION=${VERSION:-0.9.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
# For those of you that don't install anything to /opt, be sure to change
|
||||
# the symlink creation line in doinst.sh to match to the location defined
|
||||
# here if changed.
|
||||
OPT=${OPT:-/opt}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar -xzvf $CWD/$PRGNAM-$VERSION-src.tgz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Apply patch so everything will link correctly.
|
||||
#cp $CWD/ggmud-link.diff $TMP/$PRGNAM-$VERSION
|
||||
patch -p0 < $CWD/ggmud-link.diff
|
||||
|
||||
mkdir build && cd build
|
||||
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_BUILD_TYPE="release" \
|
||||
..
|
||||
make
|
||||
# make install DESTDIR=$PKG
|
||||
# No make install exists for this application. Must do it manually.
|
||||
# Because ggmud expects it's conf files to be in the same directory as
|
||||
# itself, it is best to install to /opt/ggmud to keep it's files together
|
||||
# and to keep from cluttering up /usr/bin with non binaries.
|
||||
mkdir -p $PKG/$OPT/$PRGNAM
|
||||
cp $TMP/$PRGNAM-$VERSION/build/$PRGNAM $PKG/$OPT/$PRGNAM
|
||||
cp $TMP/$PRGNAM-$VERSION/gg_help.txt $PKG/$OPT/$PRGNAM
|
||||
cp $TMP/$PRGNAM-$VERSION/leu/* $PKG/$OPT/$PRGNAM
|
||||
cd -
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
(
|
||||
mkdir -p $PKG/usr/bin
|
||||
cd $PKG/usr/bin
|
||||
ln -s /opt/ggmud/ggmud .
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/share/{applications,pixmaps}
|
||||
cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/
|
||||
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
|
||||
cp $TMP/$PRGNAM-$VERSION/pixmaps/* $PKG/usr/share/pixmaps/
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
12
games/ggmud/ggmud.desktop
Normal file
12
games/ggmud/ggmud.desktop
Normal file
|
@ -0,0 +1,12 @@
|
|||
[Desktop Entry]
|
||||
Comment=a MUD/MOO/MUSH terminal client
|
||||
Comment[fr_FR]=un terminal client de MUD/MOO/MUSH
|
||||
Exec=ggmud
|
||||
GenericName=MUD terminal client
|
||||
GenericName[fr_FR]=terminal client de MUD
|
||||
Icon=ggmud.png
|
||||
Name=ggmud
|
||||
StartupNotify=true
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Game
|
10
games/ggmud/ggmud.info
Normal file
10
games/ggmud/ggmud.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="ggmud"
|
||||
VERSION="0.9.3"
|
||||
HOMEPAGE="www.ggsoft.org/ggmud/index.html"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/ggmud/ggmud-0.9.3-src.tgz"
|
||||
MD5SUM="b07b984f2286ff76def2bdd6016eabb5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Eric Underhill"
|
||||
EMAIL="uhillem@gmail.com"
|
BIN
games/ggmud/ggmud.png
Normal file
BIN
games/ggmud/ggmud.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 1.9 KiB |
BIN
games/ggmud/icon.png
Normal file
BIN
games/ggmud/icon.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 3.1 KiB |
19
games/ggmud/slack-desc
Normal file
19
games/ggmud/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
ggmud: ggmud (console MUD client)
|
||||
ggmud:
|
||||
ggmud: GGMud is a lightweight terminal based MUD client. It supports a host
|
||||
ggmud: of expected features expected from a modern MUD client including
|
||||
ggmud: triggers, aliases, gags, highlights, macros, support for external Lua
|
||||
ggmud: scripting language, and support for Tintin commands. Based on ZMud,
|
||||
ggmud: SClient, and TinTin++.
|
||||
ggmud:
|
||||
ggmud: home: http://www.ggsoft.org/ggmud/index.html
|
||||
ggmud:
|
||||
ggmud: online manual: http://www.ggsoft.org/ggmud/doc/index.html
|
Loading…
Reference in a new issue