mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-25 10:03:03 +01:00
graphics/ocropus: Removed (no SBo maintainer)
Nothing else in the repo needs this, so there's not any good reason for us to continue carrying it. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
fe59227d7a
commit
4c6ef1f89d
5 changed files with 0 additions and 151 deletions
|
@ -1,10 +0,0 @@
|
|||
OCRopus is a state-of-the-art document analysis and OCR system, featuring
|
||||
pluggable layout analysis, pluggable character recognition, statistical
|
||||
natural language modeling, and multi-lingual capabilities.
|
||||
|
||||
The system is being developed with the generous support from Google and
|
||||
other organizations; the primary developers are at the IUPR Research
|
||||
Group at the DFKI Research Center.
|
||||
|
||||
Note: the tarball of the sources is nearly 400 megs, so be patient when
|
||||
downloading/building.
|
|
@ -1,15 +0,0 @@
|
|||
See https://code.google.com/p/ocropus/issues/detail?id=365
|
||||
|
||||
diff -Naur ocropus-20120920.orig/ocropy/setup.py ocropus-20120920/ocropy/setup.py
|
||||
--- ocropus-20120920.orig/ocropy/setup.py 2012-09-20 06:48:34.000000000 +0200
|
||||
+++ ocropus-20120920/ocropy/setup.py 2012-09-20 11:16:24.784307573 +0200
|
||||
@@ -4,6 +4,9 @@
|
||||
from distutils.core import setup, Extension, Command
|
||||
from distutils.command.install_data import install_data
|
||||
|
||||
+import matplotlib
|
||||
+matplotlib.use('Agg')
|
||||
+
|
||||
from ocrolib import default
|
||||
modeldir = "models/"
|
||||
modelfiles = default.installable
|
|
@ -1,97 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for OCROpus.
|
||||
|
||||
# Copyright 2010 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=ocropus
|
||||
VERSION=${VERSION:-0.6_20120920}
|
||||
SRCVER=${SRCVER:-20120920}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$SRCVER
|
||||
tar xvf $CWD/$PRGNAM-$SRCVER.tar.?z*
|
||||
cd $PRGNAM-$SRCVER
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# We don't need a DISPLAY, we're just packaging
|
||||
patch -p1 < $CWD/no_display.patch
|
||||
|
||||
# Fix some paths
|
||||
sed -i "s|/usr/local/share|/usr/share|" \
|
||||
ocropy/Notebooks/ocropus-steps.ipynb \
|
||||
ocropy/ocrolib/default.py \
|
||||
ocropy/ocrolib/common.py
|
||||
|
||||
( cd ocropy
|
||||
python setup.py install --root=$PKG )
|
||||
|
||||
# move models in a subfolder
|
||||
mkdir -p $PKG/usr/share/models
|
||||
mv $PKG/usr/share/$PRGNAM/* $PKG/usr/share/models
|
||||
mv $PKG/usr/share/models $PKG/usr/share/$PRGNAM/
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a fraktur-boxes historic-newspaper uw3-500 $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="ocropus"
|
||||
VERSION="0.6_20120920"
|
||||
HOMEPAGE="https://code.google.com/p/ocropus/"
|
||||
DOWNLOAD="http://ponce.cc/slackware/sources/repo/ocropus-20120920.tar.xz"
|
||||
MD5SUM="a61133bdb989e4a812dd130024830c0f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="matplotlib pytables python-magick scipy"
|
||||
MAINTAINER="Pierre Cazenave"
|
||||
EMAIL="pwcazenave < at > gmail {dot} com"
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
ocropus: OCRopus (document analysis and OCR system)
|
||||
ocropus:
|
||||
ocropus: OCRopus(tm) is a state-of-the-art document analysis and OCR system
|
||||
ocropus: featuring pluggable layout analysis, pluggable character recognition,
|
||||
ocropus: statistical natural language modeling, and multi-lingual capabilities.
|
||||
ocropus:
|
||||
ocropus: The system is being developed with the generous support from Google
|
||||
ocropus: and other organizations; the primary developers are at the IUPR
|
||||
ocropus: Research Group at the DFKI Research Center.
|
||||
ocropus:
|
||||
ocropus: https://code.google.com/p/ocropus/
|
Loading…
Reference in a new issue