libraries/SimGear: Updated for version 2020.3.2.

Signed-off-by: Dave Woodfall <dave@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Lenard Spencer 2020-11-14 05:06:01 +00:00 committed by Willy Sudiarto Raharjo
parent 88d3ff0d15
commit 4c3f59a471
No known key found for this signature in database
GPG key ID: 3F617144D7238786
5 changed files with 9 additions and 63 deletions

View file

@ -1,6 +1,3 @@
SimGear is a set of open-source libraries designed to be used as building
blocks for quickly assembling 3d simulations, games, and visualization
applications.
For those wanting to build this in current (15.0 EXPERIMENTAL), pass
CURRENT=yes to the script.
SimGear is a set of open-source libraries designed to be used as
building blocks for quickly assembling 3d simulations, games, and
visualization applications.

View file

@ -1,29 +0,0 @@
diff -Naur simgear-2020.1.2/CMakeLists.txt simgear-2020.1.2.new/CMakeLists.txt
--- simgear-2020.1.2/CMakeLists.txt 2020-05-24 11:13:35.000000000 -0400
+++ simgear-2020.1.2.new/CMakeLists.txt 2020-06-01 09:36:21.608814301 -0400
@@ -43,13 +43,13 @@
set(CMAKE_CXX_STANDARD_REQUIRED YES)
# read 'version' file into a variable (stripping any newlines or spaces)
-file(READ version versionFile)
+file(READ simgear-version versionFile)
string(STRIP ${versionFile} SIMGEAR_VERSION)
project(SimGear VERSION ${SIMGEAR_VERSION} LANGUAGES C CXX)
# add a dependency on the version file
-set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS version)
+set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS simgear-version)
set_property(GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS TRUE)
diff -Naur simgear-2020.1.2/simgear-version simgear-2020.1.2.new/simgear-version
--- simgear-2020.1.2/simgear-version 1969-12-31 19:00:00.000000000 -0500
+++ simgear-2020.1.2.new/simgear-version 2020-05-24 11:13:36.000000000 -0400
@@ -0,0 +1 @@
+2020.1.2
diff -Naur simgear-2020.1.2/version simgear-2020.1.2.new/version
--- simgear-2020.1.2/version 2020-05-24 11:13:36.000000000 -0400
+++ simgear-2020.1.2.new/version 1969-12-31 19:00:00.000000000 -0500
@@ -1 +0,0 @@
-2020.1.2

View file

@ -3,6 +3,7 @@
# Copyright before version 2016.3.1 by Diego Pantano <poplin.dp@gmail.com>
# Copyright 2016-2018 Panagiotis Nikolaou, Culver City, CA
# Copyright 2020 Lenard Spencer, Orlando, Florida, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -24,7 +25,7 @@
PRGNAM=SimGear
SRCNAM=simgear
VERSION=${VERSION:-2020.1.2}
VERSION=${VERSION:-2020.3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -70,22 +71,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Option to build on -current
if [ "${CURRENT:-no}" = "yes" ]; then
BOOSTOPT="-DBoost_NO_BOOST_CMAKE=ON"
# patch for the new boost:
patch -p1 < $CWD/simgear-enable-if.patch
# Thanks Gentoo for this one
patch -p1 < $CWD/SimGear-version.patch
else
BOOSTOPT=""
fi
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -fpermissive" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSIMGEAR_SHARED=ON \
-DSYSTEM_EXPAT=ON \

View file

@ -1,8 +1,8 @@
PRGNAM="SimGear"
VERSION="2020.1.2"
VERSION="2020.3.2"
HOMEPAGE="http://wiki.flightgear.org/SimGear"
DOWNLOAD="https://downloads.sourceforge.net/flightgear/simgear-2020.1.2.tar.bz2"
MD5SUM="72b30525f3c9f538535574403ea3d4ab"
DOWNLOAD="https://downloads.sourceforge.net/flightgear/simgear-2020.3.2.tar.bz2"
MD5SUM="a88945b4823d2387dd6985fd8f7d505d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="OpenSceneGraph freealut plib"

View file

@ -1,12 +0,0 @@
diff --git a/simgear/nasal/cppbind/NasalHash.hxx b/simgear/nasal/cppbind/NasalHash.hxx
index aac672fd..2ee7d044 100644
--- a/simgear/nasal/cppbind/NasalHash.hxx
+++ b/simgear/nasal/cppbind/NasalHash.hxx
@@ -23,6 +23,7 @@
#include "to_nasal.hxx"
#include <simgear/structure/map.hxx>
+#include <boost/core/enable_if.hpp>
#include <boost/iterator/iterator_facade.hpp>
namespace nasal